VirtualBox

Ticket #1794 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Host hibernation hang after runing Virtual Box with enabled VT-x -> fixed in SVN/2.2

Reported by: zoltanf Owned by:
Priority: critical Component: VMM/HWACCM
Version: VirtualBox 2.1.4 Keywords: hibernation VT-x
Cc: Guest type: other
Host type: other

Description

Similar to ticket #1408.

Host PC: Notebook HP 9710p, Intel Core 2 duo processor, Windows XP Professional SP3, latest version of Virtual Box (1.6.2).

If any guest machine is run with hardware virtualization on (VT-x/AMD-V enabled), the host PC fails to enter hibernation (even after shutting down all of the guest machines and closing Virtual Box). The symptoms are: Start > Shutdown, hibernate, the OS displays "Preparing to hibernate... " message, then the screen goes black and nothing happens. I tried to wait for 15 minutes and nothing happened, only thing to do at this moment is to power off the notebook and power on again.

If the guest machines are run using software virtualisation only (VT-x/AMD-V disabled) everything works fine, and the host PC is able to hibernate.

Tried with different guest machines, Windows XP SP2, Ubuntu, etc., all behaving the same way.

Change History

comment:1 Changed 6 years ago by xcl

same issue: dell d630, vbox 1.6.2, xp sp3 host with xp sp1 guest. another ticket:  http://www.virtualbox.org/ticket/1408 so i think bug appears not only with 1.6.2

on the same machine with sp2 nad vbox 1.4.x (maybe 1.4.6) everything worked great.

comment:2 Changed 6 years ago by sandervl73

Can you check if there's a bios update available for your systems? After shutting down VBox completely, it shouldn't have any effect on hibernation. Hibernating the system while VBox is running could indeed cause troubles.

comment:3 Changed 6 years ago by zoltanf

No bios update is available for my notebook.

I know that shutting down VBox completely should not have any affect on the system and hibernation latter, but it does. Virtual PC works with hardware virtualization, and does not have this side effect.

Best regards, hope we can fix the problem!

comment:4 Changed 6 years ago by frank

  • Keywords hibernation added; host hibernate failure removed
  • Component changed from other to VMM/HWACCM

comment:5 Changed 6 years ago by zoltanf

Tested on Virtual Box 2.0 and the problem still exists.

comment:6 Changed 5 years ago by dosboss

I run into the same issue on a Lenovo ThinkPad T60p. The laptop is equipped with 2GB Ram, a Intel Core Duo Processor and had the latest BIOS update (Sep 2008).

I noticed the issue first with VBox 1.6.6 and XP SP2. After running VBox the PC fails to hibernate. The screen goes blank but nothing happens anymore (as described above). I tried to upgrade to SP3 but the symptom did not change. Even with VBox 2.0.4 i have still the same issue.

Hibernation works well if i do not run VBox or if i run VBox machines with VT-x disabled.

comment:7 Changed 5 years ago by zoltanf

Same problem still exists with Virtual Box latest version, 2.1.2.

Noticed someting new: If I run the Virtual Box, with Hardware virtualisation enabled, and then close Virtual Box and all runing machines, the system will not go to hibernation (same issue as described above). But, if I do a system standby after closing Virtual Box, and all Virtual Machines, then start the system again, then do a hibernate, everything works ok.

So:

  • Run Vbox and VM with enabled HW Virtulisation, close everything, hibernate the host system = fail
  • Run Vbox and VM with enabled HW Virtualisation, close everything, standby the host sistem, restore the host sistem, hibernate the host sistem = everything ok

comment:8 Changed 5 years ago by Graham Norris

I've had this problem on a Thinkpad T61p (XP Pro SP3 host, Windows or Linux guest) for some time, and finally found this bug. zoltanf's workaround appears to work for me too, as does disabling hardware virtualization.

comment:9 follow-up: ↓ 10 Changed 5 years ago by prozema

I am also running into this same issue on a Dell Latitude D620 (XP Pro SP3 host, Windows or Linux guests). This same issue has been affecting me for a while now, at least since v1.5. The workaround that Zoltanf mentions does work for me too. Its just a pain to go into standby, then wake the system up and then back to hibernation.

comment:10 in reply to: ↑ 9 Changed 5 years ago by maxmorio

I can confirm that this bug still exists in VirtualBox 2.1.4.


Running a XP SP3 Host with VT-x enabled, Suspend to RAM is fine, but suspend to disk ('Hibernate') causes system to hang with black screen. Disabling VT-x allows to hibernate as expected, but guest system is slower, then.

Error occurs like described by zotanf on 2009-02-02.

comment:11 Changed 5 years ago by Graham Norris

How can we get some attention paid to this eight month old bug? I would not be surprised if it isn't affecting more people than have commented here as there's no obvious relationship between VirtualBox and the hibernation failure - until you find this bug report and turn off VT-x in VirtualBox and the hibernation problem immediately goes away.

I'd had the problem for several months before I finally stumbled upon this bug; it had never occurred to me that VirtualBox was the cause, but it clearly is: I've not had a single hibernate problem since turning off VT-x in VirtualBox, plus the standby workaround worked for me too.

comment:12 Changed 5 years ago by zoltanf

Don't know how to get some dev's attention. The owner of the bug is changed, that should meen that there should be some one responsible for solving this bug. As someone reported that this bug was not present with the older version of the SW, probably all they need to see is what is set and left for the CPU VT-x function that messes with the hibernate. I think that every modern centrino notebooks have this problem, many people don't use hibernate, or use it rearly enough not to realise that the hibernate problem is related to VirtualBox...

comment:13 Changed 5 years ago by sandervl73

Hibernate works fine here. If it didn't, I would have fixed the problem already. So we are aware of it, but haven't been able to reproduce this so far.

comment:14 follow-up: ↓ 19 Changed 5 years ago by Graham Norris

Well, we have this known to be occurring on three different brands of PC (Lenovo, HP and Dell) plus one unspecified PC in this bug (maxmorio) and one unspecified laptop ( http://forums.virtualbox.org/viewtopic.php?f=6&t=15083#p62869), so we can rule out manufacturer-specific crapware and BIOS changes. We know it isn't fixed with a BIOS update (zoltanf and I are both running the most recent relevant BIOSes). We can probably rule out the common Symantec/McAfee stuff too as I at least don't use them. It's also 100% reproducible by those who have discovered that VirtualBox causes it.

How can we move this forward? Is there some system state we can dump for you to help, for example, after using VT-x In VirtualBox, dump the state before standby, then again after resuming from standby - since going into standby and resuming is known to cure the problem until the next time VT-x is used by VirtualBox, it is reasonable to suspect it is causing something to be restored during resume.

comment:15 Changed 5 years ago by sandervl73

I think I've tried this on two thinkpads here too, but will repeat the experiment next week.

comment:16 follow-up: ↓ 21 Changed 5 years ago by sandervl73

Remind me in case I forget. My todo list is rather big. :)

comment:17 Changed 5 years ago by zoltanf

All of the systems seems to involve Intel Core Duo Processor and large amount of RAM (>1GB). Might be a good starting point for testing.

comment:18 Changed 5 years ago by Graham Norris

I would also add that my symptoms do vary slightly.

I get my machine to hibernate by pressing the power button: I don't know if doing it by using Start/Shut Down also causes the problem. When I press the power button, Windows always notices, however what happens next varies.

a) Sometimes the screen just goes black immediately and the machine becomes completely unresponsive, except to the power button. Pressing the power button immediately causes the power to shut off (normally on a hung system I'd have to press it for several seconds to make the power actually shut off).

b) Sometimes hibernate actually goes through the process of saving to disk, then the screen goes black (when the machine should power off) and the machine becomes completely unresponsive except to the power button as in the first scenario.

BTW, I always exit all regular applications before entering hibernate: I use hibernate to make the machine stop and start quicker, not to leave applications open while I'm not using it.

This machine has 4GB or RAM and has the latest available drivers for everything (which isn't always a good thing of course). I do not have any other virtualization software installed, and never have on this machine.

comment:19 in reply to: ↑ 14 Changed 5 years ago by maxmorio

Replying to Graham Norris:

Well, we have this known to be occurring on three different brands of PC (Lenovo, HP and Dell) plus one unspecified PC in this bug (maxmorio) and one unspecified laptop ( http://forums.virtualbox.org/viewtopic.php?f=6&t=15083#p62869), so we can rule out manufacturer-specific crapware and BIOS changes. We know it isn't fixed with a BIOS update (zoltanf and I are both running the most recent relevant BIOSes). We can probably rule out the common Symantec/McAfee stuff too as I at least don't use them. It's also 100% reproducible by those who have discovered that VirtualBox causes it.

How can we move this forward? Is there .....


The 'unspecified PC' (maxmorio) mentioned by Graham Norris yesterday is a Transtec Levio210 (rebranded MSI S262) Laptop with Intels Centrino Duo (Core Duo CPU) and 4GB Ram. It has latest BIOS provided by MSI, no Symantec/McAfee Software installed. I also can confirm the bug to occur like described by zoltanf with 'a)' on my computer. Hope this helps in narrowing the problem.

comment:20 Changed 5 years ago by solamour

My laptop (Dell D830, Core 2 Duo, 3GB RAM, 32-bit WinXP) hangs when hibernating, just as described in this Ticket, but my desktop (ASUS M3A78-EM, AMD Athlon X2, 4GB RAM, 32-bit WinXP) works perfectly. I'm very close to ditching VMware once and for all, but hibernation is just too important to ignore, at least to me. I'd very like to see a progress on this issue.

comment:21 in reply to: ↑ 16 Changed 5 years ago by Graham Norris

Replying to sandervl73:

Remind me in case I forget. My todo list is rather big. :)

Consider yourself reminded!

comment:22 in reply to: ↑ description ; follow-up: ↓ 32 Changed 5 years ago by MrEasy

Same symptom here. Dell Latitude E6400 Intel Core 2 Duo P8400 4GB RAM Host: Windows XP Pro 32bit SP3

comment:23 Changed 5 years ago by sandervl73

Is anybody seeing this with Vista? I don't have a laptop with XP and VT-x here, but will try it anyway.

comment:24 Changed 5 years ago by Graham Norris

I don't use Vista (upgraded my Thinkpad to XP from Vista soon after I got it), but I do still have the original Vista x64 hdd I could try. I don't recollect anyone reporting the current problem with Vista or x64 though.

comment:25 Changed 5 years ago by sandervl73

Ok, unable to reproduce on my Thinkpad T61p (Core 2 Duo (T7700)) and Vista 32 bits. I'll have to resurrect another (desktop) machine that has VT-x and XP.

comment:26 Changed 5 years ago by Graham Norris

I just found this  http://forums.virtualbox.org/viewtopic.php?f=6&t=12545&p=64734#wrap where there's a suggestion (2nd post) that a complete uninstall and re-install might cure the problem. I've not tried that; is it worth it?

If I uninstall completely, I know I won't lose my virtual machines, but will I lose any other settings?

comment:27 Changed 5 years ago by zoltanf

I don't believe that reinstalling Virtual Box will solve the problem, but I will give it a shot today...

comment:28 Changed 5 years ago by zoltanf

BTW, in the second post, the working system mentioned is x64, most of the system reported this error, as long as I can recall, are 32bit + XP + Core Duo + Large amount of RAM.

comment:29 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 1.6.2 to VirtualBox 2.1.4

comment:30 Changed 5 years ago by sandervl73

I'm seeing similar behaviour with an old Pentium-D system and XP SP3 as a host. Not always consistent, but often enough. Monitor loses the connection after initiating hibernation and the machine doesn't turn itself off. Reset/hard poweroff required to get it back.

comment:31 Changed 5 years ago by sandervl73

  • Priority changed from major to critical

comment:32 in reply to: ↑ 22 Changed 5 years ago by MrEasy

Replying to MrEasy:

Same symptom here.
Dell Latitude E6400
Intel Core 2 Duo P8400
4GB RAM
Host: Windows XP Pro 32bit SP3

Can confirm, that first entering standby, wake it up and entering hibernate works (but is a pain in the ass).

comment:33 Changed 5 years ago by sujitvp

Same symptom here: Toshiba Tecra M8 Intel Core 2 Duo T7250 @ 2.00Ghz 4 GB RAM Host: Windows XP Pro SP2

comment:34 Changed 5 years ago by CaptainFlint

Just for the information (maybe it will be of use): I have the same problem, and zoltanf's solution (stand-by, wake up, then hibernate) does NOT help. Even after stand-by my host OS fails to hibernate (screen goes black, keyboard not responding, computer remains turned on). In BIOS stand-by is configured as S1 state.

VB 2.1.4 OS: XP SP3 32-bit Core 2 Duo E6600, 2GB RAM

comment:35 follow-up: ↓ 36 Changed 5 years ago by sandervl73

  • Summary changed from Host hibernation hang after runing Virtual Box with enabled VT-x to Host hibernation hang after runing Virtual Box with enabled VT-x -> fixed in SVN/2.2

Fixed the problem. It will be included into the next 2.2 beta (see our forum). Beta 1 still has the bug.

Thanks for your help!

comment:36 in reply to: ↑ 35 Changed 5 years ago by Graham Norris

Replying to sandervl73:

Fixed the problem. It will be included into the next 2.2 beta (see our forum). Beta 1 still has the bug.

Thanks for your help!

And thank you too. I'm looking forward to putting this to the test when the next beta lands.

comment:37 Changed 5 years ago by zoltanf

sndervl73, thank for the effort. Others, thank you for sharing information and participating in resolving this problem. We are waiting for the next beta to test.

Best Regards, Z.

comment:38 Changed 5 years ago by MrEasy

Tested hibernation successfully with 2.2 beta 2 - thx.

comment:39 Changed 5 years ago by zoltanf

I can also confirm, that this issue no longer exists in Virtual Box 2.2 beta 2.

Hibernation and standby now works, with VT-x/AMD-V enabled, even while the virtual machines are running.

Thanks for all who worked on resolving this issue.

comment:40 Changed 5 years ago by Graham Norris

Yup, works here too.

Unfortunately 2.2.0b2 screwed up my PC's networking so badly that networking in VirtualBox wouldn't work and then had I to run System Restore to recover from BSODs (indeterminate driver broken - have to suspect VB's network driver) while logging on after rebooting, but that's another story for another place.

comment:41 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed. Please open another ticket for unrelated problems.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use