VirtualBox

Ticket #17779 (closed defect: duplicate)

Opened 21 months ago

Last modified 21 months ago

arrow keys don't correctly repeat

Reported by: pw2 Owned by:
Component: USB Version: VirtualBox 5.2.12
Keywords: keyboard repeat Cc:
Guest type: Windows Host type: Linux

Description

I'm using a very updated version of Ubuntu 16.04 as the host machine

I just noticed this as a problem with Virtualbox 5.2.12

What happens is that I type in a long string of characters (80 or more) in an application text field or even in Notepad.exe. I then _hold down_ a left or right arrow key to move the cursor -- the problem is that the cursor will get stuck every 30 or so characters and then continue -- sometimes in sets a selection-marker (starts highlighting text) -- the selection-marker is sometimes hard to get rid of

CTRL-A doesn't select all characters

Visible keyboard characters seem to repeat fine when the key is held down. It is mainly the arrow-keys that are failing (when held down) in Windows guests.

This happens in Windows XP and Windows 7 guest machines

It looks like the shift-key is also not working correctly as numbers are not possible to type and after trying to type a few numbers, a new problem happens: only caps-lock can be used to choose upper or lowercase letters (shift doesn't work for that)

I tried an older version of Virtualbox (5.2.2) in Ubuntu 16.04 with Windows guests and it didn't have this problem

(there aren't any USB filters defined)

I am using Ubuntu 16.04 guests and those work ok in Virtualbox 5.2.12 in an Ubuntu 16.04 host.

Thanks for looking into this one!

Change History

comment:1 Changed 21 months ago by pw2

The issues can pile up after holding down the arrow-keys and repeating it a few times or more; after holding down the arrow-keys, getting them to get temporarily stuck, and repeating this many times, the VM seems to get increasingly confused as to whether the shift key or ctrl key or other special key is held down

comment:3 Changed 21 months ago by janitor

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use