VirtualBox

Ticket #17778 (new defect)

Opened 15 months ago

Last modified 6 months ago

Double cursor on Mac OS host with unscaled HiDPI / W10 Guest with 200% scale

Reported by: plexus Owned by:
Component: other Version: VirtualBox 5.2.12
Keywords: Cc:
Guest type: Windows Host type: Mac OS X

Description

Mac OS host (MacBook retina) with unscaled HiDPI enabled, 3d acceleration disabled (otherwise bug #17369 resurfaces). W10 Guest with 200% DPI scale (to compensate for the smaller fonts etc - is there a different way in W10 to do this?). VB Version 5.2.12 r122591 (Qt5.6.3), matching guest additions version installed. Result - double two cursors, host and guest, with guest cursor "chasing" host cursor.

Attachments

Windows 10.vbox.zip Download (2.8 KB) - added by plexus 15 months ago.
Windows 10-2018-05-21-21-45-05.log.zip Download (30.2 KB) - added by plexus 15 months ago.
w10 guest - double cursor - windowed - 150% scale.mov Download (221.2 KB) - added by plexus 15 months ago.

Change History

comment:1 Changed 15 months ago by socratis

  • Follow a "start the VM from cold-boot" / "observe error" / "shutdown the VM" cycle.
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response.
  • You were supposed to follow these steps when you filed the bug:

    Attach a (full) log file ("Machine" menu/"Show Log" in the main VirtualBox Manager window) straight away to save time for you and for us. The log file contains a lot of useful information about both the host and the guest systems as well as information about what happened during a particular machine run. Please do not cut and paste it.


I would also like to see the "recipe" of the VM, the ".vbox" file:

  • Right-click on the VM in the VirtualBox Manager. Select "Show in Finder/Explorer/Whatever".
  • ZIP the selected ".vbox" file and attach it to your response.

comment:2 Changed 15 months ago by janitor

Is this different from #15610?

comment:3 Changed 15 months ago by socratis

janitor, I don't know yet, that's why I want to see the evidence asked. #15610 is resolved, that's why I want to see what's going on here...

Changed 15 months ago by plexus

Changed 15 months ago by plexus

comment:4 Changed 15 months ago by plexus

Attached the log and the recipe. One thing to note is that after starting the VM in fullscreen mode it often (and in this case too) does not auto-resize and stays at a very low resolution, in my case occupying a small square in the middle of the screen. Sometimes toggling "auto-resize guest display" off and on helps, sometime it just takes about 10 seconds after the guest OS starts to resize, but when unscaled HiDPI mode is enabled and 3d acceleration is disabled, the only thing that helps is toggling full screen mode off and on. Guess it's another, unrelated bug, but if in the log you see me toggling full-screen it's because of this. Important: when it starts and fails to auto-resize, the double cursor bug is not present. It's only when the guest OS is resized to fit the whole screen that I see the double cursor.

And as already mentioned, if the guest W10 scale is set to 100% the double cursor effect disappears too.

comment:5 Changed 15 months ago by socratis

plexus, take a look at  https://forums.virtualbox.org/viewtopic.php?f=2&t=87964 I think you're having the same issue. So far reported only with Win10.

Read the whole thread for context, but the juicy part starts at  https://forums.virtualbox.org/viewtopic.php?f=2&t=87964#p421079

This happens if the guest OS uses the Windows 10 scaling setting (System->Display->Change the size of text, apps, and other items). Whenever this is set above 125%, this problem surfaces. I have it set to 200%, as I'm running a 3840x2160 monitor.


I could try and replicate your issue, but:

  1. I don't have that big of a monitor, which means that...
  2. I will need to create a Win10 clone with a lower resolution.
  3. There's an easy workaround; don't use the "Unscaled HiDPI output" and change the scaling within Windows to 100%. That should give you the exact same result until this gets fixed.

If it's the same behavior, then I think it's a new "issue" that deserves its own ticket, not a duplicate of #15610. BTW, I believe it's the first time I've used the "not" in front of a "duplicate" in the bug tracker :D

I will update the thread in the forums to point to this ticket.

Changed 15 months ago by plexus

comment:6 Changed 15 months ago by plexus

socratis, yes looks like the same issue. As for replicating - you can replicate on any resolution monitor as long as W10 scale is set to something like 150% or 200%. I've attached a screen capture of a 1024x768 windowed session. The easy workaround works, of course, and this is what I've been using, but it looks ugly as the guest is not utilising the HiDPI monitor.

comment:7 Changed 15 months ago by socratis

Yes, I saw the issue. Reminds me of #15610, but I don't think it's the same underlying reason, mainly because it hasn't been reported on anything else except a Wi10 guest...

Interesting fun fact: try to install or update the GAs. Just before you click on the "Reboot" or "I want to manually reboot later", open Notepad. Notice the same exact effect, even with a scaling of 100%. At least I do on an OSX 10.11.6 host. It's like the GAs get deactivated if the scaling is set to something more than 125%.

Just FYI, I tried the latest test (rev. 122773) and development (rev. 122781) builds, but no joy, I guess they're still working on it...

comment:8 Changed 12 months ago by coderforlife

I am seeing this issue on Linux as well.

  • Host: Fedora 28, kernel 4.17.19-200, Cinnamon DE
  • Guest: Windows 10 Pro
  • VirtualBox: 5.2.18
  • VBox GA: 5.2.16r123759

Goes away when mouse integration is turned off (but then the cursor flickers when moving) or when the scaling is set to 100%. Unlike on the Macs, the desktop environment is set to use HiDPI and this still occurs.

I really only have 1 graphics card (there is a second card that is for diagnostics only and is disabled, even still it sometimes causes graphical issues with some programs in strange circumstances). The card I am using is an Nvidia card and I am using the latest official drivers for it.

Last edited 12 months ago by coderforlife (previous) (diff)

comment:9 Changed 12 months ago by coderforlife

A little update: I misunderstood other users. This is using unscaled setting in VBox and the DE is doing Hi-DPI.

With a setting of 100% or 125% in Windows there is no problem. For 150% or 175% is starts to appear (only noticeable when the two cursors are significantly different from each other). At 200% it gets worse and both cursors are always visible.

comment:10 Changed 11 months ago by coderforlife

It seems that the second cursor, the one that shouldn't be showing up, is always a custom cursor instead of one of the built-in ones. When a custom cursor is shown, then it is the only cursor that is shown. The double cursor is shown as the current built-in cursor plus the last shown custom cursor.

I plan on creating a test application for this soon to determine what combinations of LoadCursor/LoadImage/CreateCursor/window cursor class result in this issue.

comment:11 Changed 10 months ago by akm

hello

Am having the exact same cursor issue however the setup is a bit different. Windows 10 host running a Windows 10 Guest -> this works perfect, no weird cursor issues. If I then start a XenDeskop in the Guest it has the exact same issues as described in this call. Turning of the mouse integration solves it but gives a pretty bad mouse behaviour.

So not sure if this should be a new call or added to this ?

comment:12 Changed 10 months ago by coderforlife

That is likely the same issue. As I have observed, if only built-in cursors are shown then there seems to be no problem. As soon as an application sets a custom cursor, the custom cursor becomes "sticky" and continues to be shown well after it is turned off.

It is likely that XenDesktop is always setting a custom cursor even if it looks exactly like a built-in one due to its level of indirection.

comment:13 Changed 6 months ago by MiSterS

Looks like I have the same problem running VB6.0.4 on OSX 10.11.6 with a Win10 Pro guest.

It happens if scaling in VB is set to 100% and scaling in Windows ist set to 175% It DOES NOT happen if Mouse Integration is OFF. It also happens independently of installing GA.

In addition to the double mouse pointer right mouse click (two finger tap on OSX) does NOT work correctly. (This also works fine if Mouse integration is turned OFF). E.g. the contextmenu is just flickering shortly and dependent on the location of the mouse pointer a menuitem is selected.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use