VirtualBox

Ticket #1768 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

core dumps from VBox 1.6.2 on Sol10u5 host => Fixed in 1.6.4

Reported by: phess Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Host: Solaris 10 update 5 on amd64 Guest: Windows XP Service Pack 3

When attempting to use Microsoft Update to install MSIE7 VBoxHeadless crashes. Also, VBoxHeadless crashes when attempting to install the latest Flash Player from Adobe. In both cases I had to resort to a command line driven installation to accomplish the task.

I have 6 bzip'd core files totaling almost 1GB that I can leave for your examination. Please let me know where I can upload them for your retrieval.

If there is more information that you need, I can provide it upon request.

root@sol10-host:etc # cat /etc/release
                        Solaris 10 5/08 s10x_u5wos_10 X86
           Copyright 2008 Sun Microsystems, Inc.  All Rights Reserved.
                        Use is subject to license terms.
                             Assembled 24 March 2008
root@sol10-host:/ # uname -X
System = SunOS
Node = sol10-host
Release = 5.10
KernelID = Generic_127128-11
Machine = i86pc
BusType = <unknown>
Serial = <unknown>
Users = <unknown>
OEM# = 0
Origin# = 1
NumCPU = 1

root@sol10-host:/ # psrinfo -v
Status of virtual processor 0 as of: 06/24/2008 01:02:27
  on-line since 06/19/2008 00:07:45.
  The i386 processor operates at 1808 MHz,
        and has an i387 compatible floating point processor.
root@sol10-host:/ # isainfo -kv
64-bit amd64 kernel modules
root@sol10-host:/ # pkginfo -il SUNWvbox
   PKGINST:  SUNWvbox
      NAME:  Sun xVM VirtualBox
  CATEGORY:  application
      ARCH:  i386
   VERSION:  1.6.2,REV=2008.05.31.04.05
   BASEDIR:  /
    VENDOR:  Sun Microsystems, Inc.
      DESC:  A powerful PC virtualization solution
    PSTAMP:  vbox20080531040521
  INSTDATE:  Jun 07 2008 02:58
   HOTLINE:  Please contact your local service provider
     EMAIL:  info@virtualbox.org
    STATUS:  completely installed
     FILES:      551 installed pathnames
                   1 shared pathnames
                  25 directories
                  16 executables
              153015 blocks used (approx)

root@sol10-host:/ # file /opt/VirtualBox/VBoxHeadless 
/opt/VirtualBox/VBoxHeadless:   ELF 64-bit LSB executable AMD64 Version 1, dynamically linked, stripped
root@sol10-host:/ # 

Change History

comment:1 Changed 6 years ago by franith

Hi - I have a similar problem on 64-bit Solaris 10 U6 (05/08) hosting a Windows 2000 Server. I am running VBox in a non-global zone called 'vm1' . The zone has been configured with:

zonecfg -z vm1
add device
set match="/dev/vboxdrv"
end

as suggested at  http://blogs.sun.com/gfaden/entry/virtualized_instances_of_vista_in . I am also running a 'stub' zone in the global zone to keep the driver loaded so it can be accessed by the zone.

I am frequently getting Seg Fault errors:

Segmentation Fault      (core dumped) VBoxHeadless -startvm "Windows 2000 Server"

This occurs typically during installation of new apps on the Windows machine - including Apache, SQL Server, Firefox, and Windows Update. It consistently fails, for example, just as the final screen of SQL Server install announcing 'setup finished' is rendered.

I have noted the IRQ delay fix suggested in the user manual and set the delay to 1 and then 3ms but with no effect.

Typically the last message in my VBox.log file is something like 00:05:19.959 PATM: Disable block at 811bd764 - write 811bd87c-811bd880

but it does not happen at the same time as the crash, and i have read elsewhere that this is not that relevant.

System info included below.

[root@vm1]:/>uname -X
System = SunOS
Node = vm1
Release = 5.10
KernelID = Generic_137112-01
Machine = i86pc
BusType = <unknown>
Serial = <unknown>
Users = <unknown>
OEM# = 0
Origin# = 1
NumCPU = 2

[root@vm1]:/>psrinfo -v
Status of virtual processor 0 as of: 06/30/2008 17:24:07
  on-line since 06/22/2008 21:43:18.
  The i386 processor operates at 2792 MHz,
        and has an i387 compatible floating point processor.
Status of virtual processor 1 as of: 06/30/2008 17:24:07
  on-line since 06/22/2008 21:43:24.
  The i386 processor operates at 2792 MHz,
        and has an i387 compatible floating point processor.

[root@vm1]:/>isainfo -kv
64-bit amd64 kernel modules

[root@global]:/>pkginfo -il SUNWvbox

   PKGINST:  SUNWvbox
      NAME:  Sun xVM VirtualBox
  CATEGORY:  application
      ARCH:  i386
   VERSION:  1.6.2,REV=2008.05.31.04.05
   BASEDIR:  /
    VENDOR:  Sun Microsystems, Inc.
      DESC:  A powerful PC virtualization solution
    PSTAMP:  vbox20080531040521
  INSTDATE:  Jun 27 2008 15:19
   HOTLINE:  Please contact your local service provider
     EMAIL:  info@virtualbox.org
    STATUS:  completely installed
     FILES:      551 installed pathnames
                   1 shared pathnames
                  25 directories
                  16 executables
              153015 blocks used (approx)

[root@vm1]:/>file /opt/VirtualBox/VBoxHeadless 
/opt/VirtualBox/VBoxHeadless:   ELF 64-bit LSB executable AMD64 Version 1, dynamically linked, stripped

Thanks - Francis

comment:2 Changed 6 years ago by ramshankar

Since you are able to start your VM from a zone, zones here are irrelevant. Once you gain access to the device from your zone it's just like running it from the global zone as there is no other zone specifics involved.

Have you enabled VT-x or hardware acceleration?

Along with uploading a core file, can you also post here a stack dump of the core ("mdb core") and then "$c" and paste output.

comment:3 Changed 6 years ago by frank

Maybe this is just a problem of the RDP server, we fixed several related bugs after 1.6.2 was released. We could provide you a test build so you could verify if the bug is already fixed.

comment:4 Changed 6 years ago by franith

Hi Frank, that would be great, can you provide a link? I will be able to upload the core and stack dump tomorrow, i don't have time right now.

comment:5 Changed 6 years ago by frank

franith, your account does not contain an E-mail address. Please could you either add your address using  Trac settings or write me a short note to frank dot mehnert at sun dot com.

comment:6 follow-up: ↓ 8 Changed 6 years ago by frank

Francis acknowledges that his problem is gone with a 1.6.3 test build. phess, do you want to try a test build as well?

comment:7 Changed 6 years ago by phess

I'm willing to be a guinea pig, but having installed the packages I needed I don't have another method for reproducing the bug on the fly.

--phess

comment:8 in reply to: ↑ 6 Changed 6 years ago by phess

I found yet another way to make this happen. Please direct me to the test build. :)

--phess

Replying to frank:

Francis acknowledges that his problem is gone with a 1.6.3 test build. phess, do you want to try a test build as well?

comment:9 Changed 6 years ago by phess

Yes, that has resolved the issue I was having. Thank you.

--phess

comment:10 Changed 6 years ago by frank

  • Summary changed from core dumps from VBox 1.6.2 on Sol10u5 host to core dumps from VBox 1.6.2 on Sol10u5 host => Fixed in 1.6.4

comment:11 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use