VirtualBox

Ticket #17664 (closed defect: fixed)

Opened 8 months ago

Last modified 4 weeks ago

Crash in hdaR3Timer, Fedora 27 host, Oracle Linux 7.2 guest -> fixed in 5.2.22

Reported by: the_source_him Owned by:
Priority: major Component: guest additions/x11/graphics
Version: VirtualBox 5.2.8 Keywords:
Cc: pentagonik Guest type: Linux
Host type: Linux

Description

VirtualBox crashes when any gnome based application is started, including gdm and gnome desktop, but only with guest additions installed (3d acceleration disabled). With 3d acceleration enabled I get kernel panics and oopses, system can not load. Worked fine in 5.2.6. Guest kernel is 3.8.13-98.7.1.el7uek.x86_64

Host system - Fedora 27 x86_64

Attachments

Oracle linux 7.2-2018-03-30-08-57-40.log Download (81.2 KB) - added by the_source_him 8 months ago.
Virtual machine log

Change History

Changed 8 months ago by the_source_him

Virtual machine log

comment:1 Changed 8 months ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Crash with oracle linux 7.2 guest (gnome based software) to Crash with oracle linux 7.2 guest (gnome based software) -> duplicate of #17623

Probably a duplicate of #17623. If it is then the latest test builds should fix the problem, if not please re-open.

comment:2 Changed 8 months ago by the_source_him

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I posted my problem to #17623, but that bug is not kernel related, while this is. Under kernel 3.8 virtualbox crashes, under 3.10 everything works fine. I could get some backtrace of the crash, but it might not be very useful:

#0  0x00007f5b11c08f8a in hdaR3Timer(PDMDEVINS*, TMTIMER*, void*) () from /usr/lib/virtualbox/VBoxDD.so
No symbol table info available.
#1  0x00007f5b6e0bb653 in tmR3TimerQueueRunVirtualSync(VM*) () from /usr/lib/virtualbox/components/VBoxVMM.so
No symbol table info available.
#2  0x00007f5b6e0beca6 in TMR3TimerQueuesDo () from /usr/lib/virtualbox/components/VBoxVMM.so
No symbol table info available.
#3  0x00007f5b6e0582f8 in emR3ForcedActions () from /usr/lib/virtualbox/components/VBoxVMM.so
No symbol table info available.
#4  0x00007f5b6e05c259 in emR3HmExecute () from /usr/lib/virtualbox/components/VBoxVMM.so
No symbol table info available.
#5  0x00007f5b6e058ddf in EMR3ExecuteVM () from /usr/lib/virtualbox/components/VBoxVMM.so
No symbol table info available.
#6  0x00007f5b6e0c8a2d in vmR3EmulationThreadWithId(RTTHREADINT*, UVMCPU*, unsigned int) () from /usr/lib/virtualbox/components/VBoxVMM.so
No symbol table info available.
#7  0x00007f5b9d09034c in rtThreadMain () from /usr/lib/virtualbox/VBoxRT.so
No symbol table info available.
#8  0x00007f5b9d12193a in rtThreadNativeMain(void*) () from /usr/lib/virtualbox/VBoxRT.so
No symbol table info available.
#9  0x00007f5b9d9e350b in start_thread () from /lib64/libpthread.so.0
No symbol table info available.
#10 0x00007f5b9d51716f in clone () from /lib64/libc.so.6
No symbol table info available.
Last edited 8 months ago by michael (previous) (diff)

comment:3 Changed 8 months ago by michael

  • Summary changed from Crash with oracle linux 7.2 guest (gnome based software) -> duplicate of #17623 to Crash in hdaR3Timer, Fedora 27 host, Oracle Linux 7.2 guest

comment:4 Changed 8 months ago by michael

  • Cc pentagonik added

comment:5 Changed 4 weeks ago by the_source_him

It seems to be fixed in VirtualBox-5.2.22

comment:6 Changed 4 weeks ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Summary changed from Crash in hdaR3Timer, Fedora 27 host, Oracle Linux 7.2 guest to Crash in hdaR3Timer, Fedora 27 host, Oracle Linux 7.2 guest -> fixed in 5.2.22

Thank you for letting us know!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use