VirtualBox

Ticket #17663 (closed defect: fixed)

Opened 16 months ago

Last modified 14 months ago

Graphics lockup leading to VM lockup with Fedora 27 guest -> reported fixed in 5.2.10

Reported by: Vek Owned by:
Component: other Version: VirtualBox 5.2.8
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description

On a Mac host, I have a Fedora 27 guest using the Cinnamon window manager, which requires 3D acceleration. X server version is 1.19.6. With the VBox 5.2.8 release (and at least with 5.2.6 prior to that), I've been experiencing a problem with graphics lockups that, if not addressed, leads eventually to a full guest lockup. This is a frustrating problem, because I haven't found any logs with useful information on the guest side, and only just discovered the logs for VBox (which I'll attach). (For the record, I am using the guest additions provided with VBox, rather than the guest additions available in the Fedora package repositories.)

The main symptom of the problem is that graphics stop updating: the clock running in the X desktop stops updating, and the only graphical element that functions is the cursor. I also hear the host fan spool up, so whatever is happening is causing a high CPU load. If I catch the problem right away, I can switch to a text terminal and kill the Cinnamon session; this causes X to restart, and seems to clear the problem. If I don't catch the problem, however, eventually the guest completely locks up and has to be hard reset.

As for the cause of the problem: anything that produces high graphics load does seem to increase the likelihood of it appearing; for instance, I just experienced a lockup while attempting to watch a video. However, graphics load is not the sole cause, as I was able to watch that video and much more after the X restart (without restarting the VM). Additionally, the lockup has occurred with the system completely idle; I had this condition occur over the weekend, where I came into my office on a Sunday evening (computer had been idle since Friday), and heard the fan and was able to intervene and restart X. The problem occurs regularly enough that I have had to restart X twice while showing a presentation to some coworkers, yet can have a period of up to a couple of days with no problems.

I will be attaching two files: one from the last time I had to hard reset the guest, and one from the current session, where I've had to restart the X server by killing cinnamon-session.

Attachments

Work-2018-03-16-21-45-51.log Download (315.5 KB) - added by Vek 16 months ago.
Log from instance that required hard reset
Work-2018-04-03-14-28-43.log Download (216.6 KB) - added by Vek 16 months ago.
Log from currently running instance, after having to restart X

Change History

Changed 16 months ago by Vek

Log from instance that required hard reset

Changed 16 months ago by Vek

Log from currently running instance, after having to restart X

comment:1 Changed 15 months ago by Vek

I am continuing to have problems with my VM locking up. Is there any further information you would like to have from me to diagnose this problem? Any luck finding the root cause? I haven't seen any updates to this ticket, and the problem is happening frequently enough to cause me work hindrance.

comment:2 Changed 15 months ago by socratis

There is call for help from the developers for end-users to pitch in helping with this: 3D support for X11 guests.

And as for diagnosing and adding more info, from ticket #13653, from one of the developers:

Just to summarize the situation: we do not currently have free developer time (as in developers with the required skills who are not already taken up with other work) to investigate this bug, much as we understand that it is annoying to the people affected. This situation might change, but that is not something we can promise. Of course, I quite understand that if this means that something else fits any individual's requirements better than VirtualBox then it is a sensible solution to use that instead.

However, the fact that VirtualBox is open source means that users who are interested have another option to get changes made, by doing the work themselves or crowd-sourcing the work. If you go this way of course, please communicate with us before starting and while doing the work, as we hate to see work go to waste due to misunderstandings like mismatches with our development style. Though this is more a fix than a feature, so likely to be easier to integrate.

See also the X11 guest 3D wiki page. Windows guest 3D is not user-maintained, but we are still rather limited in what we can do.

I would kindly request that as of now people do not add unneeded information to this ticket, such as that this is still not fixed or does not work for a given person. However, if you would like to subscribe to the ticket please add a "me too" comment, and we will delete the comment and add your nickname to the "CC" list.

Now, I saw your ticket, I'm on OSX and I thought I'd try F27. And try, I did. I downloaded the first one that I found, in  https://getfedora.org/en/workstation/download/ on the right side, the one under "Other Downloads", the "64-bit 1.5GB Live image" ( https://download.fedoraproject.org/pub/fedora/linux/releases/27/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-27-1.6.iso).

I didn't have any problems at all. So, you may want to stay away from the Cinnamon based one for the foreseeable future...

comment:3 Changed 15 months ago by Vek

  1. For the record, it appears 5.2.10 resolves the issue; I've gone for more than a week now without having to reboot my VM. I believe this issue can now be closed.
  1. Somehow I failed to receive any notification about the comment left by socratis; that would have been useful information for me...

comment:4 Changed 14 months ago by socratis

  1. The developers will be glad to hear this!
  1. I don't remember the exact setting, but you should be able to subscribe to a ticket. Which is the default, BTW. On the top right corner of the page, there's a Preferences link (https://www.virtualbox.org/prefs). Is your e-mail there your primary e-mail?

comment:5 Changed 14 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Graphics lockup leading to VM lockup with Fedora 27 guest to Graphics lockup leading to VM lockup with Fedora 27 guest -> reported fixed in 5.2.10
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use