VirtualBox

Ticket #17502 (closed defect: duplicate)

Opened 4 years ago

Last modified 2 years ago

Windows 98 cannot boot w/ HardwareVirtEx enabled if host is an AMD Ryzen

Reported by: kumba Owned by:
Component: VMM Version: VirtualBox 5.2.6
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

I just upgraded off of an Intel Ivy Bridge system to an AMD Ryzen 7 1700X, and am reloading my VM images one-by-one. When restoring my Windows 98 guest used for testing NetWare stuff, I found that it would refuse to boot, stating "Windows protection error. You need to restart your computer."

Turning off settings one-by-one, I worked out that the "HardwareVirtEx" setting ('Enable VT-x/AMD-V' in the GUI) is the cause. Turning that off, along w/ "Nested Paging", allows Windows 98 to boot. So it is possibly an issue with AMD-V and this really old OS. CPU has microcode 08001129 loaded, as well, in case that matters, given how new Ryzen CPUs are. Motherboard is an Asus PRIME X370-Pro running the latest BIOS (3402).

Also, the guest will boot into safe mode, so it might be one of the drivers causing the problem. I tried doing a step-by-step load, but the last driver to load was "msmouse", and given that the mouse will work under safe mode, I doubt it's that one. I'll attach a VBox.log file if that helps any.

Attachments

VBox.log Download (113.6 KB) - added by kumba 4 years ago.
VBox.log

Change History

Changed 4 years ago by kumba

VBox.log

comment:1 in reply to: ↑ description ; follow-up: ↓ 2 Changed 4 years ago by socratis

Replying to kumba:

Turning off settings one-by-one, I worked out that the "HardwareVirtEx" setting ('Enable VT-x/AMD-V' in the GUI) is the cause. Turning that off, along w/ "Nested Paging", allows Windows 98 to boot.

So, what is exactly the problem? That you have to clear a setting or two?

comment:2 in reply to: ↑ 1 Changed 4 years ago by kumba

Replying to socratis:

Replying to kumba:

Turning off settings one-by-one, I worked out that the "HardwareVirtEx" setting ('Enable VT-x/AMD-V' in the GUI) is the cause. Turning that off, along w/ "Nested Paging", allows Windows 98 to boot.

So, what is exactly the problem? That you have to clear a setting or two?

Well, this VM worked fine under my old setup a few weeks ago, and I had that setting enabled. Since I was running an Intel platform, that meant that VT-x would have been enabled (regardless if the OS used it or not). Now I am on an AMD platform, thus AMD-V, and the VM image no longer boots. That would mean there is a bug of some kind between AMD-V and Win98. What, I don't know. That's why I opened the bug. Turning a setting on or off was just a way to isolate what the problem was.

I play around with old OSes at random. Normally, when I find a problem between one of them and Virtualbox, I report it. Haven't had any of the devs express issues with this thus far.

comment:3 Changed 2 years ago by janitor

  • Status changed from new to closed
  • Resolution set to duplicate

comment:4 Changed 2 years ago by michaln

This is either a direct duplicate of #19275 (Win9x broken, not compatible with Ryzen) or the more generic "Windows 9x breaks on fast CPUs". Either way it's not something VirtualBox can really fix, the problem is with the underlying hardware/broken software.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use