VirtualBox

Ticket #17320 (closed defect: fixed)

Opened 8 months ago

Last modified 5 months ago

VirtualBox-5.2-5.2.2_119230_fedora26-1.x86_64 config fails -> fixed in 5.2.8

Reported by: obiewan Owned by:
Priority: blocker Component: installer
Version: VirtualBox 5.2.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Installed VirtualBox-5.2-5.2.2_119230_fedora26-1.x86_64 but config fails. Same with the latest development version.

/tmp/vbox.0/r0drv/linux/timer-r0drv-linux.c:1588:13: error: implicit declaration of function ‘init_timer_pinned’; did you mean ‘init_timer_key’? [-Werror=implicit-function-declaration]

Attachments

vbox-install.log Download (92.2 KB) - added by joeAverage 6 months ago.
module compile log
vboxadd-setup.log.gz Download (3.0 KB) - added by obiewan 6 months ago.

Change History

comment:1 Changed 7 months ago by weeman

Same for me using kernel 4.15 and VirtualBox 5.2.4

Last edited 7 months ago by weeman (previous) (diff)

comment:2 Changed 7 months ago by obiewan

I found this link on the web and installed it's patch to VB. The patch seems to have worked since I'm able to start VB now.

Regards,

George...

 https://bbs.archlinux.org/viewtopic.php?id=232356

comment:3 Changed 6 months ago by joeAverage

yesterday I tested the above patch with kernel 4.15.0-rc7 without success.

If I'm not "total blind" - tried to apply the patch twice - this patch doesn't work anymore !

I attach the log.

Changed 6 months ago by joeAverage

module compile log

comment:4 Changed 6 months ago by joeAverage

forgot to mention: I'm running Fedora 27

comment:5 Changed 6 months ago by joeAverage

arrrggghhh I get old: log is without the patch applied

Changed 6 months ago by obiewan

comment:6 Changed 6 months ago by obiewan

Hi,

I have attempted to run VBoxGuestAdditions.iso file VboxLinuxguest* on both the guest and the host. Both appear to have failed. I added the log file from the host installation.

What do "we" do now?

George...

comment:7 Changed 6 months ago by M.Poil

Same compilation bug as Debian 9 / Ubuntu 16.04 ... I think there is not test before releasing the Guest Additions :)

The only way I've found is to download Guest Addition 5.1.26 ( http://download.virtualbox.org/virtualbox/5.1.26/) and reinstall it over 5.2.6.

Best regards,

comment:8 Changed 6 months ago by socratis

M.Poil
Not every ticket needs to downgrade to 5.1.26. There may be different issues at play...

comment:9 Changed 6 months ago by michael

Please anyone having trouble with VirtualBox on Linux 4.15 release candidates (host or guest) try the current test builds<1> and provide feedback here.

  1. wiki:Testbuilds

comment:10 Changed 6 months ago by obiewan

I just upgraded VB to the latest test build. That went well and my guest booted. I first tried the rpm but it failed with a complaint about "font" not being a valid mime type. Do you need the exact text of the msg?

Here's what I'm running now (on kernel 4.15.0-0.rc8.git0.1.fc28.x86_64; Fedora 28 rawhide):

-rw-r--r-- 1 tstusr2 tstusrs 72229646 Jan 18 00:00 VirtualBox-5.2-5.2.6_120293_fedora26-1.x86_64.rpm -rw-r--r-- 1 tstusr2 tstusrs 94412229 Jan 18 00:50 VirtualBox-5.2.97-120150-Linux_amd64.run

comment:11 Changed 6 months ago by michael

It certainly won't hurt to have it. Other than that, Rawhide is not an officially supported host, but do I understand that your problem is now solved with the .run package?

comment:12 Changed 6 months ago by obiewan

Michael,

The version of VB I reported this problem against was solved with the patch I got from the web with the .run package. I installed with the "keep" option and then applied the patch. Everything worked great after that.

rpm -ivh VirtualBox-5.2-5.2.6_120293_fedora26-1.x86_64.rpm warning: VirtualBox-5.2-5.2.6_120293_fedora26-1.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY Preparing... ################################# [100%] Updating / installing...

1:VirtualBox-5.2-5.2.6_120293_fedor################################# [100%]

Creating group 'vboxusers'. VM users must be member of that group! Error in file "/usr/share/applications/org.kde.kfontview.desktop": "font/otf" is an invalid MIME type ("font" is an unregistered media type) Error in file "/usr/share/applications/org.kde.kfontview.desktop": "font/ttf" is an invalid MIME type ("font" is an unregistered media type)

There is no clear indication that the rpm install succeeded but apparently it did.

rpm -qa | grep virtualbox VirtualBox-5.2-5.2.6_120293_fedora26-1.x86_64

The result of the install appears to have succeeded AND boots my Linux guest. However, when the console of the guest actualizes, it's just a line on my display. Maybe this is caused by the error above?

Removing the rpm gives this message:

rpm -e VirtualBox-5.2-5.2.6_120293_fedora26-1.x86_64 Error in file "/usr/share/applications/org.kde.kfontview.desktop": "font/otf" is an invalid MIME type ("font" is an unregistered media type) Error in file "/usr/share/applications/org.kde.kfontview.desktop": "font/ttf" is an invalid MIME type ("font" is an unregistered media type)

comment:13 Changed 5 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from VirtualBox-5.2-5.2.2_119230_fedora26-1.x86_64 config fails to VirtualBox-5.2-5.2.2_119230_fedora26-1.x86_64 config fails -> fixed in 5.2.8
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use