VirtualBox

Ticket #1729 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Video display corrupts when using shared folders -> Fixed in 2.1.2

Reported by: brian Owned by:
Priority: critical Component: shared folders
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: Windows
Host type: other

Description

I have configured shared folders to work with my $host_os:~ however, whenever I try to access it from my WinXP Pro guest, within a few seconds of access, the video display of the guest will get corrupt. I have attached an example of this corruption. As soon as the display corrupts the VBox.log says:

00:01:23.286 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=b22d0000 w=1312 h=890 bpp=0 cbLine=0x480
00:01:23.286 VBVA: Disabled.

Of course there is no actual display resize at this point. It was simply trying to access a shared folder. I will attach the VBox.log as well.

Attachments

Screenshot-Windows XP Professional [Running] - Sun xVM VirtualBox-1.png Download (89.0 KB) - added by brian 6 years ago.
corrupted screen
VBox.log Download (45.1 KB) - added by brian 6 years ago.
VBox.log from session that corrupted the display
Screenshot.png Download (36.2 KB) - added by lesliev 6 years ago.
Crash after trying vboxsf.sys released 1 Sep 2008
VBoxSF.sys Download (182.8 KB) - added by sunlover 6 years ago.
Shared folders driver for VBox 1.6.x (updated)

Change History

Changed 6 years ago by brian

corrupted screen

comment:1 Changed 6 years ago by brian

Well, I was hoping to add the VBox.log file but when I try to "Attach File" I get an error:

TICKET_APPEND privileges are required to perform this operation

Hopefully the few lines above from the log that appear exactly when the corruption happens is enough. If not, please either fix the TICKET_APPEND problem or request the log from me by e-mail.

comment:2 Changed 6 years ago by michael

Try attaching the file again now. No idea why this didn't work in the first place.

Changed 6 years ago by brian

VBox.log from session that corrupted the display

comment:3 follow-up: ↓ 4 Changed 6 years ago by lesliev

I have the same problem, thought it was fixed with this version but it seems not. I get the same thing when accessing SAMBA shares on my host machine: after a random (but normally short) interval, the display goes corrupt and mostly black. Sometimes there's a blue screen after that but mostly the machine is well frozen and I have to "ACPI off".

If I get the blue screen again I'll post the info it contains.

comment:4 in reply to: ↑ 3 Changed 6 years ago by brian

Replying to lesliev:

I have the same problem, thought it was fixed with this version but it seems not. I get the same thing when accessing SAMBA shares on my host machine: after a random (but normally short) interval, the display goes corrupt and mostly black. Sometimes there's a blue screen after that but mostly the machine is well frozen and I have to "ACPI off".

Yeah, other than I've never seen a BSOD from this problem, it sounds very familiar. It's interesting that it appears to be some kind of networking problem rather than shared folders or something.

If I get the blue screen again I'll post the info it contains.

Cool.

comment:5 Changed 6 years ago by frank

  • Guest type changed from other to Windows

comment:6 Changed 6 years ago by frank

  • Component changed from other to shared folders

comment:7 follow-ups: ↓ 8 ↓ 9 Changed 6 years ago by poulsbo

I see this too on VirtualBox 1.6.4 running Windows XP SP3.

To repro: Attempt to view My Network Places or navigate to a share directly in Windows Explorer by typing \<host>\<server> or \vboxsvr\<share> into the address bar.

I get the same display corruption and have to ACPI shut down my guest.

comment:8 in reply to: ↑ 7 Changed 6 years ago by brian

Replying to poulsbo:

I see this too on VirtualBox 1.6.4 running Windows XP SP3.

To repro: Attempt to view My Network Places or navigate to a share directly in Windows Explorer by typing \<host>\<server> or \vboxsvr\<share> into the address bar.

I get the same display corruption and have to ACPI shut down my guest.

Yup, that is exactly my situation too. I wonder what we all have in common that others don't share.

comment:9 in reply to: ↑ 7 Changed 6 years ago by sunlover

  • Version changed from VirtualBox 1.6.2 to VirtualBox 1.6.4

Replying to poulsbo:

I see this too on VirtualBox 1.6.4 running Windows XP SP3.

To repro: Attempt to view My Network Places or navigate to a share directly in Windows Explorer by typing \<host>\<server> or \vboxsvr\<share> into the address bar.

I get the same display corruption and have to ACPI shut down my guest.

Which host OS do you use?

If you use Windows, could you try to reproduce the problem with a debugger attached to the guest? If yes, I'll provide detailed instructions. Thanks.

comment:10 follow-up: ↓ 11 Changed 6 years ago by poulsbo

My host OS is Mac 10.5.4. Please let me know if there is anything I can do to help debug this.

comment:11 in reply to: ↑ 10 ; follow-up: ↓ 12 Changed 6 years ago by poulsbo

I uninstalled my Guest Additions, rebooted, reinstalled Guest Additions, rebooted, and now I have a different symptom, which I believe has been reported separately -- normal SMB networking works, but I cannot access \vboxsvr\<share>.

comment:12 in reply to: ↑ 11 Changed 6 years ago by poulsbo

Ok this is back after a series of steps detailed in defect 1680 ( http://www.virtualbox.org/ticket/1680), basically, trying to get Shared Folders working using manually merged registry entries attached to that defect ticket.

comment:13 Changed 6 years ago by sunlover

Please try the attached shared folders driver (ut the file to Windows\system32\drivers). Let me know whether it works. Thanks!

comment:14 Changed 6 years ago by lesliev

Wow, it actually seems to be working now! I have successfully messed around in shared directories longer than ever before without a crash, even running programs from those directories. The big test will be running the Visual Studio service pack - then I'll report back. Thanks so much for all your work on this, it really helps me a whole lot.

Changed 6 years ago by lesliev

Crash after trying vboxsf.sys released 1 Sep 2008

comment:15 follow-up: ↓ 16 Changed 6 years ago by lesliev

Aw, it crashed now. I attached the bluescreen. I was just browsing my local SAMBA share, changing directories. My host OS is Ubuntu 8.04 (Linux lesliev-laptop 2.6.24-21-generic #1 SMP Mon Aug 25 17:32:09 UTC 2008 i686 GNU/Linux), my guest is Windows XP SP2. This crash is after I copied in the new VBoxSF.sys released 1 Sep 2008.

comment:16 in reply to: ↑ 15 Changed 6 years ago by sunlover

Replying to lesliev:

Aw, it crashed now. I attached the bluescreen. I was just browsing my local SAMBA share, changing directories. My host OS is Ubuntu 8.04 (Linux lesliev-laptop 2.6.24-21-generic #1 SMP Mon Aug 25 17:32:09 UTC 2008 i686 GNU/Linux), my guest is Windows XP SP2. This crash is after I copied in the new VBoxSF.sys released 1 Sep 2008.

This looks similar to  http://forums.virtualbox.org/viewtopic.php?t=2155&start=0&postdays=0&postorder=asc&highlight=mrxdav Could you try to disable the web client?

comment:17 Changed 6 years ago by lesliev

I disabled the web client and.... IT WORKS! I managed to run a detailed search on a shared drive, browse, install over the drive - even install Visual Studio 2005 SP1, which I have never been able to do in Virtual Box.

Thank-you very much!

comment:18 follow-up: ↓ 19 Changed 6 years ago by gupta.nikhil83

I am noticing the same black screen with dots on Virtual Box version 2.0.0, but obviously the attached vboxsf.sys does not work. As such, this issue is unfixed.

comment:19 in reply to: ↑ 18 Changed 6 years ago by sunlover

Replying to gupta.nikhil83:

I am noticing the same black screen with dots on Virtual Box version 2.0.0, but obviously the attached vboxsf.sys does not work. As such, this issue is unfixed.

Have you tried the driver attached to  http://www.virtualbox.org/ticket/2055 ? The one from this defect will not work in 2.0.x.

Changed 6 years ago by sunlover

Shared folders driver for VBox 1.6.x (updated)

comment:20 Changed 5 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Video display corrupts when using shared folders to Video display corrupts when using shared folders -> Fixed in 2.1.2

Should be fixed in 2.1.2.

comment:21 Changed 5 years ago by eohrnberger

  • Status changed from closed to reopened
  • Resolution fixed deleted

Not certain if this bug is fixed. I've got 2.1.2 installed, and I've run into exactly this issue. If I navigate with explorer on an SMB share, the scree corrupts. However, if I navigate with the 'Run . . ' dialog, it doesn't corrupt the screen.

comment:22 Changed 5 years ago by sunlover

Please attach VBox.log and provide some additional information:

1) Which guest/host is it? 32 or 64 bit?

2) You said you use a SMB share, is that right? Or do you use VBox shared folders actually?

3) Have you disabled the Web Client service in the guest?

Thanks.

comment:23 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response. Please reopen if you can provide more information. Especially, attach the VBox.log file of such a VM session.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use