VirtualBox

Ticket #17227 (closed defect: fixed)

Opened 11 months ago

Last modified 10 months ago

Kernel debug problem via pipe to com port => fixed in SVN/next maintenance

Reported by: michaeljo Owned by:
Priority: major Component: uart
Version: VirtualBox 5.2.0 Keywords: pipe com port
Cc: Guest type: Windows
Host type: Windows

Description

I have several windows guests that I have been using for driver development and kernel debugging (WinDbg) using a
.\pipe\com1 to the windows guest's com port. This has always worked but after upgrading to 5.2 WinDbg says: Retry sending the same data packet for 64 times. The transport connection between host kernel debugger and target Windows seems lost. please try resync with target, recycle the host debugger, or reboot the target Windows.

Attachments

VBox.log Download (112.9 KB) - added by michaeljo 11 months ago.
VBox.log

Change History

comment:1 Changed 11 months ago by aeichner

Please attach a VBox.log of one of the affected VMs please.

comment:2 Changed 11 months ago by vushakov

Likely a duplicate of #17239 which does provide logs.

Changed 11 months ago by michaeljo

VBox.log

comment:3 Changed 11 months ago by vushakov

  • Component changed from other to uart

comment:4 Changed 11 months ago by vushakov

Also #17093. This is likely the same regression.

comment:5 Changed 11 months ago by aeichner

  • Summary changed from Kernel debug problem via pipe to com port to Kernel debug problem via pipe to com port => fixed in SVN/next maintenance

Thanks for the report, this is indeed a regression in 5.2.0 and will be fixed with the next maintenance release.

comment:6 Changed 10 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use