VirtualBox

Ticket #17194 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

VBOX Guest additions 5.2 does not work with Ubuntu 17.10 -> guest configuration problem, please install gcc and make

Reported by: hl Owned by:
Component: other Version: VirtualBox 5.2.0
Keywords: Cc:
Guest type: other Host type: Windows

Description

I did install VirtualBox 5.2 in Windows 10 64-bit, version 1709 build 16299.19

The guest is Ubuntu 17.10 64-bit.

Neither version of the guest additions work. I tried with:

  • the version delivered together with VirtualBox
  • 118447
  • 118452

An error is produced during Linux startup: VBoxClient: VBoxClient (seamless): failed to start. Stage: Setting guest IRQ filter mask Error: VERR_INTERNAL_ERROR

Attachments

Ubuntu-2017-12-12-19-06-04.zip Download (45.8 KB) - added by hl 4 years ago.
Log with version from test builds
Ubuntu-2017-12-13-17-17-16.zip Download (209.6 KB) - added by hl 4 years ago.
screenshots and VB log

Change History

comment:1 Changed 4 years ago by vushakov

  • Status changed from new to closed
  • Resolution set to duplicate

comment:2 Changed 4 years ago by lothario

This ticket is marked as a dupe of a fixed one, but the bidirectional clipboard bridge still doesn't work between Ubuntu 16.04.3 host and Ubuntu Budgie 17.10 guest.

I've installed virtualbox-5.2_5.2.2-119230_Ubuntu_xenial_amd64.deb from the Downloads page. When booting the guest, I get

VBoxClient: VBoxClient (seamless): failed to start. Stage: Setting guest IRQ filter mask Error: VERR_INTERNAL_ERROR

comment:3 Changed 4 years ago by lothario

  • Status changed from closed to reopened
  • Resolution duplicate deleted

comment:4 Changed 4 years ago by michael

You did not provide a log file<1>. I wonder though whether you are using Guest Additions provided by Oracle or by Ubuntu.

  1. https://www.virtualbox.org/newticket

comment:5 Changed 4 years ago by michael

Looks similar to #17356.

comment:6 Changed 4 years ago by hl

I had installed the Additions from Oracle (downloaded from virtualbox.org).

note: the problem is still the same with VBoxGuestAdditions_5.2.3-119611.iso (from the test builds)

Changed 4 years ago by hl

Log with version from test builds

comment:7 Changed 4 years ago by hl

Adding Virtualbox logs

comment:8 Changed 4 years ago by michael

Then it looks like there was some problem installing the Additions, because the log file says that you are using the Ubuntu version. Anything of interest in Additions-related log files under /var/log on the guest? Do you have gcc, make and the right kernel headers installed on the guest?

comment:9 Changed 4 years ago by hl

I did the following test:

  • uninstall additions 5.1.30 from the Ubuntu VM and reboot VM
  • terminate VirtualBox
  • install VirtualBox 5.2.3 from test builds (on Windows 10)
  • start VirtualBox
  • boot Ubuntu VM
  • mount and install VBoxGuestAdditions_5.2.3-119611.iso from test builds
  • reboot Ubuntu VM

--> error occurs

Atttached info: screenshot of error message on Ubuntu screenshot of dmesg filtered on "vbox" VirtualBox log

Changed 4 years ago by hl

screenshots and VB log

comment:10 Changed 4 years ago by michael

Thank you. Could you please also attach the logs I asked for in comment 8?

comment:11 Changed 4 years ago by hl

One of the logs showed that make was missing, so the kernel modules could not be created. After installation of make the installation and setup of the VB additions is ok.

It seems that make was not needed for the additions 5.1.30 as it worked withot error ?

Thanks for your help. It seems to run now.

comment:12 Changed 4 years ago by michael

Ubuntu provides its own 5.1.28 kernel modules, which work with 5.1.30 Additions even if the 5.1.30 modules cannot be built. Ubuntu's modules are not compatible with our 5.2 Additions though.

comment:13 Changed 4 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to invalid
  • Summary changed from VBOX Guest additions 5.2 does not work with Ubuntu 17.10 to VBOX Guest additions 5.2 does not work with Ubuntu 17.10 -> guest configuration problem, please install gcc and make

comment:14 Changed 4 years ago by MM735

I run the actual Virtualbox on a Mac and have the same Problem. I do not know how to install gcc. Please help me!

Last edited 4 years ago by MM735 (previous) (diff)

comment:15 Changed 4 years ago by socratis

@MM735

The tickets are not the place to get help. The forums are:  https://forums.virtualbox.org/

comment:16 Changed 4 years ago by socratis

Just for completion, the problem the @MM735 was facing got resolved, see  https://forums.virtualbox.org/viewtopic.php?f=3&t=86664

No action needed on the ticket, it's already closed...

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use