VirtualBox

Ticket #17082 (closed defect: fixed)

Opened 15 months ago

Last modified 13 months ago

No more elevated rights after install of Guest Additions 5.1.28 on Windows -> fixed in 5.1.30

Reported by: tboerner Owned by:
Priority: major Component: guest additions
Version: VirtualBox 5.1.28 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

After installation of the Guest Additions for Windows 5.1.28 on Window 10 Pro no more programs with elevated rights can be executed. There is always a popup saying "The extended attributes are inconsistent". I found no way to execute anything with elevated righs. I am running Virtualbox 5.1.28 on Ubuntu 16.04.

Attachments

Screenshot from 2017-09-18 09-33-36.png Download (10.8 KB) - added by Zachary 15 months ago.
Windows Error
Screenshot from 2017-09-18 09-33-36.2.png Download (10.8 KB) - added by Zachary 15 months ago.
Windows Error
errors-vbox.evtx Download (68.0 KB) - added by isReal 15 months ago.

Change History

comment:1 Changed 15 months ago by tboerner

Only way to recover was to revert to a snapshot and not to install the new version of guest additions.

comment:2 Changed 15 months ago by gourdcaptain

I can report the same issue occuring to me with Virtualbox 5.1.28, Arch Linux 64-bit host, and a Windows 10 Pro guest (both 1607 and 1703).

comment:3 Changed 15 months ago by Denis.L

I can confirm the same issue with Windows 10 Pro 1703, both as host and guest. Came after update from 5.1.26 to 5.1.28.

comment:4 Changed 15 months ago by Denis.L

Have this issue also with Windows 10 Pro 1703 as guest and Windows 7 as host.

comment:5 Changed 15 months ago by WillFR

Same here.
Host: Linux Ubuntu 17.04
Guest: Windows 10 pro 1703

comment:6 Changed 15 months ago by keefw

Same here. Problem is with VBoxOGLpackspu.dll at offset 0x00041665. Did not exhibit in 5.1.26!

There are a number of fault entries in the Application event log -- all have the same faulting module and fault offset. Here are two examples of the fault event:

==Attempting to start an elevated PowerShell==

Faulting application name: consent.exe, version: 10.0.15063.0, time stamp: 0x4b028dca Faulting module name: VBoxOGLpackspu.dll, version: 5.1.28.17968, time stamp: 0x59b8f5de Exception code: 0xc0000005 Fault offset: 0x00041665 Faulting process ID: 0x11c8 Faulting application start time: 0x01d32f94f3aebf3f Faulting application path: C:\WINDOWS\system32\consent.exe Faulting module path: C:\WINDOWS\system32\VBoxOGLpackspu.dll Report ID: 156b5c66-3d98-4701-a7cf-891cba5e4231 Faulting package full name: Faulting package-relative application ID:

==logging into Windows -- which it seems to recover from==

Faulting application name: LogonUI.exe, version: 10.0.15063.0, time stamp: 0xe00e3d35 Faulting module name: VBoxOGLpackspu.dll, version: 5.1.28.17968, time stamp: 0x59b8f5de Exception code: 0xc0000005 Fault offset: 0x00041665 Faulting process ID: 0x350 Faulting application start time: 0x01d32f8bdad73ddf Faulting application path: C:\WINDOWS\system32\LogonUI.exe Faulting module path: C:\WINDOWS\system32\VBoxOGLpackspu.dll Report ID: e3fd3887-7aa2-4083-a482-88fbc914fcbb Faulting package full name: Faulting package-relative application ID:

Switching off 3D acceleration stops the problem from exhibiting.

Regards keefw

comment:7 Changed 15 months ago by wildanielen

I also have this problem

comment:8 Changed 15 months ago by Franc Drobnič

I can confirm that switching off 3D acceleration helps.

Changed 15 months ago by Zachary

Windows Error

Changed 15 months ago by Zachary

Windows Error

comment:9 Changed 15 months ago by Zachary

(Sorry about the two attachments that was a mistake) It also does gives this error during shutdown if you've got 3D acceleration enabled. +1 also have this issue.

comment:10 Changed 15 months ago by mhc

Î have two instances of Windows 10 (1703) running on a Debian 9.1 host with identical VBox parameters. One of the Windows guests shows the bug described above, including the error message during shutdown.

==> I can confirm that after switching off 3D acceleration the bug does not show up. Thanks to keefw!

Changed 15 months ago by isReal

comment:11 Changed 15 months ago by isReal

I can confirm the error showing up, prior to 5.1.28 all was fine. Error log attached. I can also confirm that disabling 3D acceleration is a successful workaround.

comment:12 Changed 15 months ago by flof76

Same problem on a MacBook and a Laptop with Arch Linux. I can confirm that when disabling 3d the error disapears.

comment:13 follow-up: ↓ 14 Changed 15 months ago by DmitrG

Could you check the latest Guest Additions from https://www.virtualbox.org/wiki/Testbuilds ? It contains fix for the problem.

comment:14 in reply to: ↑ 13 Changed 15 months ago by Franc Drobnič

Replying to DmitrG:

Could you check the latest Guest Additions from https://www.virtualbox.org/wiki/Testbuilds ? It contains fix for the problem.

Yes, VBoxGuestAdditions_5.1.29-118062 works for me as expected.

comment:15 Changed 15 months ago by isReal

Fixed for me per version 5.1.29-118062. Thanks for the prompt response! There are a number of other tickets that might be duplicates of this one. I think they all can be marked fixed.

comment:16 Changed 15 months ago by tobalur

I can confirm that the latest Guest Additions 5.1.29 seem to fix the problem.

Thanx for the quick response!

Have a nice weekend ;-)

comment:17 Changed 15 months ago by DmitrG

  • Status changed from new to closed
  • Resolution set to fixed

comment:18 Changed 14 months ago by michael

  • Summary changed from No more elevated rights after install of Guest Additions 5.1.28 on Windows to No more elevated rights after install of Guest Additions 5.1.28 on Windows -> fixed in 5.1.30

comment:19 Changed 14 months ago by ehaase

The same problem exists on macOS (High Sierra).

After updating Windows10 (amd64) to 2017 FALL Creators Update, then the error is no longer "The extended attributes are inconsistent" but instead it is "File system error (-107374819)."

Disabling 3d acceleration makes the problem go away, that is how one can install the 5.1.30 Guest Additions (they need elevated rights themselves).

Last edited 14 months ago by ehaase (previous) (diff)

comment:20 Changed 13 months ago by b-long

The issue also exists on a macOS 10.12 (Sierra) host running a Windows 10 (Version 1703, Build 15063.674) guest.

Disabling 3D acceleration resolved the problem I was observing ("The extended attributes are inconsistent.")

comment:21 Changed 13 months ago by Daleos

Not fixed on Windows 10 1709 Host with Windows 10 Insider Preview 17017 client.

I've tried every version of VB from 5.1.28 -> 5.2.2 and it just won't work with 3D acceleration enabled.

comment:22 Changed 13 months ago by DmitrG

Hi Daleos.

Have you updated Guest Additions alongside with VBox itself? The issue discussed here should be fixed in recent GA, please check again and attach Vbox.log or crashdump if problem persists.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use