VirtualBox

Ticket #17080 (reopened defect)

Opened 22 months ago

Last modified 21 months ago

guest additions do not build with 4.14 kernel -> fixed in builds after 1. November 2017, 5.2 and later

Reported by: robatino Owned by:
Component: other Version: VirtualBox 5.1.26
Keywords: Cc:
Guest type: Linux Host type: other

Description

Got an error message while attempting to install guest additions in a Fedora Rawhide guest for the 4.14.0-0.rc0.git5.1.fc28.x86_64 kernel.

vboxadd.sh: failed: Look at /var/log/vboxadd-install.log to find out what went wrong.

Attachments

VBox.log Download (123.0 KB) - added by robatino 22 months ago.
vboxadd-install.log Download (241.1 KB) - added by robatino 22 months ago.
/var/log/vboxadd-install.log
vboxadd-install.2.log Download (241.1 KB) - added by robatino 22 months ago.
/var/log/vboxadd-install.log with 5.1.28
vboxadd-install.3.log Download (247.6 KB) - added by robatino 21 months ago.
/var/log/vboxadd-install.log with 5.1.30
VBox.2.log Download (118.6 KB) - added by robatino 21 months ago.
VBox.3.log Download (126.1 KB) - added by robatino 21 months ago.
VBox.log for VirtualBox 5.2.0, Fedora 27 guest, 4.13.8-300.fc27.x86_64 kernel
vboxadd-setup.log Download (223.6 KB) - added by robatino 21 months ago.
vboxadd-setup.log for VirtualBox 5.2.0, Fedora 27 guest, 4.13.8-300.fc27.x86_64 kernel
vboxadd-setup.2.log Download (237.1 KB) - added by robatino 21 months ago.
vboxadd-setup.log for VirtualBox 5.2.0, Fedora Rawhide guest, 4.14 kernel
VBox.4.log Download (142.3 KB) - added by robatino 21 months ago.

Change History

Changed 22 months ago by robatino

Changed 22 months ago by robatino

/var/log/vboxadd-install.log

comment:1 follow-up: ↓ 2 Changed 22 months ago by michael

Is this still the case with VirtualBox 5.1.28?

Changed 22 months ago by robatino

/var/log/vboxadd-install.log with 5.1.28

comment:2 in reply to: ↑ 1 Changed 22 months ago by robatino

Replying to michael:

Is this still the case with VirtualBox 5.1.28?

I didn't see any error when installing the GA for that kernel, but the vboxadd-install.log file still shows errors, so I'm guessing yes.

comment:3 Changed 22 months ago by DTI

Hello,

problem is change in the linux kernel  https://lkml.org/lkml/2017/8/29/254

I build my kernel with the vboxvideo module from the staging area.

I dont know if the problem is solved in 5.1.28

Best regards Damian

comment:4 Changed 22 months ago by robatino

While installing a new 4.14 kernel in 5.1.28 after my last comment, I saw the same error messages as before, so definitely not solved.

Changed 21 months ago by robatino

/var/log/vboxadd-install.log with 5.1.30

Changed 21 months ago by robatino

comment:5 Changed 21 months ago by robatino

Same error with 5.1.30 (see above 2 attachments).

comment:6 Changed 21 months ago by robatino

In VirtualBox 5.2.0, I get an error message even with previously fixed kernels. The following message and logs are with a Fedora 27 guest installing the 4.13.8-300.fc27.x86_64 kernel.

VirtualBox Guest Additions: Look at /var/log/vboxadd-setup.log to find out what went wrong

It's not clear whether this is an error or just a warning or whether the Guest Additions are installed or not. Are they, and does this need to be filed as a new bug? Is it known already?

Changed 21 months ago by robatino

VBox.log for VirtualBox 5.2.0, Fedora 27 guest, 4.13.8-300.fc27.x86_64 kernel

Changed 21 months ago by robatino

vboxadd-setup.log for VirtualBox 5.2.0, Fedora 27 guest, 4.13.8-300.fc27.x86_64 kernel

comment:7 Changed 21 months ago by michael

Please try the updated images on the downloads page which should fix both problems.

comment:8 Changed 21 months ago by robatino

The later of the two images mentioned (VBoxGuestAdditions_5.2.1-118452.iso) appears to fix the problem with recent kernels, but not experimental 4.14 kernels. (I didn't try 118447, hoping 118452 would fix both problems.) Attaching files for Rawhide guest.

Changed 21 months ago by robatino

vboxadd-setup.log for VirtualBox 5.2.0, Fedora Rawhide guest, 4.14 kernel

Changed 21 months ago by robatino

comment:9 Changed 21 months ago by DTI

Hello,

the problem is the function pointer load_lut in the kernel struct drm_crtc_helper_func was removed.

Best regards Damian

comment:10 follow-up: ↓ 19 Changed 21 months ago by robatino

I tested 118447, and it also appears to fix the problem with recent kernels, though with either image I see the following errors in vboxadd-setup.log.

At main.c:160:
- SSL error:02001002:system library:fopen:No such file or directory: crypto/bio/bss_file.c:74
- SSL error:2006D080:BIO routines:BIO_new_file:no such file: crypto/bio/bss_file.c:81
sign-file: certs/signing_key.pem: No such file or directory

Since 118452 does not fix the problem with 4.14 kernels, the reference to it should be removed from https://www.virtualbox.org/wiki/Downloads .

comment:11 follow-up: ↓ 12 Changed 21 months ago by socratis

I believe that the error you're seeing is due to the fact that you're loading signed kernel extensions, which VirtualBox doesn't provide. You will either need to disabled signed extensions or sign them with your own key.

I recently saw that comment from a developer, can't claim that as my own and I might be misquoting, but I think I'm really close. I'm trying to find the exact reference, but I can't at the moment...

comment:12 in reply to: ↑ 11 Changed 21 months ago by vushakov

Replying to socratis:

I recently saw that comment from a developer, can't claim that as my own and I might be misquoting, but I think I'm really close. I'm trying to find the exact reference, but I can't at the moment...

#17206

comment:13 Changed 21 months ago by vushakov

  • Status changed from new to closed
  • Resolution set to duplicate

comment:14 Changed 21 months ago by socratis

Hey... I was really, really close, if not spot-on! No checkup for my memory module needed... :D

Thanks vushakov!

comment:15 Changed 21 months ago by robatino

It's not clear to me why you closed this bug. Does 17206 prevent building 4.14 Guest Additions?

comment:16 Changed 21 months ago by robatino

  • Status changed from closed to reopened
  • Resolution duplicate deleted

comment:17 Changed 21 months ago by socratis

The building process fails due to your requirement for having signed kernel modules. Just like in #17205. So, it's a duplicate of #17205. Ergo, closed as a duplicate.

Or put in another way, it's not the 4.14 kernel that's the problem. The error that you're getting is due to the signed kernel modules requirement. You're focusing on the wrong parameter.

Too bad you chose to reopen the ticket without actually testing the proposed solution, or maybe you didn't realize what the nature of the "issue" was...

comment:18 Changed 21 months ago by robatino

Just to be clear, I'm not talking about the error I mentioned offhand in comment 10. I'm talking about the 4.14-specific errors reported before that (such as those that appear in my vboxadd-setup.log attachment in comment 8) which are why I opened this ticket in the first place. Is there a fix for that, and if so, can you point me to a fixed image so I can test it?

Edit: BTW, the error from comment 10 does not appear to prevent me from building GA for 4.13. I do that regularly. The GA build only fails for 4.14.

Last edited 21 months ago by robatino (previous) (diff)

comment:19 in reply to: ↑ 10 Changed 21 months ago by socratis

Well, that's what happens when you throw too many parameters and logs all lumped together, you throw people off. I was specifically replying to your comment 10 and that specific error message. And vushakov closed the ticket based on that. Simple.

There are so many tickets, threads in the forums and chats in the IRC that it's not humanly possible to review every single comment or history of a ticket every time. When you stir the waters with a new comment, I read the last comment. And your comment 10 was:

I tested 118447, and it also appears to fix the problem with recent kernels, though with either image I see the following errors in vboxadd-setup.log.

At main.c:160:
- SSL error:02001002:system library:fopen:No such file or directory: crypto/bio/bss_file.c:74
- SSL error:2006D080:BIO routines:BIO_new_file:no such file: crypto/bio/bss_file.c:81
sign-file: certs/signing_key.pem: No such file or directory

So, do you see what you did there? You declared that build 118447 fixes the issues except your SSL ones. To which I replied to use non-signed kernel modules. To which vushakov (correctly) remembered the quoted text of mine and closed your bug as a duplicate.

Had you not changed and mixed the comments involved, none of that would have happened.

Is there a fix for that, and if so, can you point me to a fixed image so I can test it?

Always test the latest builds. I mean you are running an experimental kernel to begin with. The developers have barely enough time to fix existing kernel issues. Don't really push for the experimental ones until they're released. They deal with it, they simply don't have to support them before they are released, and even then it may take some time.

Try the latest release of VirtualBox (at revision 118468 as of this writing) from https://www.virtualbox.org/wiki/Testbuilds at the "Development snapshots".

comment:20 follow-up: ↓ 21 Changed 21 months ago by robatino

No, when I said it fixes the problem with recent kernels, I was repeating the language at https://www.virtualbox.org/wiki/Downloads , which refers to fixing "recent Linux guest kernels". That language IS confusing, since it doesn't explain that 4.14 isn't included, but I thought that since it's still posted there, I could repeat it without being misunderstood. And given that this ticket is 6 weeks old, the only alternative to attaching all the logs to this ticket, is filing a new one, which I thought would be bad practice since the original isn't fixed yet. Let me know if I should do that.

Edit: Just checked using the Development snapshot 118468 of the GA. Building 4.14 GA still fails with the same error as before (the one mentioned in comment 9).

Edit: Regarding comment 21, I only tested 118468 because YOU asked me to (and I made it an Edit: so as not to generate an additional email). I'm not trying to get anyone's attention.

Last edited 21 months ago by robatino (previous) (diff)

comment:21 in reply to: ↑ 20 Changed 21 months ago by socratis

Replying to robatino:

Just checked using the Development snapshot 118468 of the GA. Building 4.14 GA still fails with the same error as before (the one mentioned in comment 9).

OK, fine leave it at that, do not keep on commenting in the hopes that it will get more attention or a higher priority. I'm sure the developers already know about it. As it is stated in the Downloads:

For experimental Linux 4.14 support, please try this image.

So, you'll have to be a little bit more patient as they get around the issues. If you want to keep track of the changes and to know if the issue is being addressed in "real-time", check out the Timeline (https://www.virtualbox.org/timeline) which shows you the patches that go into VirtualBox.

If you see something related, like "addresses 4.14 building issues" or "fixes the problem in the function pointer load_lut in the kernel struct drm_crtc_helper_func was removed, see #17080" or something similar, you can ask politely either here or in the IRC for a development build to try out. Like a "Hey there, I noticed a fix for XYZ in changeset 12345, can you create a test build to try it out?". They have never refused ;)

comment:22 Changed 21 months ago by michael

I have updated the link on the downloads page<1>. Please give the new build a try.

  1. https://www.virtualbox.org/wiki/Downloads

comment:23 Changed 21 months ago by robatino

VBoxGuestAdditions_5.2.1-118868.iso works for building 4.14 GA! Thanks.

comment:24 Changed 21 months ago by michael

  • Summary changed from guest additions do not build with 4.14 kernel to guest additions do not build with 4.14 kernel -> fixed in builds after 1. November 2017, 5.2 and later
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use