VirtualBox

Ticket #1707 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Cannot remember size and state of window. Starting from ver. 1.6.0

Reported by: vladaz Owned by:
Priority: major Component: GUI
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: other
Host type: other

Description

My host system: Kubuntu 8.04 Hardy Virtual Machine: Windows XP When I had innotek 1.5.6 version, my Windows XP was configured to be launched in full screen, and everything worked splendid. Starting from ver. 1.6.0 my sunVM isn't able to remember, what size of window it was when stopped last time. Also it isn't able to launch itself in full screen mode. I thought, that this annoying bug of 1.6.0 must have been repaired with 1.6.2, but it unfortunately resisted. The worse thing on it is, that each time I open my sunVM Windows, I have to rearrange the icons on desktop. What's vasting time, because next all icons will be again gathered in small rentacle of 640x480 pixels ..... I'm starting to think about migration to VmWare, sorry ...

Attachments

vm_01_start.jpg Download (82.3 KB) - added by vladaz 6 years ago.
Start of work each day
vm_04_after_VM_power_off_windowed.jpg Download (74.4 KB) - added by vladaz 6 years ago.
It was big window before stopping virtual windows.
vm_02_after_resize_to_what_i_want.jpg Download (82.4 KB) - added by vladaz 6 years ago.
vm_03_icons_re-arranged.jpg Download (81.8 KB) - added by vladaz 6 years ago.
Re-arranged icons. I want it can be in this design after I turno off and power on the VM
vm_04_after_VM_power_off_fullscreened.jpg Download (55.4 KB) - added by vladaz 6 years ago.
this is after power on. It seems like full screen, but it doesn't fit my real screen

Change History

comment:1 follow-up: ↓ 3 Changed 6 years ago by frank

WinXP guests definitely remember their geometry. And the fullscreen bug was fixed with version 1.6.2. as well. I guess you didn't update your guest additions or the update was not successful for some reason. Please check the version of your guest additions.

comment:2 Changed 6 years ago by rgesswein

I can confirm this as well. For me WinXP guest always starts at 800x600x32. I even tried uninstalling the guest additions completely and reinstalling them (version 1.6.2). No change in behavior. The setting is saved when I "reboot" rather than having turning off the guest completely.

The screen dimensions I'm trying to save are an odd size: 1272x702. Could this have something to do with it? Also, after a I boot the guest, nothing greater than 800x600 shows up in the list of available modes. Maybe this?

Changed 6 years ago by vladaz

Start of work each day

Changed 6 years ago by vladaz

It was big window before stopping virtual windows.

comment:3 in reply to: ↑ 1 Changed 6 years ago by vladaz

Replying to frank:

WinXP guests definitely remember their geometry. And the fullscreen bug was fixed with version 1.6.2. as well. I guess you didn't update your guest additions or the update was not successful for some reason. Please check the version of your guest additions.

I don't think the bug is definately resolved. At least in Kubuntu 8.04 it doesn't work. I'm talking about four different computers (2 desktops and 2 notebooks). Only one thing is same for the machines: Kubuntu Hardy 8.04. The computers differ one to each in all other: mainboards, graphic cards, three of them with KDE3 and one with KDE4. Guest Additions are really the latest version. I checked the drivers in WinXP control panel (driver is from May 30, 2008; VBoxVideo.sys and the according VBoxDisp.dll are 1.6.2.31466).

I want to start machine in fullscreen 1400x1050. It worked, as I mentioned, in 1.5.6 version of VirtualBox. As rgesswein wrote, only when reboot or when "save VM state" the window size and configuration is saved. When you shutdown VM, everything is lost again. You can see sequence of screenshots I made.

Changed 6 years ago by vladaz

Changed 6 years ago by vladaz

Re-arranged icons. I want it can be in this design after I turno off and power on the VM

Changed 6 years ago by vladaz

this is after power on. It seems like full screen, but it doesn't fit my real screen

comment:4 follow-up: ↓ 5 Changed 6 years ago by frank

Does autoresize work for you? That is, what happens if the VM window is not in fullscreen and your resize the window: does the guest size change as well or not? From your screenshots I miss the small tray icon for the VirtualBox guest additions. Is this icon hidden or is the VBoxTray application not active?

comment:5 in reply to: ↑ 4 Changed 6 years ago by vladaz

Replying to frank:

Does autoresize work for you? That is, what happens if the VM window is not in fullscreen and your resize the window: does the guest size change as well or not? From your screenshots I miss the small tray icon for the VirtualBox guest additions. Is this icon hidden or is the VBoxTray application not active?

Yes, autoresize works well (in windowed mode, guest size changes with window size changes accordingly). The trayicon is hidden. It's the blue cube-computer shape icon. The latest one for 1.6.2.

comment:6 Changed 6 years ago by cornbread

I have the same issue didn't see this bug earlier. My posted bug is #1722. I have the icon issue as well. Big regression from 1.5.4 I have to move my icons back to normal every time.

comment:7 Changed 6 years ago by vladaz

Unfortunately in the new 1.6.4 version the behaviour is unchanged. (Well, I read the changelog and it's clear from there, that the bug is not fixed yet.) One important thing I want to emphasize today. rgesswein pointed to that. VM's window size is forgotten each time the VM is completly stopped. If you restart windows only, or stop VM with current state saving, the parameters of screen aren't lost. It means: one have never stop VM completely and everything will be okay. (Unfortunatelly there are cases when VM application must be stopped.) Moreover: window size of application is saved well in VirtualBox.xml and in <machine>.xml. As far as I can understand the section <ExtraDataItem name="GUI/LastWindowPostion" value="0,0,1380,975"/> about last window position in the files. Even after complete stop of virtual machine the correct value is still there. It means, that the bug must happen during new start of VM, not in closing time of it.

comment:8 Changed 6 years ago by frank

  • Component changed from other to GUI

comment:9 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this bug is still present for you with VirtualBox 3.0.0. This works for me for ages but that release contains a minor fix which could be related.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use