VirtualBox

Ticket #17004 (closed defect: fixed)

Opened 6 weeks ago

Last modified 3 days ago

Virtual machine dies instantly when unplugging external thunderbolt display

Reported by: smayoo Owned by: pentagonik
Priority: minor Component: other
Version: VirtualBox 5.1.26 Keywords: crash external monitor thunderbolt
Cc: smayoo@… Guest type: Windows
Host type: Mac OS X

Description

This never happened before, I only noticed it after last update to VirtualBox 5.1.26 r117224. If I have a virtual machine window on an external thunderbolt display, it dies instantly (crashes without a sound or any kind of alert) when I unplug the thunderbolt cable from my Apple MacBookPro. Maybe it has nothing to do with external display, but with something else I use over that Thunderbolt link (ethernet connection, usb keyboard and mouse, external hard drive in a thunderbolt dock). But it definitely didn't happen before. Host computer is Apple MacBookPro 15" non-retina Mid 2012 (MacBookPro 9,1) with 16 GB RAM, 480 GB SanDisk SDSSDXPS480G, Nvidia GT650M, running Mac OS X 10.11.6. Guest machine is MS Windows XP SP3, 3GB RAM.

Attachments

VirtualBoxVM_2017-08-12-165509_jabook-2.crash Download (83.6 KB) - added by smayoo 6 weeks ago.
Crash report from window server
VirtualBoxVM_2017-08-12-165509_jabook-2.2.crash Download (83.6 KB) - added by smayoo 6 weeks ago.
Crash report from window server
All Messages.log Download (6.6 KB) - added by smayoo 6 weeks ago.
system console log grep on "virtualbox"

Change History

comment:1 in reply to: ↑ description Changed 6 weeks ago by socratis

Replying to smayoo:

Maybe it has nothing to do with external display, ...in a thunderbolt dock.

I cannot reproduce the problem with an external display over the Thunderbolt port (Thunderbolt -> DVI -> Apple Studio 17"). The worst case scenarion is that WinXP goes on full-display in another space in the main monitor, and goes back to its own space in the second monitor as soon as I replug the Thunderbolt cable:

  • Host: OSX 10.11.6
  • VirtualBox: 5.1.26 r117224 (Qt5.6.2), 5.2.0_BETA1 r117406 (Qt5.6.2)
  • Guest: WinXP SP3

I left on purpose the "dock" part of your description. Since there are more that one things going on, could you limit it to what actually crashes the guest? And is it just the guest or everything VirtualBox* including the VirtualBox Manager?

Changed 6 weeks ago by smayoo

Crash report from window server

Changed 6 weeks ago by smayoo

Crash report from window server

Changed 6 weeks ago by smayoo

system console log grep on "virtualbox"

comment:2 Changed 6 weeks ago by smayoo

Grrr... I wrote a detailed reply, but it got destroyed when I uploaded the attachments. :-[ The crash report is accidentally uploaded twice, but I can't delete the extra copy. The guest window crash is 100% repeatable (virtualbox manager window is unaffected, and after the crash, it reports the virtual machine as "aborted"), regardless of what else is connected or disconnected to the thunderbolt dock. So - it seems that the problem stays with the display itself. Also, guest crashes both ways - when I DISconnect the display, but also when I connect it. Only difference is that on DISconnection, the crash is instanteneous, and on connection the guest window lingers for a second and then crashes. Attaching a Mac OS Window Server crash log (the latest one, there's one for every attempt I made), and a Console Log excerpt (grep virtualbox).

comment:3 Changed 6 weeks ago by aeichner

Your crash reporti ndicates an audio related crash. Please check if the latest test build fixes your problem. It contains a fix for an audio crash which was not yet fixed in 5.1.26.

comment:4 Changed 6 weeks ago by smayoo

Thanks, it's downloading. What if I run into some other (more severe) problems? Can I just install the "official" version back over it?

Last edited 6 weeks ago by smayoo (previous) (diff)

comment:5 Changed 6 weeks ago by aeichner

Sure installing the old version will work just fine. The testbuild is from the stable branch just containing additional bugfixes which will go into the next maintenance release, so the chance of regressions is very low (although not 0).

comment:6 Changed 6 weeks ago by smayoo

The latest test build does indeed fix the problem. Thank you!

comment:7 Changed 6 weeks ago by frank

Thanks for the feedback! It makes indeed some sense that your thunderbolt problem was actually audio-related.

comment:8 Changed 3 days ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to assigned

comment:9 Changed 3 days ago by pentagonik

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use