VirtualBox

Ticket #16970 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Non-windows guests crash on headphones connect or disconnect

Reported by: ahuzik Owned by: pentagonik
Component: audio Version: VirtualBox 5.1.26
Keywords: mac audio crash linux Cc:
Guest type: Linux Host type: Mac OS X

Description

Steps to reproduce:

  1. start a guest
  2. wait for it to boot (for linux crash can't be reproduced in grub menu, in the beginning of a boot sequence, but after some point in a boot sequence it can be reproduced every time (regardless of whether X11 is started or not)
  3. connect or disconnect headphones (tested with both regular wired headphones and bluetooth headphones). Alternatively you may just click on volume icon in macOS system tray and select different audio output device.

Expected result: guest continues to work, using new active audio output

Actual result: guest crashes (crash report attached)

Host: macOS Sierra 10.12.6 (16G29)

Guests crashing:

  • Linux nixos 4.9.39 #1-NixOS SMP Fri Jul 21 05:42:36 UTC 2017 x86_64 GNU/Linux (guest additions installed)
  • Haiku shredder 1 hrev51050 Mar 28 2017 17:40:13 BePC x86 Haiku (no guest additions)

Guests not crashing:

  • Microsoft Windows [Version 10.0.14393] (guest additions installed)
  • KolibriOS v0.7.7.0. Kernel SVN-rev.: 6880 (no guest additions)

Tested on both latest stable and latest test (Version 5.1.27 r117314 (Qt5.6.2)) build. Virtualbox extensions are installed.

Attachments

vbox-crash-report.txt Download (88.5 KB) - added by ahuzik 3 years ago.
VM crash report (linux guest)

Change History

Changed 3 years ago by ahuzik

VM crash report (linux guest)

comment:1 Changed 3 years ago by pentagonik

Thanks for the report. I think I found and fixed the issue -- I'll provide a new test build later today.

comment:2 Changed 3 years ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to assigned

comment:3 follow-up: ↓ 4 Changed 3 years ago by pentagonik

Please have a try using build 117332, which is available for download here:

https://www.virtualbox.org/download/testcase/VirtualBox-5.1.27-117332-OSX.dmg

This should (hopefully) fix the crashes. Thanks!

comment:4 in reply to: ↑ 3 Changed 3 years ago by ahuzik

Works great! Thanks a lot!

comment:5 Changed 3 years ago by pentagonik

Thanks for letting us know -- the fix will be available in the next upcoming maintenance version.

comment:6 Changed 3 years ago by pentagonik

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:7 Changed 3 years ago by doogie

I found this ticket because I was experiencing the same issue. I can also confirm the test build fixed the issue for me. Thank you!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use