VirtualBox

Ticket #16969 (closed defect: fixed)

Opened 4 months ago

Last modified 9 days ago

VirtualBox Vm crashes when bluetooth audio device is connected to host

Reported by: Jamison Owned by: pentagonik
Priority: major Component: audio
Version: VirtualBox 5.1.26 Keywords: audio crash
Cc: Guest type: Linux
Host type: Mac OS X

Description

The VirtualBox VM crashes immediately upon connecting a bluetooth audio device to my host. This problem started occurring after updating to VirtualBox 5.1.26. I don't recall my previous version number, but it was probably the previous public released version (5.1.24).

The issue is very easy for me to consistently reproduce on equipment.

Host OS: macOS Sierra 10.12.6 Guest OS: Ubuntu 14.04 LTS Virtual Box: 5.1.26 r117224 Audio Device: Bose QuietControl 30 Firmware 1.2.9

Other Details: I think this is different from #16268.

Attachments

VBox.log Download (110.6 KB) - added by Jamison 4 months ago.
VirtualBox log
crash.log Download (84.7 KB) - added by Jamison 4 months ago.
macOS crash log

Change History

Changed 4 months ago by Jamison

Changed 4 months ago by Jamison

macOS crash log

comment:1 Changed 4 months ago by pentagonik

Thanks for the report. I think I found and fixed the issue -- I'll provide a new test build later today.

comment:2 Changed 4 months ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to assigned

comment:3 follow-up: ↓ 4 Changed 4 months ago by pentagonik

Please have a try using build 117332, which is available for download here:

https://www.virtualbox.org/download/testcase/VirtualBox-5.1.27-117332-OSX.dmg

This should (hopefully) fix the crashes. Thanks!

comment:4 in reply to: ↑ 3 Changed 4 months ago by Jamison

Thank you for the quick response and fix. I tested build 117332 and it fixed the crash. Thanks again!

comment:5 Changed 4 months ago by pentagonik

Thanks for letting us know -- the fix will be available in the next upcoming maintenance version.

comment:6 Changed 4 months ago by pentagonik

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:7 Changed 2 months ago by MikeyT

Hi the link to the build with the bug fix is 404ing.

comment:8 Changed 2 months ago by klaus

Seems our internal policy of never pointing to specific testbuilds (since they get deleted automatically after 3 weeks) is still getting ignored :)

Simply get the latest Testbuilds instead.

comment:9 Changed 9 days ago by pentagonik

Any news here regarding using the test builds?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use