VirtualBox

Ticket #16953 (closed defect: duplicate)

Opened 8 weeks ago

Last modified 4 days ago

VirtualBox UI crashes when searching for files under MacOS

Reported by: Promet Owned by:
Priority: minor Component: VM control
Version: VirtualBox 5.1.26 Keywords: search, macos
Cc: Guest type: all
Host type: Mac OS X

Description

It happens on my Mac since VirtualBox 5.1.22 or probably even earlier, and continues to be so under 5.1.26.

Every time when I am setting my virtual machine preferences, such as mounting ISOs, appointing shared folders, if I search for files in the opened dialog window, the VirtualBox UI will crash suddenly.

But this does not affect the operating virtual machines, if there is any. Therefore I think it is some sort of UI bug instead of anything underlying goes wrong.

Change History

comment:1 Changed 8 weeks ago by frank

Sounds related to #16935.

comment:2 Changed 8 weeks ago by socratis

It most certainly does frank, and Promet correctly continued the discussion in #16935. So, if you could close this as duplicate so that all further discussion continues in #16935.

comment:3 Changed 8 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks. I assume it's an issue with a 3rd-party shared library.

comment:4 Changed 6 weeks ago by frank

We think we fixed the problem. Could you install the most recent 5.1 Mac OS X test build >= revision 117470 to verify if it resolves your problem?

comment:5 Changed 4 days ago by Uli

Not fixed - 5.1.28 continues to have this issue for me. I can reproduce it easily (not every time, but maybe every other time) with many file-related operations, for example drag-moving files to another folder, and even bash file name completion (e.g. type "cat .bas", hit Tab => hang). The entire UI hangs and does not come back - I force close Virtualbox and restart, don't know if there's another workaround. I am running MacOS Sierra 10.12.6 client on MacOS Sierra 10.12.6 host. Restarting host and client to clean things up does not make a difference for reproducing the problem.

This a fairly recent issue for me - I think I first saw it in 5.1.24, and I always use these same kinds of file operations, and I did not have the issue previously. I might not have used a version or two before 5.1.24, but the problem does not go back further than that for me.

Just to be clear - I am browsing files inside the client to trigger the hang.

Last edited 4 days ago by Uli (previous) (diff)

comment:6 in reply to: ↑ description Changed 4 days ago by socratis

Uli,

This ticket is a duplicate of #16935, so it would be wiser to continue the discussion there, or in the forums (preferably, see below).

But, I just want to point out that this ticket as well as #16935 are about a "Spotlight" hang on the host, and what you're describing doesn't sound like that. You seem to have generic file operations issues, like tab-completion. And it is something that it is happening on the guest, not on the host . See the differences:

Original poster: But this does not affect the operating virtual machines, if there is any.

Uli: Just to be clear - I am browsing files inside the client to trigger the hang.

So, maybe what you're seeing is something completely different, not a Spotlight issue on the host. So, if you can, please open a new thread in the  Mac OS X Guests section of the forums to discuss this further and figure out whether it deserves a ticket or not.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use