VirtualBox

Ticket #16938 (closed defect: fixed)

Opened 3 months ago

Last modified 3 months ago

since 5.1.24 not just one PulseAudio sink gets created but 10

Reported by: Bard0 Owned by: pentagonik
Priority: minor Component: audio
Version: VirtualBox 5.1.24 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

i am running debian, but same happens (at least) on Arch as well. For linux VM's (with Audio being ICH AC97), there are too many sinks created on the host. I am currently working around this by using Intel Audio instead.

The host has too many audio controls (sliders) and after just 2 VM's (which use up 20 of them) i can no longer control host applications volume in the mixer.

Change History

comment:1 Changed 3 months ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to assigned

comment:2 Changed 3 months ago by pentagonik

Reproduced this locally. Investigating.

comment:3 Changed 3 months ago by pentagonik

Found (and hopefully) fixed the error. I'll supply a test build shortly.

comment:4 Changed 3 months ago by pentagonik

The files can be downloaded from the test builds page.

Last edited 3 months ago by frank (previous) (diff)

comment:5 Changed 3 months ago by Bard0

First: since you could reproduce, i trust your tests.

Second: although my comp is not set up like a dev machine, i did create a test partition, and installed the test build there. So i could see myself, that there is only 1 sink now (as it should be). But the effort to manage different versions is too high to my liking. Thus i am going to wait for the released version and only then switch back to the former Audio-Chipset-Configuration.

Well, nice to see, you got this one nailed pretty fast! Good job. :-)

comment:6 Changed 3 months ago by pentagonik

Thanks for confirming -- No problem, I think this is good enough to at least try it once, as I also was able to see this locally.

The fix will be included in the next upcoming maintenance version.

comment:7 Changed 3 months ago by pentagonik

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use