VirtualBox

Ticket #16935 (closed defect: fixed)

Opened 2 months ago

Last modified 5 days ago

First character typed into Spotlight field on macOS 10.12.5 crashes VirtualBox UI -> fixed in 5.1.28

Reported by: ntg Owned by:
Priority: minor Component: GUI
Version: VirtualBox 5.1.24 Keywords: spot
Cc: Guest type: all
Host type: Mac OS X

Description

Having created a new VM, I want to attach an .ISO before first boot. Since I don't remember exactly where I saved my .ISO file, I would like to use Finder's built-in Spotlight search box to help me locate it.

I can consistently cause VirtualBox to crash by:

  1. Launch VirtualBox
  2. Select an existing VM from the left sidebar
  3. Under "Storage", click any disk image value to the right of the "SATA Port" labels
  4. Click "Choose disk image..."
  5. The Finder dialog window is presented
  6. Click once in the Spotlight search field (to focus)
  7. Type one or more characters

Expected result: Spotlight search results matching what was typed in the Spotlight field

Actual result: Crash

Upon further investigation, steps 2-4 can be replaced with *any* action(s) which cause VirtualBox to display a Finder dialog. The result is the same.

OS: 10.12.5 (Sierra) Hardware: MacBook Air (mid-2013)

Change History

comment:1 follow-up: ↓ 2 Changed 2 months ago by socratis

I cannot reproduce the above scenario.

  • Host: 10.11.6 (15G1611)
  • VirtualBox: 5.1.25 r.117110 (Qt5.6.2)
  • Guest: Any

To be honest, that's the first such instance that I've heard that. Are you running anything special on your host? Do you have any connected network volumes? External drives? Do you have any other Qt-based programs installed?

comment:2 in reply to: ↑ 1 Changed 8 weeks ago by Promet

Replying to socratis:

I cannot reproduce the above scenario.

  • Host: 10.11.6 (15G1611)
  • VirtualBox: 5.1.25 r.117110 (Qt5.6.2)
  • Guest: Any

To be honest, that's the first such instance that I've heard that. Are you running anything special on your host? Do you have any connected network volumes? External drives? Do you have any other Qt-based programs installed?

I experience the same situation.

One thing unusual in my case is that most of my VMs and files are located in an external drive, probably this is the problem?

comment:3 Changed 8 weeks ago by frank

Could you attach the output of

dtruss VirtualBox

and reproduce the crash? It might be necessary to make dtruss 'chmod u+s', I cannot test this currently.

comment:4 Changed 8 weeks ago by socratis

@Promet
I'll briefly include your report from #16953, which is most probably a duplicate, so that we have the full picture of your problem as well:

VirtualBox UI crashes when searching for files under MacOS

It happens on my Mac since VirtualBox 5.1.22 or probably even earlier, and continues to be so under 5.1.26.

Every time when I am setting my virtual machine preferences, such as mounting ISOs, appointing shared folders, if I search for files in the opened dialog window, the VirtualBox UI will crash suddenly.

But this does not affect the operating virtual machines, if there is any. Therefore I think it is some sort of UI bug instead of anything underlying goes wrong.


I too have VMs that are on external hard drives, and I also have VMs that are on network drives. No problem searching for and/or browsing for ISOs, VDIs, or anything else for that matter.

Can you think of anything out of the ordinary that is installed in your system? There's got to be a 3rd party application that interferes with VirtualBox (most probably with Qt).

comment:5 Changed 8 weeks ago by frank

As this problem appears to have started my assumption is that some 3rd-party shared library is supposed to be loaded but wouldn't due to increased security checks in 5.1.22 and Qt/whatever cannot handle this case. dtruss will hopefully show the problem.

comment:6 Changed 6 weeks ago by frank

We think we fixed the problem. Could you install the most recent 5.1 Mac OS X test build >= revision 117470 to verify if it resolves your problem?

comment:7 Changed 5 days ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from First character typed into Spotlight field on macOS 10.12.5 crashes VirtualBox UI to First character typed into Spotlight field on macOS 10.12.5 crashes VirtualBox UI -> fixed in 5.1.28
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use