VirtualBox

Ticket #16911 (closed defect: fixed)

Opened 3 months ago

Last modified 3 months ago

hostonly network broken on 5.1.24

Reported by: mrvanes Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.22 Keywords:
Cc: Guest type: other
Host type: Linux

Description

After upgrading to 5.1.24 my hostonly network failed:

$ ping 192.168.56.101
PING 192.168.56.101 (192.168.56.101) 56(84) bytes of data.
From 145.145.17.101 icmp_seq=12 Destination Net Unreachable

Probably because virtualbox failed to create a route for vboxnet0:

# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         194.171.172.1   0.0.0.0         UG    600    0        0 wlp59s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlp59s0
194.171.172.0   0.0.0.0         255.255.252.0   U     600    0        0 wlp59s0

I tried to create a route by hand but this failed:

# ip route add 192.168.56.0/24 dev vboxnet0 
RTNETLINK answers: Network is down

Reverting back to 5.1.22 solved my problem. This was tested on a vanilla 4.12.1 kernel.

Change History

comment:1 Changed 3 months ago by aleksey

Did you check if bridged attachment worked? In other words, was it host-only issue or were both host-only and bridged affected? What did ip addr show dev vboxnet0 say?

comment:2 Changed 3 months ago by opi99

Same issue here ... the vboxnet0 do not come up.

$ sudo ifconfig
br0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
...
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
...
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
...

Last edited 3 months ago by opi99 (previous) (diff)

comment:3 Changed 3 months ago by mrvanes

I did not check bridged attachment and I don't fancy toggling versions on a production system just to see if things are working or not. Especially since getting 5.1.22 to work needs applying the 4.12 patch. In contrast to what opi99 says, I did see a vboxnet0 device and it did get an address from dhcp server (192.168.56.1) after starting the guest. It just doesn't work.

comment:4 Changed 3 months ago by opi99

BTW: More information about host system.
System: Kubuntu 17.04
syslog writes:

Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8067] manager: (vboxnet0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/3)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8129] manager: (vboxnet1): new Ethernet device (/org/freedesktop/NetworkManager/Devices/4)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8205] manager: (vboxnet2): new Ethernet device (/org/freedesktop/NetworkManager/Devices/5)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8237] devices added (path: /sys/devices/virtual/net/vboxnet0, iface: vboxnet0)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8238] device added (path: /sys/devices/virtual/net/vboxnet0, iface: vboxnet0): no ifupdown configuration found.
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8240] devices added (path: /sys/devices/virtual/net/vboxnet1, iface: vboxnet1)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8241] device added (path: /sys/devices/virtual/net/vboxnet1, iface: vboxnet1): no ifupdown configuration found.
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8295] manager: (vboxnet3): new Ethernet device (/org/freedesktop/NetworkManager/Devices/6)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8354] manager: (vboxnet4): new Ethernet device (/org/freedesktop/NetworkManager/Devices/7)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8368] devices added (path: /sys/devices/virtual/net/vboxnet2, iface: vboxnet2)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8368] device added (path: /sys/devices/virtual/net/vboxnet2, iface: vboxnet2): no ifupdown configuration found.
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8390] devices added (path: /sys/devices/virtual/net/vboxnet3, iface: vboxnet3)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8391] device added (path: /sys/devices/virtual/net/vboxnet3, iface: vboxnet3): no ifupdown configuration found.
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8479] devices added (path: /sys/devices/virtual/net/vboxnet4, iface: vboxnet4)
Jul 18 16:31:17 lx-d2-pollux NetworkManager[1299]: <info>  [1500388277.8480] device added (path: /sys/devices/virtual/net/vboxnet4, iface: vboxnet4): no ifupdown configuration found.
Jul 18 16:31:22 lx-d2-pollux kernel: [  541.227368] SUPR0GipMap: fGetGipCpu=0xb
Jul 18 16:31:22 lx-d2-pollux kernel: [  541.321593] vboxdrv: 0000000000000000 VMMR0.r0
Jul 18 16:31:22 lx-d2-pollux kernel: [  541.396074] VBoxNetFlt: attached to 'vboxnet0' / 0a:00:27:00:00:00
Jul 18 16:31:22 lx-d2-pollux kernel: [  541.396229] device vboxnet0 entered promiscuous mode
Jul 18 16:31:22 lx-d2-pollux kernel: [  541.506971] vboxdrv: 0000000000000000 VBoxDDR0.r0
Last edited 3 months ago by opi99 (previous) (diff)

comment:5 Changed 3 months ago by vushakov

  • Host type changed from other to Linux

comment:6 Changed 3 months ago by vushakov

This might be related to #14526, though that has been fixed almost two years ago and there were no relevant code changes in the epsilon neighborhood for this to get broken in 5.1.24 suddenly.

comment:7 Changed 3 months ago by nickistre

I can confirm this regression happened to me with host-only networks, and someone has reported this in the forums:  https://forums.virtualbox.org/viewtopic.php?f=7&t=83853

Both our cases, reverting back to 5.1.22 allowed host-only networking to work.

comment:8 Changed 3 months ago by vushakov

On an affected system, what does the following commands show?

ip link show vboxnet0

and

ifconfig vboxnet0

when you have at least one VM attached to vboxnet0 started.

comment:9 Changed 3 months ago by ndsrl

on openSUSE 42.2 with the host only problem

ip link show vboxnet0
3: vboxnet0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 0a:00:27:00:00:00 brd ff:ff:ff:ff:ff:ff

and

ifconfig -a
vboxnet0  Link encap:Ethernet  HWaddr 0A:00:27:00:00:00  
          inet addr:192.168.56.1  Bcast:0.0.0.0  Mask:255.255.255.0
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:120 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
Last edited 3 months ago by vushakov (previous) (diff)

comment:10 Changed 3 months ago by opi99

$ ip link show vboxnet0

4: vboxnet0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 0a:00:27:00:00:00 brd ff:ff:ff:ff:ff:ff
$ ifconfig vboxnet0

vboxnet0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.56.1  netmask 255.255.255.0  broadcast 0.0.0.0
        ether 0a:00:27:00:00:00  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

comment:11 Changed 3 months ago by opi99

*hmpf* old package versions get deleted in the debian repository. :-(

comment:12 follow-up: ↓ 14 Changed 3 months ago by opi99

And Ubuntu 17.04 builds not listed on the old downloads page https://www.virtualbox.org/wiki/Download_Old_Builds_5_1

comment:13 Changed 3 months ago by HarryM

Same problem here, on CentOS 6.8. Host-only network; have not tried it with any other network type.

# ifconfig
eth0      Link encap:Ethernet  HWaddr 1C:87:2C:63:9D:D4  
          inet addr:192.0.2.0  Bcast:192.0.2.255  Mask:255.255.255.0
          inet6 addr: 2601:206:8100:6056:1e87:2cff:fe63:9dd4/64 Scope:Global
          inet6 addr: fe80::1e87:2cff:fe63:9dd4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:39180556 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20298328 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:44855974943 (41.7 GiB)  TX bytes:12594632936 (11.7 GiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:420286 errors:0 dropped:0 overruns:0 frame:0
          TX packets:420286 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:44549814 (42.4 MiB)  TX bytes:44549814 (42.4 MiB)
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.0.2.0       *               255.255.255.0   U     1      0        0 eth0
# 

There is no sign of vboxnet0. (That fake IP address is used to force traffic through my fw appliance.)

The configuration of my virtual network, VMs and host were working under 5.1.22; upon update to 5.1.24, the network no longer creates the vboxnet0 device. Upon downgrade back to 5.1.22, all is working again.

comment:14 in reply to: ↑ 12 Changed 3 months ago by mrvanes

Replying to opi99:

And Ubuntu 17.04 builds not listed on the old downloads page https://www.virtualbox.org/wiki/Download_Old_Builds_5_1

I "guessed" the right URL:  http://download.virtualbox.org/virtualbox/5.1.22

comment:15 Changed 3 months ago by aleksey

This appears to be a recent regression in VBoxNetAdpCtl, which now uses 'ip' instead of 'ifconfig' and fails to bring the interface up. The test build will be available shortly. Meanwhile you can work around the issue by manually bringing the interface up with ip link set dev vboxnet0 up.

comment:16 Changed 3 months ago by ndsrl

The proposed workaround "ip link set dev vboxnet0 up" does NOT work on openSUSE leap 42.2

# ip link show vboxnet0 3: vboxnet0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000

link/ether 0a:00:27:00:00:00 brd ff:ff:ff:ff:ff:ff

# ip link set dev vboxnet0 up # ip link show vboxnet0 3: vboxnet0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000

link/ether 0a:00:27:00:00:00 brd ff:ff:ff:ff:ff:ff

Not an OpenSUSE issue though as ip link set dev vboxnet0 (up/down) works fine on Virtualbox 5.1.22

Last edited 3 months ago by ndsrl (previous) (diff)

comment:17 follow-ups: ↓ 22 ↓ 24 Changed 3 months ago by aleksey

Please download and try test build 117090 from test builds page. It should resolve the issue.

comment:18 follow-up: ↓ 19 Changed 3 months ago by eworm

What SVN commit id has the needed changes?

comment:19 in reply to: ↑ 18 Changed 3 months ago by aleksey

Replying to eworm:

What SVN commit id has the needed changes?

The changes have not made it to the public repository yet. Trying any test build more recent than 117085 is greatly appreciated.

comment:20 Changed 3 months ago by Erich Ritz

I can confirm that VirtualBox-5.1.25-117110-Linux_amd64.run fixes the problem for me, whereas 5.1.24 had the problem.

My guest system is Windows 7 64-bit, and my host system is Slackware 14.2 (64 bit, multilib enabled) running kernel 4.4.75 with glibc 2.23.

comment:21 Changed 3 months ago by manschenk

Is there an estimated date when a fixed package will be released? Or could you make the previous package available in the debian-specific repository so that it can be installed as a workaround via standard package tools? Currently the older version cannot be installed since it was already removed from the repository.

comment:22 in reply to: ↑ 17 Changed 3 months ago by NginUS

Replying to aleksey:

Please download and try test build 117090 from test builds page. It should resolve the issue.

If I install the test build manually, I presume I'd have to uninstall/purge the version installed via aptitude. In which case I'd have no way to be notified when I can switch back to the official (stable) release when it becomes available.

Does anyone know a way to not have to check manually every day with aptitude search? Ideally a new official release would be replacing this broken one in the repo, but as of 10 hours later after 'manschenk' requested an ETA, no one has an answer for us on that.

comment:23 Changed 3 months ago by aleksey

The fix is now available in public repository: changeset 68056.

comment:24 in reply to: ↑ 17 Changed 3 months ago by Paddy Landau

Replying to aleksey:

Please download and try test build 117090 from test builds page. It should resolve the issue.

I have installed the test build and it works again for me, thank you.

Replying to NginUS:

Does anyone know a way to not have to check manually every day with aptitude search?

You can run the following terminal command:

dpkg-query --list 'virtualbox*'

and watch for when 5.1.24 changes. You can automate this with a script via cron to send yourself a message. If you're unsure how to do this, ask on your favourite Linux forum.

Last edited 3 months ago by Paddy Landau (previous) (diff)

comment:25 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 5.1.26.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use