VirtualBox

Ticket #16908 (closed defect: obsolete)

Opened 4 years ago

Last modified 4 years ago

Virtualbox Debian repository requests 5.1.24, but it doesn't exist, prevents system update -> obsolete

Reported by: Fuquay Owned by:
Component: other Version: VirtualBox 5.1.22
Keywords: Cc:
Guest type: Linux Host type: other

Description

When attempting to update my system (Ubuntu 17.04, 5.1.22), the Virtualbox Debian repository requests VirtualBox 5.1.24. However, it doesn't exist. *This error in the package definition prevents systems that use the repository from receiving ANY updates (without manual intervention) - not just VirtualBox.*

E: Failed to fetch http://download.virtualbox.org/virtualbox/debian/pool/contrib/v/virtualbox-5.1/virtualbox-5.1_5.1.24-117012~Ubuntu~zesty_amd64.deb  404  Not Found [IP: 88.221.50.105 80]

Note: A workaround that allows the system to be updated manually is to add the --ignore-missing flag to the apt or apt-get command.

Change History

comment:1 Changed 4 years ago by Fuquay

This appears to have been fixed. VirtualBox 5.1.24 has been made available. (The URL is my report above no-longer reports a 404 Not Found status code, and I have been able to upgrade.)

comment:2 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to obsolete
  • Summary changed from Virtualbox Debian repository requests 5.1.24, but it doesn't exist, prevents system update to Virtualbox Debian repository requests 5.1.24, but it doesn't exist, prevents system update -> obsolete

comment:3 Changed 4 years ago by Fuquay

  • Status changed from closed to reopened
  • Resolution obsolete deleted

I spoke too soon. On launching VirtualBox 5.1.24 for the first time I was prompted to install the extension pack, which resulted in "The network operation failed with the following error: During network request: Url not found on the server." It seems that there are still missing or inaccessible 5.1.24 resources for the moment.

Update: The extension pack at  http://download.virtualbox.org/virtualbox/5.1.24/Oracle_VM_VirtualBox_Extension_Pack-5.1.24.vbox-extpack downloads. However, at the following "Verifying VirtualBox Extension Pack..." an "Url not found on the server" is produced. So perhaps it just can't access filehashes to verify the integrity of the downloads? I can manually download the file hashes manually from:

 http://download.virtualbox.org/virtualbox/5.1.24/MD5SUMS  http://download.virtualbox.org/virtualbox/5.1.24/SHA256SUMS

I'm not sure what the problem is.

Update: I've been able to work around the problem by manually downloading and installing the extension pack (via Preferences > Extensions). The file I downloaded has md5 and sha256 hashes matching those in the above links.

Last edited 4 years ago by Fuquay (previous) (diff)

comment:4 Changed 4 years ago by Fuquay

The update process, including installation of updated extension pack and guest editions, worked fine on a separate machine a few hours later. I'm happy for this to be closed again.

comment:5 Changed 4 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use