VirtualBox

Ticket #1687 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Stardock Deskscapes interferes with VBox

Reported by: rwesterb Owned by:
Priority: major Component: host support
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

I'm using Windows Vista x64 Ultimate as my host operating system. I have installed Ubuntu 8.04 as OS on my virtual machine. If I assign more than 300 MB (not really sure about the exact limit) of RAM to the virtual machine, I always end up with the following error message when I try to launch applications inside my guest OS:

"Unable to allocate and lock memory. The virtual machine will be paused. Please close applications to free up memory or close the VM.

Error ID: HostMemoryLow Severity: Non-Fatal Error"

These problems have occurred on both of the VirtualBox versions I have tried out, that is v. 1.6 and v. 1.6.2. My system has plenty of RAM, so that shouldn't be the problem. I have also tried several VM configuration options. My system briefly:

Windows Vista Ultimate x64 SP 1 Intel Core 2 Duo E6750 RAM 5 GB Nvidia 8800 GT

Please ask for log files if you need them!

Attachments

VBox.log Download (31.2 KB) - added by rwesterb 6 years ago.

Change History

comment:1 follow-ups: ↓ 2 ↓ 3 Changed 6 years ago by sandervl73

Can you attach the VBox.log of the session? I have never seen that on Vista64 and I tend to use at least 512 MB ram for my VMs.

Changed 6 years ago by rwesterb

comment:2 in reply to: ↑ 1 Changed 6 years ago by rwesterb

This crash occurred immediately when I tried to launch the VM, check out the log for the information you need.

comment:3 in reply to: ↑ 1 Changed 6 years ago by rwesterb

After playing around with different system settings I have come to an interesting conclusion. I usually run my Vista desktop with Dreamscene enabled (video background). However, with Dreamscene disabled I'm no longer able to reproduce the crashes, which else usually occur within a minute from startup.

With that said maybe I should mention that Stardock's Deskscapes is also installed on my desktop. Especially Deskscapes has proven useful when it comes to crashing the Nvidia drivers, don't now who to blame.

I disabled/enabled the Dreamscene several times, all with the same result: The VM crashes every time when Dreamscene was enabled, not a single crash when disabled. The only thing I did was to launch Eclipse and Open Office Word inside the VM.

I hope that this information may give you some clues. Guess I will have to manage without eye candy while I'm programming till you find a solution then :-)

comment:4 Changed 6 years ago by rwesterb

Seems as this problem might have been Nvidia-specific. Since I installed my older Ati 2600XT GPU I havn't had any problems at all running VirtualBox.

comment:5 Changed 6 years ago by frank

  • Host type changed from other to Windows
  • Component changed from other to host support

comment:6 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Error ID "HostMemoryLow" on Vista x64 host to Stardock Deskscapes interferes with VBox

Try again with 2.0. The Qt4 GUI might behave differently. Reopen if required please.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use