VirtualBox

Ticket #16866 (closed defect: worksforme)

Opened 2 years ago

Last modified 2 years ago

Window 7 Crashes Running any Virtual Machine

Reported by: jenko Owned by:
Component: USB Version: VirtualBox 5.1.22
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

I have been running the Kali Linux VM image downloaded from the official web site for some time now. I also had other guest systems for Windows XP and Windows 7.

All guest images were 32-bit versions

The host system is running Windows 7 Home Premium 64 bit Service Pack 1, 4gb RAM, NVIDIA GeForce 9500.

All these were loading and running fine until about two days ago when the whole system would blue screen.

I have attached the log files and the minidump. If anyone can shed some light onto what is causing the crash it would be much appreciated.

I just dont understand why it would suddenly do this.

I have re-installed a fresh copy of Windows 7 onto the base system and the same error is occurring.

I have attached the log files from Vbox and also the minidump.

I have only been able to attach 2 of the 3 log files and the .dmp file will not upload.

I ran BlueScreenView and and it showed:

Caused by Driver: VMMR0.r0 Crash address: ntoskrnl.exe BugCheckString: SYSTEM_SERVICE_EXCEPTION

In the bottom panel of BlueScreenView it is highlighting:

dxgmms1.sys ntoskrnl.exe VMMR0.r0

The host PC only shows the bluescreen when I start the guest.

The first run had the Guest system the display video memory was set to 28mb. The host system froze and now blue screen appeared. I had to reboot. I lowered the display video memory to 8mb and disabled 2d and 3d accelaration. The guest ran for about 10 minutes then show the BSOD.

I just dont understand why this is happening now. I have ran Vbox on this system since i got it 5 years ago and never had any issues.

Virtualbox Version 5.1.22 Extensions Pack Installed

This all started when I added a USB Linksys Wifi dongle to the guest. I have been able to run this in the past

Attachments

Kali-Linux-2017.1-vbox-i686-2017-06-30-13-12-01.log Download (3.1 KB) - added by jenko 2 years ago.
Kali-Linux-2017.1-vbox-i686-2017-06-30-13-22-06.log Download (367.1 KB) - added by jenko 2 years ago.
Kali-Linux-2017.1-vbox-i686-2017-06-30-13-23-42.log Download (105.8 KB) - added by jenko 2 years ago.
063017-22666-01.dmp Download (279.4 KB) - added by jenko 2 years ago.
driver.txt Download (18.1 KB) - added by jenko 2 years ago.

Change History

Changed 2 years ago by jenko

Changed 2 years ago by jenko

Changed 2 years ago by jenko

comment:1 Changed 2 years ago by frank

I would like to have complete information about the BSOD of your Windows 7 host. If the host automatically reboots on BSOD (so you don't have enough time to write down the information) then make sure to change the system settings to NOT reboot the computer on BSOD. To do this, go to the Control Panel, System and Security, System, Advanced System Settings, Startup and Recovery, System failure: Uncheck Automatically restart.

I need all the hexadecimal numbers of the BSOD.

comment:2 Changed 2 years ago by jenko

As requested:

Bug Check String: SYSTEM_SERVICE_EXCEPTION
Bug check Code: 0x0000003b
Parameter 1: 00000000`c0000005
Parameter 2: fffff880`094b4774
Parameter 3: fffff880`09134d80
Parameter 4: 00000000`00000000
Caused by driver: VMMR0.r0
Caused by address: VMMR0.r0+d774
Processor: x64
Crash Address: ntoskrnl.exe+70e40

Filename: dxgmma1.sys
Address in stack: dxgmms1.sys+e755
From Address: fffff880`04b35000
To Address: fffff880`04b7b000
Size: 0x00046000
Time Stamp: 0x58e7a920

Filename: ntoskrnl.exe
Address in stack: ntoskrnl.exe+703e9
From Address: fffff800`02801000
To Address: fffff800`02de7000
Size: 0x005e6000
Time Stamp: 0x5915f59a

Filename: VMMR0.r0
Address in stack: VMMR0.r0+d774
From Address: fffff880`094a7000
To Address: fffff880`095cf000
Size: 0x00128000
Time Stamp: 0x5903619f

comment:3 Changed 2 years ago by frank

Thanks. This information is already helpful but could I also ask for a minidump, see for instance  here?

comment:4 Changed 2 years ago by frank

Actually I'm 99% sure that another hypervisor is interfering with VirtualBox. Do you have another hypervisor (e.g. VMware installed) or is Hyper-V active on your system? See  here.

Changed 2 years ago by jenko

comment:5 Changed 2 years ago by jenko

I have attached the minidump file 063017-22666-01.dmp

I do not have vmware installed. Would there be another service or program that would interfere. I only have Virtualbox installed.

When I was researching the issue, I saw lots of instances where people advised that Hyper-V should be turned off. As I am running Windows 7 Home Edition, Hyper-V is not available.

I followed the link you provided and ran

bcdedit /set hypervisorlaunchtype off

as Admin and the command completed successfully.

I also looked in the BIOS of my system for instances of Hyper-V. I have a ASUS P5KPL-AM EPU Motherboard and I could see no instances of Hyper-V options there.

Am I correct in what I have done so far?

comment:6 Changed 2 years ago by frank

Thanks for the dump. It proves that the VMXON instruction for enabling the VT-x root mode fails eventually. On Windows we enable / disable the root mode when before / after we execute guest code. You may try

VBoxManage setextradata VM_NAME VBoxInternal/HM/Exclusive 1

before you start any VM (replace VM_NAME with the name of a VM which you would like to start). Then start the VM as usual, does that work?

Our suspicion is still that some 3rd-party software is entering the VT-x root mode on your computer when this mode should be exclusively used by VirtualBox. Which AV software do you have installed?

comment:7 Changed 2 years ago by frank

Also, could you provide the output of

driverquery

on your Windows 7 host? Please use the Attach file function to attach the file. Thank you!

comment:8 Changed 2 years ago by frank

Actually that information is already part of the minidump. Turns out that you have Avast installed. See #15135.

Changed 2 years ago by jenko

comment:9 Changed 2 years ago by jenko

I have added the output for the driverquery command (driver.txt).

Just to let you know, someone on the forums suggested I run the VM with audio disabled. I tried this and it ran fine. I have since updated the audio driver to the latest version available.

The audio driver is now:

VIA Technologies
29/03/2011
Version 6.0.1.9500

This is the latest version available for my motherboard.

As I did a clean install of Windows 7 the OS installed a driver for audio which was much older.

I have also since updated the NVIDIA GeForce 9500 GT driver to:

version 21.21.13.4201 
dated 14/11/2016. 

This is also the most up to date available.

I ran the command:

VBoxManage setextradata Kali-Linux-2017.1-vbox-i686 VBoxInternal/HM/Exclusive 1

Then started the VM with audio enabled and the VM loaded without any issue.

comment:10 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

I don't believe that audio is not the problem. If VBox ran successfully with audio disabled then this was a co-incidence.

I already mentioned in comment:8 that you are running Avast. The real solution to your problem is in mentioned in ticket #15135.

Running the VM with 'VBoxInternal/HM/Exclusive' might do the trick but it shouldn't be necessary if you properly tame Avast like described in ticket #15135.

comment:11 Changed 2 years ago by jenko

Awesome. Thank You.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use