VirtualBox

Ticket #16858 (closed defect: fixed)

Opened 4 months ago

Last modified 3 months ago

2d acceleration grayed

Reported by: Sizy458 Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.22 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello i update virtualbox from 4.3.38 into 5.1.22 , and
i have 2d acceleration grayed !

Change History

comment:1 Changed 4 months ago by Sizy458

Information : linux debian installed in the host machine.

comment:2 Changed 4 months ago by socratis

It's usually better and faster, if issues like this one (configuration, question) get first addressed in the  VirtualBox forums. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is most probably not a bug and someone from the developers has to deal with it and close it as "Invalid".

Related topic:  https://forums.virtualbox.org/viewtopic.php?f=7&t=83615

comment:3 Changed 4 months ago by frank

  • Priority changed from critical to major

If the 2D box is greyed then VirtualBox cannot make use of 2D acceleration. If you are using the .deb package from download.virtualbox.org/virtualbox then there should be an application /usr/lib/virtualbox/VBoxTestOGL which is used to test if the host supports 2D video acceleration (which is only supported for Windows guests btw). You might want to execute

/usr/lib/virtualbox/VBoxTestOGL --test 2D --log log.txt

and have a look at log.txt.

comment:4 Changed 4 months ago by Sizy458

I have NVIDIA Corporation GeForce GT 620 [10de:0f01] (rev a1) and installed the latest driver version 375.66

Then Problem is always not resolved

Conclusion : button 2d acceleration always grayed.

cudila@debian-w:~$ /usr/lib/virtualbox/VBoxTestOGL --test 2D --log log.txt
cudila@debian-w:~$ cat log.txt
VBoxTestGL 5.1.22 r115126 linux.amd64 (Apr 28 2017 18:09:39) release log
00:00:00.000135 Log opened 2017-06-29T16:00:51.056550000Z
00:00:00.000164 OS Product: Linux
00:00:00.000169 OS Release: 3.2.0-4-amd64
00:00:00.000174 OS Version: #1 SMP Debian 3.2.54-2
00:00:00.000181 Executable: /usr/lib/virtualbox/VBoxTestOGL
00:00:00.000182 Process ID: 4858
00:00:00.000182 Package type: LINUX_64BITS_DEBIAN_7_0
00:00:00.000188 Testing 2D Support:
00:00:00.022518 Failed to create gl context
00:00:00.022567 Testing 2D Failed
cudila@debian-w:~$

Last edited 4 months ago by Sizy458 (previous) (diff)

comment:5 Changed 4 months ago by Sizy458

I downgrade from 5.1.22 into 5.0.40 then the problem is fix it.

comment:6 Changed 4 months ago by frank

Thanks for the information. I think we found and fixed the problem. Could you install this test build and confirm that it fixes your problem?

comment:7 Changed 4 months ago by Sizy458

I try the version 5.1.23 ,then the button "2d acceleration" is now black (not grayed), (operational).
J'ai tester la version 5.1.23 , le bouton "accélérateur 2d" est maintenant activable.

comment:8 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.24.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use