VirtualBox

Ticket #16803 (closed defect: fixed)

Opened 3 months ago

Last modified 4 weeks ago

Video Capture is not capturing the boot sequence in Windows 7 Guest

Reported by: TheDcoder Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.22 Keywords: video capture
Cc: Guest type: Windows
Host type: Linux

Description

Hello! I have a Virtual Machine with Windows 7 Home Premium x64 installed on my host OS Fedora 25 x86_64

I was trying to capture the entire process from start up of the machine (i.e starting from the BIOS) and till shutdown.

When I tried video capture, it only started recording after Windows 7 had logged me in (the part where the desktop is visible). I could see the little "movie reel" icon rolling in the status bar of the VM the entire time but the recording only started after booting into the OS.

I have Guest Additions installed, both 3D and 2D acceleration is enabled and Windows Aero is enabled too.

Thank you in advance, I will be happy to cooperate in order to get this fixed!

Attachments

Windows 7-2017-05-31-21-00-29.log Download (151.2 KB) - added by TheDcoder 3 months ago.
VM's Log

Change History

Changed 3 months ago by TheDcoder

VM's Log

comment:1 follow-up: ↓ 2 Changed 3 months ago by frank

Actually this is a 5.1.20 regression. This problem should be fixed in 5.1.x test builds >= revision 115881.

comment:2 in reply to: ↑ 1 Changed 3 months ago by TheDcoder

Replying to frank:

Actually this is a 5.1.20 regression. This problem should be fixed in 5.1.x test builds >= revision 115881.

Oh! I see... I cannot test it because I am not very good at manually updating stuff in Linux, I will test it the next latest release. Thanks for the comment :)

comment:3 Changed 3 months ago by socratis

It works under OSX as advertised, thanks for the quick fix!

I'll test it under Win7 later on when my other host decides to cooperate. Updates (hopefully) later on.

comment:4 Changed 5 weeks ago by TheDcoder

This bug is mentioned in 5.1.24 changelog as fixed but this issue is still open, can someone verify and close this ticket?

comment:5 follow-up: ↓ 6 Changed 5 weeks ago by socratis

  1. What's preventing you from verifying it? I mean, you opened the ticket in the first place, shouldn't you be the one that actually verifies that it got fixed?
  2. I did verify it and it works as expected.

comment:6 in reply to: ↑ 5 Changed 5 weeks ago by TheDcoder

Replying to socratis:

What's preventing you from verifying it? I mean, you opened the ticket in the first place, shouldn't you be the one that actually verifies that it got fixed?

I had deleted the Virtual Machine in order to save some space in my hard disk that I needed... so I couldn't test it. I hope that you can see my issue here.

Actually I just bought a new larger hard disk so I can test it when I finish setting it up.

comment:7 Changed 4 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Let's close the ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use