VirtualBox

Ticket #16680 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Vbox-5.1.20 mount -t vboxsf returns sf_read_super_aux err=-22

Reported by: zd59 Owned by:
Component: shared folders Version: VirtualBox 5.1.20
Keywords: mount -t vboxsf error Cc:
Guest type: Linux Host type: Windows

Description

Hi!

My config:

Windows 10 x64 host for Virtualbox-5.1.20 Guest: Slackware x64 14.2 with installed guest additions 5..1.20 tests accomplished on guest kernel 4.10.10 and 4.10.11

After installing Vbox-5.1.20 on my host Windows mount -t vboxsf no longer works.

I get reply:

mount -t vboxsf vbshare /mnt/vbshare

mount wrong fs type bad option bad superblock

# dmesg | tail

[ 1320.117014] sf_read_super_aux err=-22

[ 3310.304804] sf_read_super_aux err=-22

I installed VboxGuestAdditions.iso from older versions (5.1.18 and 5.1.16) on running Vbox-5.1.20. Slackware guest, and mount -t vboxsf command works.

Tested the same in Windows 10 guest - shared folders works.

So VboxGuestAdditions.iso for a Vbox-5.1.20 do not works only in linux guests.

Change History

comment:1 Changed 6 years ago by socratis

Most probably a duplicate of #16670.

See that ticket, there a potential solution; use the Testbuild GAs.

comment:2 Changed 6 years ago by zd59

Yes # 16670 solved the issue.

Please add that to comment at the main download site to warn users of that issue.

Regards

comment:3 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use