VirtualBox

Ticket #16675 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

It causes windows 10 ( Creators update ) to have a BSOD

Reported by: angarato_surion Owned by:
Component: other Version: VirtualBox 5.1.20
Keywords: Cc:
Guest type: all Host type: Windows

Description

It causes windows 10 ( Creators update ) to have a BSOD Error: SYSTEM_SERVICE_EXCEPTION

Attachments

VBox.log Download (32.0 KB) - added by angarato_surion 2 years ago.
callstack.txt Download (9.9 KB) - added by ghislain 2 years ago.
WinDbg output with call stack
Desktop.zip Download (442.7 KB) - added by angarato_surion 2 years ago.
minidumps
callstack_Vbox_5.1.20.txt Download (9.9 KB) - added by ghislain 2 years ago.
WinDbg output with call stack with Vbox 5.1.20
042417-7609-01.7z Download (78.7 KB) - added by ghislain 2 years ago.
Minidump taken with VirtulBox 5.1.20
050517-10328-01.zip Download (107.4 KB) - added by ghislain 2 years ago.
Minidump taken with VB 5.1.22
VBoxSVC.log.1 Download (3.1 KB) - added by sec2015test 2 years ago.
VBoxSVC Log
virtualbox_BSOD_kernal_dump.zip Download (190.1 KB) - added by sec2015test 2 years ago.
Kernal Dump file

Change History

comment:1 Changed 2 years ago by frank

Sorry, not enough information. The absolute minimum required information is a VBox.log file of a VM run. I even don't know if your host crashes or your guest. If your hosts crashes then please describe at which time: When you opened the selector, when you started a VM etc. Again, if there is any VBox.log file for a started VM available, please attach it to this ticket.

Changed 2 years ago by angarato_surion

comment:2 Changed 2 years ago by angarato_surion

i just select one of the virtual machines and when i t goes to boot/start it it causes the bsod

comment:3 follow-up: ↓ 4 Changed 2 years ago by frank

To be clear: The host shows a BSOD (the computer one which you execute VirtualBox), is that correct?

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 2 years ago by angarato_surion

Replying to frank:

To be clear: The host shows a BSOD (the computer one which you execute VirtualBox), is that correct?

The host of course .. iwill n't care if it was the os runing in virtualbox..

Last edited 2 years ago by angarato_surion (previous) (diff)

comment:5 in reply to: ↑ 4 Changed 2 years ago by ghislain

Hi,

I'm using VirtualBox 5.1.18 on Win10 Pro 64 bits host. Whenever I start a Win10 guest VM, I get a BSOD on the host :
Stop code : IRQL_NOT_LESS_OR_EQUAL

Looking at the crashdump, I get this conclusion from WinDbg (X64) :

*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck D1, {0, ff, 0, 0}

*** WARNING: Unable to verify timestamp for VBoxDrv.sys
*** ERROR: Module load completed but symbols could not be loaded for VBoxDrv.sys
*** WARNING: Unable to verify timestamp for VMMR0.r0
*** ERROR: Module load completed but symbols could not be loaded for VMMR0.r0
*** WARNING: Unable to verify timestamp for VBoxDDR0.r0
*** ERROR: Module load completed but symbols could not be loaded for VBoxDDR0.r0
Probably caused by : VBoxDrv.sys ( VBoxDrv+1f630 )

Upgrading VirtualBox to version 5.1.20 r114628 (Qt5.6.2) does not change anything. On the other hand, my Linux VMs works perfectly fine.

Could it be the same problem ? Or should I create a new ticket ?

Last edited 2 years ago by ghislain (previous) (diff)

comment:6 follow-up: ↓ 7 Changed 2 years ago by sunlover

ghislain, could you please provide entire output of the '!analyze -v' command, including the call stack?

Changed 2 years ago by ghislain

WinDbg output with call stack

comment:7 in reply to: ↑ 6 Changed 2 years ago by ghislain

Replying to sunlover:

ghislain, could you please provide entire output of the '!analyze -v' command, including the call stack?

Done.

Changed 2 years ago by angarato_surion

minidumps

comment:8 follow-up: ↓ 11 Changed 2 years ago by sunlover

angarato_surion, thanks for the dumps. In your case this looks like the same problem as in ticket #15780. Try to disable Hyper-V. See comment 6 there: https://www.virtualbox.org/ticket/15780#comment:6

comment:9 follow-up: ↓ 10 Changed 2 years ago by sunlover

ghislain, the callstack shows a different problem. Please attach a minidump taken with VirtulBox 5.1.20. Thanks!

Changed 2 years ago by ghislain

WinDbg output with call stack with Vbox 5.1.20

comment:10 in reply to: ↑ 9 ; follow-up: ↓ 13 Changed 2 years ago by ghislain

Replying to sunlover:

ghislain, the callstack shows a different problem. Please attach a minidump taken with VirtulBox 5.1.20. Thanks!

Sorry, I did not pay attention to that. The one I have just attached should have been generated with VirtualBox 5.1.20.

comment:11 in reply to: ↑ 8 Changed 2 years ago by angarato_surion

Replying to sunlover:

angarato_surion, thanks for the dumps. In your case this looks like the same problem as in ticket #15780. Try to disable Hyper-V. See comment 6 there: https://www.virtualbox.org/ticket/15780#comment:6

i boot with hyper-v disabled and crashes

comment:12 Changed 2 years ago by angarato_surion

fixed somehow the update might removed my boot settings and not noticed

Last edited 2 years ago by angarato_surion (previous) (diff)

Changed 2 years ago by ghislain

Minidump taken with VirtulBox 5.1.20

comment:13 in reply to: ↑ 10 Changed 2 years ago by ghislain

Replying to ghislain:

Replying to sunlover:

ghislain, the callstack shows a different problem. Please attach a minidump taken with VirtulBox 5.1.20. Thanks!

Sorry, I did not pay attention to that. The one I have just attached should have been generated with VirtualBox 5.1.20.

Minidump added.

comment:14 follow-up: ↓ 15 Changed 2 years ago by sunlover

ghislain, thanks for the minidump. Does the crash happen immediately after you start a Windows 10 VM or after some time? What the guest is doing when the crash happens?

comment:15 in reply to: ↑ 14 Changed 2 years ago by ghislain

Replying to sunlover:

ghislain, thanks for the minidump. Does the crash happen immediately after you start a Windows 10 VM or after some time? What the guest is doing when the crash happens?

It crashes pretty quickly after the logon. The guest is really slow and unusable.

comment:16 follow-up: ↓ 17 Changed 2 years ago by sunlover

ghislain, any idea when this crash started to happen? After Windows Creators update? After VirtualBox update? Did the VM work in the past? If yes, which VirtualBox and Windows versions?

I'm asking because the crash happens in a code path which has not been changed recently in VirtualBox and because we do not have similar reports so far.

comment:17 in reply to: ↑ 16 Changed 2 years ago by ghislain

Replying to sunlover:

ghislain, any idea when this crash started to happen? After Windows Creators update? After VirtualBox update? Did the VM work in the past? If yes, which VirtualBox and Windows versions?

I'm asking because the crash happens in a code path which has not been changed recently in VirtualBox and because we do not have similar reports so far.

Having a look at my Windows update history, I have realized that Creators update has not been applied yet to my host so I'm still running Windows 10 Pro 64 bits 1607. My VMs worked perfectly fine (for months) up to the first BSOD around the 17th of April. It first occured without any update, neither on Window, neither on Virtualbox. I can't even check the version of the Windows running on my VM, it crashes before the logon screen.

I have upgraded to version 5.1.22 of VB but still encounter BSOD. No problem running my Linux VMs.

Changed 2 years ago by ghislain

Minidump taken with VB 5.1.22

comment:18 Changed 2 years ago by sunlover

ghislain, please run the following command, where VMNAME is the name of your crashing Win10 VM:

VBoxManage setextradata VMNAME "VBoxInternal/Devices/ahci/0/Config/R0Enabled" 0

Then run the VM. If it BSODs again, then please attach the new minidump. And also in any case attach VBox.log of this VM. Thanks!

Changed 2 years ago by sec2015test

VBoxSVC Log

Changed 2 years ago by sec2015test

Kernal Dump file

comment:19 Changed 2 years ago by sec2015test

I also got the BSOD, so I took Kernel dump and attached. The "VBoxSVC.log" is empty so I attached another one (may be old)

comment:20 Changed 2 years ago by sec2015test

I have disabled Hyper-V and rebooted the host systems. Now I am able to run virtual box without BSOD.

comment:21 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Closing as duplicate of #16801.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use