VirtualBox

Ticket #16663 (closed defect: fixed)

Opened 15 months ago

Last modified 12 months ago

host macOS guest FreeBSD 11 critical error on gnome3 GUI load

Reported by: Andrii Ganenko Owned by:
Priority: major Component: guest additions/x11/graphics
Version: VirtualBox 5.1.18 Keywords: macos FreeBSD 11 gnome 3
Cc: Guest type: BSD
Host type: Mac OS X

Description

Hi!

host macOS guest FreeBSD 11 critical error on gnome3 GUI load

Thanks!

Attachments

VBox.log Download (320.2 KB) - added by Andrii Ganenko 15 months ago.

Change History

Changed 15 months ago by Andrii Ganenko

comment:1 Changed 15 months ago by socratis

  1. Duplicate of #15693, #15790, #15801, #15969, #16171, #16274, #16418, #16556, #16569, #16657. In your case you have a "VERR_IEM_INSTR_NOT_IMPLEMENTED" with a "movups xmm".
  1. Please read:  5.1.x Guru Meditation: VERR_IEM_INSTR_NOT_IMPLEMENTED.
  1. It's usually better and faster, if problems get first addressed in the forums ( https://forums.virtualbox.org/). More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is already reported several times and someone from the developers has to deal with it and close it as "Duplicate".

comment:2 Changed 15 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

comment:3 Changed 15 months ago by socratis

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Turns out that this ticket may have the same symptoms as the other ones, but it actually stands on its own and it's not a duplicate. The offending instruction is "movups xmm" as it was reported and confirmed, after 5.1.22 was released in the  5.1.x Guru Meditation: VERR_IEM_INSTR_NOT_IMPLEMENTED.

comment:4 Changed 15 months ago by frank

This was supposed to be fixed with VBox 5.1.22 but I have to confirm that there were some missing cases. They should be fixed with the latest 5.1.x test builds (>= 115260) which you can download here.

comment:5 Changed 14 months ago by zlatkig

I confirm that the issue has been resolved in test-build 115786.

The issue could be triggered by starting the X server in a FreeBSD guest. It was unrelated to a specific desktop environment. With the named test-build the X server runs properly.

comment:6 Changed 13 months ago by socratis

Add  another report of a fixed problem on an iMac17,1, with an ArchLinux_64 guest "choking" on instruction "vmovdqa oword", reported as Guru Meditation with 5.1.22, but fixed with the "latest" build (whatever "latest" means). At the time of this writing, "latest" == r115966.

comment:7 Changed 12 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of 5.1.24.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use