VirtualBox

Ticket #1660 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Vista host fails to resume from sleep if VirtualBox running -> fixed in SVN

Reported by: satya Owned by:
Priority: critical Component: VMM/HWACCM
Version: VirtualBox 2.0.2 Keywords: suspend resume
Cc: Guest type: other
Host type: other

Description

I have noticed this happen very conistently. I have Ubuntu Hardy running in VirtualBox 1.6 on a Vista SP1 Business host. The physical computer is a Dell D620 laptop with a nVidia Quadro NVS 110m display card.

Attachments

VBox.log.1 Download (38.8 KB) - added by satya 6 years ago.
VirtualBox Log
Ubuntu.xml Download (4.2 KB) - added by satya 6 years ago.
VirtualBox XML configuration
vbox210resume_kern.log Download (20.7 KB) - added by marcoc 5 years ago.
kern.log of resume boot after suspend with VM active (VirtualBox 2.1.0 on Ubuntu 8.04)
Devel_CE50-2008-12-17-18-26-09.log Download (75.8 KB) - added by marcoc 5 years ago.
VBox.log file of same session of kern.log attached yesterday (truncated repeating messages at end to fit in max size)

Change History

Changed 6 years ago by satya

Changed 6 years ago by satya

VirtualBox XML configuration

comment:1 Changed 6 years ago by frank

  • Host type changed from other to Windows
  • Component changed from other to VMM/HWACCM

comment:2 Changed 6 years ago by heheh

Have exactly the same issue. The vista host hangs after I reopen the lid of thinkpad.

comment:3 Changed 6 years ago by sandervl73

#1938 has been marked as a duplicate (vmldptr fault after suspend).

comment:4 Changed 6 years ago by sandervl73

  • Version changed from VirtualBox 1.6.0 to VirtualBox 2.0.0

comment:5 Changed 6 years ago by sandervl73

  • Keywords suspend resume added

comment:6 Changed 6 years ago by sandervl73

  • Priority changed from major to critical

comment:7 Changed 6 years ago by sandervl73

Will not be fixed in the next maintenance release (not enough time left). For now simply don't suspend the host machine when a VM is running.

We'll try to address this in 2.0.4.

comment:8 Changed 6 years ago by dmex

Has done the same on Windows Hosts for the last 8 months, If the PC enters sleep mode while Virtualbox is running it either BSODs on resume or doesnt resume at all.

There are APIs in Windows to prevent sleep mode while Virtualbox is running or there's another API to allow Virtualbox to save the Guest before letting Windows enter sleep mode.

comment:9 Changed 6 years ago by sandervl73

  • Host type changed from Windows to other

comment:10 Changed 6 years ago by sandervl73

Applies to both Linux and Windows hosts. (see e.g. #2023)

comment:11 Changed 6 years ago by sandervl73

  • Version changed from VirtualBox 2.0.0 to VirtualBox 2.0.2

comment:12 Changed 5 years ago by timrichardson

I guess a fix didn't make it into 2.0.4? (Linux user)

comment:13 follow-up: ↓ 14 Changed 5 years ago by sandervl73

No, sorry. It's scheduled for the next major release. The code in SVN already contains the fix for Windows hosts.

comment:14 in reply to: ↑ 13 Changed 5 years ago by pebo

Replying to sandervl73:

It's scheduled for the next major release.

Does it mean it won't neither be fixed in 2.0.6? (which I suppose is the next version the come out)

The code in SVN already contains the fix for Windows hosts.

There is no chance for non-OSE users to benefit from that, is there?

comment:15 Changed 5 years ago by timrichardson

I made a quick and dirty workaround for Debian (saving the session whenever suspend or hibernate happens), which at least avoids dataloss. The idea will work on all linuxes, I think.  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502043#22

comment:16 Changed 5 years ago by sandervl73

  • Summary changed from Vista host fails to resume from sleep if VirtualBox running to Vista host fails to resume from sleep if VirtualBox running -> fixed in SVN

The new release isn't very far off. Currently both Linux & Windows hosts suspend and resume properly.

comment:17 Changed 5 years ago by fzzzt

I realize this is supposed to be fixed, just wanted to say I have this problem BUT it only happens if the VM that is running when the computer goes into sleep mode has hardware support on. If hardware virtualization is disabled, my Vista host sleeps/resumes normally.

comment:18 Changed 5 years ago by sandervl73

fzzzt: This whole ticket is about VT-x/AMD-V and suspend/resume.

comment:19 Changed 5 years ago by marcoc

NOT fixed in 2.0.6 - at least on my Linux host (Ubuntu 8.04 on AMD64) running Windows 2000 guests. Just installed 2.0.6 hoping that it contained this long-awaited fix.

Suspending and resuming the host machine makes the VM window unresponsive. Must kill the process to get rid of it. Trying to start a VM again ends up in another unresponsive window. Must reboot the whole system to be able to use VirtualBox again.

comment:20 Changed 5 years ago by frank

We didn't write that this issue is fixed in 2.0.6. The change was a bit more intrusive so it will be contained in the next release.

comment:21 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 2.1.

Changed 5 years ago by marcoc

kern.log of resume boot after suspend with VM active (VirtualBox 2.1.0 on Ubuntu 8.04)

comment:22 Changed 5 years ago by marcoc

Doesn't look fixed in 2.1. Same behavior as before. I did the following:

  • remove 2.0.6 (2.1 won't install over)
  • install 2.1 via the .deb package for hardy
  • start a VM (Win2000, 512M)
  • suspend Ubuntu
  • resume Ubuntu

Now the VM is frozen in its state before suspend. BTW I think something bad happened during the resume boot. I attach a copy of kern.log. HTH Marco

comment:23 Changed 5 years ago by frank

Macroc, you are reporting this problem with a Linux host, right? Could you attach a VBox.log file of such a session as well as the output of dmesg again?

Changed 5 years ago by marcoc

VBox.log file of same session of kern.log attached yesterday (truncated repeating messages at end to fit in max size)

comment:24 Changed 5 years ago by marcoc

It works! Sorry for bothering you with a non-existent problem. Just I didn't reboot Linux after installing 2.1. The installer didn't require a reboot and I was too eager to try the new feature. Then I had to, due to the VM lockup, and now it's working fine. Thanks to you all, now I can suspend my laptop with all VM's when it's time to go :-)

comment:25 Changed 5 years ago by frank

Hmm, It should work but it should not be necessary to reboot your host. Please try some more times to make sure the problem is really fixed for you.

comment:26 Changed 5 years ago by sandervl73

You should still be very careful when leaving VMs running and putting the laptop to sleep. If it runs out of battery, you could end up with corrupted VMs.

Currently only Windows hosts save any active VM when the battery level goes below 10%. We'll add the same feature to both Linux and Mac OS X in the near future.

comment:27 Changed 5 years ago by marcoc

Sorry, maybe I'm not using the correct term: whenever I wrote "suspend" I meant saving state to disk and turn off, that should be "hibernate". Yesterday my laptop ran out of battery by mistake with a VM active and automatically hibernated, as configured. When I turned it back on, surprisingly, the VM was still alive after resume.

comment:28 Changed 5 years ago by sandervl73

marcoc: that was the whole point of the fix/change in VirtualBox :)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use