VirtualBox

Ticket #1647 (new defect)

Opened 6 years ago

Last modified 6 years ago

Cannot get USB support to work in OpenSolaris guest

Reported by: gsporar Owned by:
Priority: major Component: USB
Version: VirtualBox 1.6.0 Keywords: USB OpenSolaris
Cc: Guest type: other
Host type: other

Description

VirtualBox 1.6.0 on Windows Vista - using an OpenSolaris 2008.05 guest.

I have been unable to get USB support to work. I plugged in a USB flash drive, started VirtualBox and then created a filter for the flash drive.

I then started the OpenSolaris virtual machine. It sort of looks like VirtualBox sees the USB flash drive, because if I select Devices > USB Devices from the menu of the virtual machine's window, I get a list of four entries:

 Microsoft Basic Optical Mouse
 Unknown device 05CA:183A [0100]
 Generic Flash Disk [0100]
 TouchStrip Fingerprint Sensor [0001]

The third entry, "Generic Flash Disk [0100]" is the only entry that has a check-mark, which I think is what it should have. Further, at this point Windows Vista no longer sees the USB drive, which if I understand the documentation is the correct behavior. In other words, VirtualBox "takes over" the USB device and the host operating system no longer sees it.

Unfortunately, from inside the virtual machine, OpenSolaris does not seem to see the device. It does not get auto-mounted. At a command line in OpenSolaris I typed in:

rmformat -l

and the USB flash drive is not listed (ref:  http://mx.opensolaris.org/jive/thread.jspa?threadID=59178). The only thing listed by rmformat is the "VBOX CD-ROM" drive.

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to USB
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use