VirtualBox

Ticket #16401 (closed defect: fixed)

Opened 8 months ago

Last modified 7 months ago

Importing OVF only imports 10 network adapters

Reported by: isharacomix Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.14 Keywords:
Cc: Guest type: other
Host type: other

Description

I developed a VM that has 16 network interfaces and exported the appliance. The OVF file contains all of the network adapters. When I import the appliance, the resulting VM only has 10 adapters.

Attached please find:

  1. showvminfo of the machine before export
  2. output of vboxmanage import
  3. showvminfo of the machine after import
  4. ova file to test for yourself

Attachments

showvminfo-before.txt Download (7.7 KB) - added by isharacomix 8 months ago.
showvminfo of machine before export
import.txt Download (2.3 KB) - added by isharacomix 8 months ago.
Output of the import command
showvminfo-after.txt Download (5.9 KB) - added by isharacomix 8 months ago.
showvminfo after importing the appliance
1_oob-mgmt-switch.ovf Download (22.6 KB) - added by isharacomix 8 months ago.
OVF of the appliance

Change History

Changed 8 months ago by isharacomix

showvminfo of machine before export

Changed 8 months ago by isharacomix

Output of the import command

Changed 8 months ago by isharacomix

showvminfo after importing the appliance

Changed 8 months ago by isharacomix

OVF of the appliance

comment:1 Changed 7 months ago by klaus

Confirmed. Root cause is an old assumption (slot numbers need only one digit) which isn't true any more. Found a couple of other quirks regarding the network card count handling in the GUI for ICH9.

Fix will be in 5.1.16, whenever it'll happen. Also any test builds starting with 5.1.15r113680 has the fix.

comment:2 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed is part of VBox 5.1.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use