VirtualBox

Ticket #1630 (closed defect: fixed)

Opened 6 years ago

Last modified 2 years ago

Ubuntu Host - USB crashing in Guest Windows XP - No errors

Reported by: zavius Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.0 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)


Change History

comment:1 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I think this is a similar bug like #1629. Please do never paste the whole VBox.log file again!

comment:2 Changed 5 years ago by dayhawk

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Please note: I am also getting the issue specified by ticket 2907, which was closed because someone thought that it was the same as this one. Big Difference. First, 2907 is very consistent. It always happens when XP is installed (it would seem on a linux box... mine is Ubuntu Fiesty Fawn), USB 2.0 is enabled, and then the guest OS tries to install drivers. I have exactly the same issue as 2907 occurring with my installation. I can give a seperate screenshot (in english instead of in German) of the system crashing CONSISTENTLY at exactly the same spot. I have waited over an hour twice to make sure this is not because of the VM being slow. It isn't. I have gone back and duplicated this issue on a fresh install of Windows XP SP1, SP2, and SP3 with nothing else installed, and it occurs on all platforms. This one is not consistent. Additionally, there does not need to be any devices installed under ticket 2907's problem. I was running my system without any device filters installed. As such, nothing should have been forwarded to the guest operating system. The result was the same. I removed all filters from USB1 mode, removed the drivers from the device manager, and rebooted, the system found the device, installed the drivers, and moved along happily.

Why 2907 isn't the same as 1630... 1630 reports an issue where usb devices are plugged in, and the system crashes regardless of what mode you are in (usb1.1 or usb2.0 mode). 2907 specifically describes an issue where if there is going to be a crash, you can't even get past installing the drivers for the hub. As such, before you had the opportunity to install a device, you would already be crashed. Also, if you read 2907, you will find that he had an earlier version around 2.0 which worked with usb 2.0. After upgrading to version 2.1, the issue became prominent. 1630 is from version 1.6. Check the SVN for when changes were made to the usb source tree. Either way, it doesn't make sense for there to be an issue, then not, then an issue again.

My testing.... Ubunty Fiesty Fawn Host OS. Windows XP SP3 Guest. Only thing installed in Guest OS are Firefox 3.01, Adobe Acrobat reader 9.0, and Adobe Flash Player. Started system (without USB 2.0 enabled... no filters). Started fine. Removed drivers for usb hub. Restarted. New Hardware Found...Ready for use. Installation fine. Shutdown. make snapshot. Enable USB2.0. Still no filters, and as such no insertion event can happen (the thing causing the issue from 1630). Start machine, goes in... New hardware found. This eventually changes to Intel ..... found. Left machine for half an hour. Guest Machine Clock still reading time from when left. Host Operating Machine Reading Current time.... Crash.

Shutdown Machine, revert to previous snapshot. Boot-up machine, go to device manager, remove drivers. Shut down machine, enable USB2.0, and power up. Locked again like previously.

There is specifically an issue with Windows XP SP3 installing the drivers for the USB2.0 controller. You never get to the point where you can insert a device with this issue, and when you are only running USB1.0, there isn't an issue. This ticket needs to be reopened. I am running Virtualbox version 2.1.4 by the way.

comment:3 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use