VirtualBox

Ticket #1627 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Shared Folders blue screen during compiling/debugging (winxp sp3)

Reported by: WCarvalho Owned by:
Priority: critical Component: other
Version: VirtualBox 1.6.2 Keywords: AMD X2 AM2+ BSOD 0x0000008E
Cc: Guest type: other
Host type: other

Description

When I run Visual Studio or Codegear RAD Studio (Delphi for Win32), on first compile it run... if I try to run again to debug the application, Virtual Box crash with BSOD 0x0000008E.

I tried to run the same Virtual Machine on another Hardware and it works fine...

My old hardware: AMD 64 3800, ASUS A8N-E, 2 GB RAM (dual channel) DDR 400mhz My new hardware: AMD X2 AM2+ 5200, ASUS M3A, 2 GB RAM (dual channel) DDR2 800mhz

My guest is using 512MB RAM... and AMD-V is OFF. I tried to turn it ON but I only get a BLACK SCREEN... (???)

My Guest OS is Windows XP SP3. (it's running fine on my old hardware and crash on new one)

Regards,

WCarvalho

PS: Please, can ADMIN delete tracker #1626 (wrong Priority)

Attachments

VBox.log Download (36.4 KB) - added by WCarvalho 6 years ago.
vb160_d2k7_crash.JPG Download (78.0 KB) - added by WCarvalho 6 years ago.
TestA_VBox_162_without_AMDV.log Download (36.4 KB) - added by WCarvalho 6 years ago.
TestA_Mini060908-01_162_without_AMDV.dmp Download (88.0 KB) - added by WCarvalho 6 years ago.
TestB_VBox_162_with_AMDV.log Download (35.0 KB) - added by WCarvalho 6 years ago.
TestB_Mini060908-01_with_AMDV.dmp Download (88.0 KB) - added by WCarvalho 6 years ago.

Change History

Changed 6 years ago by WCarvalho

Changed 6 years ago by WCarvalho

comment:1 Changed 6 years ago by WCarvalho

Well ... I'm sorry for it note... but... :-(

Have no success with v1.6.2... we still got a BSOD 0x0000008E...

(just for help: My Host is a WinXP SP3 and my Guest is a WinXP SP3...)

What can I do to help you guys ?... What can I do to help the AM2+ community?

Regards,

WCarvalho

comment:2 Changed 6 years ago by sandervl73

Attach a test application that shows this behaviour please.

comment:3 Changed 6 years ago by sandervl73

Or explain better how to reproduce it. We don't have access to Delphi here.

Including a minidump from the crashed session might also help.

comment:4 Changed 6 years ago by sandervl73

According to the log file you have not activated AMD-V for the VM. Try again with 1.6.2 and update the log file.

comment:5 Changed 6 years ago by WCarvalho

Hi sandervl73,

Here's the LOGs and MINIDUMPs from VBox 1.6.2 with and without AMD-V checked...

On boths I got BSOD 0x0000008E...

I'm here to help you... ;-)

Regards,

WCarvalho

Changed 6 years ago by WCarvalho

Changed 6 years ago by WCarvalho

Changed 6 years ago by WCarvalho

Changed 6 years ago by WCarvalho

comment:6 Changed 6 years ago by sandervl73

Looks like you're getting a page fault in the kernel which is not supposed to happen. Unfortunately the mini dump doesn't contain enough. A full system dump would tell a bit more, but it will be too big to attach here. Could you upload it somewhere?

comment:7 Changed 6 years ago by sandervl73

A kernel memory dump should suffice. (two relevant options here in Vista; small & kernel)

comment:8 Changed 6 years ago by WCarvalho

Here's the links for downloads... (case sensitive - Linux Server)

 http://www.botzin.net/vbox/memory_kernel_dump_without_AMDV.ZIP  http://www.botzin.net/vbox/memory_kernel_dump_with_AMDV.ZIP

(If needed I may upload full memory dump)

Let's go!

comment:9 Changed 6 years ago by sandervl73

Are you using shared folders to compile to/run from in your setup? If so, try to compile on the local drive.

comment:10 Changed 6 years ago by WCarvalho

Bingo!!!

It's work!!!

If you debug/run from Shared Folders, VBox crash with 0x000008E... I copy many projects into VDI and works fine... no crashes...

So What's the bug?

Note: I try with 1.5.8 and it crash too with BSOD 0x0000008E...

comment:11 Changed 6 years ago by WCarvalho

Do you need full memory dump or anything else?...

comment:12 Changed 6 years ago by WCarvalho

note: I always debug/compile my projects from Shared Folders... and have no troubles (until upgrade my hardware)...

comment:13 Changed 6 years ago by sunlover

Have you updated the guest additions to 1.6.2? Please verify the file date, size and version of \system32\drivers\VBoxGuests.sys, \system32\drivers\VBoxSF.sys and system32\vboxmrxnp.dll.

comment:14 Changed 6 years ago by frank

verify => please post these data here.

comment:15 Changed 6 years ago by WCarvalho

Yes! It's updated.. I always do that.

\system32\drivers\VBoxGuests.sys = size: 41.760 bytes, version: 1.6.2.31466 / 1.6.2.0 \system32\drivers\VBoxSF.sys = size: 194.048 bytes, version: 1.6.2.31466 / 1.6.2.0 system32\vboxmrxnp.dll = size: 60.352 bytes, version: 1.6.2.31466 / 1.6.2.0

Next step? :-)

comment:16 Changed 6 years ago by sandervl73

  • Summary changed from (AMD X2 AM2+ / DDR2 800mhz / HD UDMA mode 6) vs BSOD 0x0000008E to Shared Folders blue screen during compiling/debugging (winxp sp3)

comment:17 Changed 6 years ago by sandervl73

  • Priority changed from blocker to critical

comment:18 Changed 6 years ago by sandervl73

Next step is to reproduce it here, which might not be so easy.

comment:19 Changed 6 years ago by sunlover

  • Status changed from new to closed
  • Version changed from VirtualBox 1.6.0 to VirtualBox 1.6.2
  • Resolution set to fixed

The fix will be available in the next version of VirtualBox.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use