VirtualBox

Ticket #162 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Fedora Core 6 wont start properly in VBox (running on Mandriva 2007)

Reported by: k776 Owned by:
Priority: blocker Component: other
Version: VirtualBox 1.3.6 Keywords: fc6, mandriva2007, broken
Cc: Guest type: other
Host type: other

Description

I'm running Mandriva 2007, and install Virtualbox. Windows XP worked perfectly (except for resolutions), but when I downloaded a 3.3gig file for Fedora Core 6, install went perfectly, but on start up, I never reach the desktop. Its very sad, since 3.3gigs is about 80% of my monthly broadband limit and it doesn't work. Any chance for a patch to make it work?

Attachments

VBox.log Download (30.0 KB) - added by k776 11 years ago.

Change History

comment:1 Changed 11 years ago by umoeller

I just downloaded Fedora Cora 6 (the DVD), and it installed fine, and it boots to the desktop too. I don't know what went wrong on your system, but apparently it's not related to VirtualBox. Are you sure your download is not corrupted? Checking with some MD5/SHA-1 tool might help.

comment:2 Changed 11 years ago by umoeller

  • Status changed from new to closed
  • Resolution set to invalid

comment:3 Changed 11 years ago by k776

  • Status changed from closed to reopened
  • Resolution invalid deleted

But did you use the i386 version? Was VirtualBox being run on Mandriva? And is it the right DVD?

I used  ftp://ftp.wicks.co.nz/pub/linux/dist/fedora/6/i386/iso/FC-6-i386-DVD.iso (md5 of the file on the server and on my computer is not correct, 6722f95b97e5118fa26bafa5b9f622cc7d49530c 89d337f5543474532027950b44ecbdd5 , so it might be corrupt though, but again install went fine :S Wouldn't it have alerted me if it was corrupted?)

Just because it works for you doesn't mean it works for everyone. I'm reopening it as I have more information too.

It apparently freezes (thats why it never reaches the desktop). But after many restarts, it finally got to a first time configuration screen (firewall settings etc). After completing them (it didn't freeze), it rebooted, and went ok until it went to load the desktop, and it froze again.

I rebooted one more time, now every time I try to load it, it doesn't reach the desktop. It goes to a command prompt (shell console) and I dont know how to load anything from there.

I'll be reinstalling everything today using default settings set by VBox (I modified ram and hdd last time). If that doesn't work, I'll let you know.

comment:4 Changed 11 years ago by frank

Please could you append the release log of the session when the machine freezes?

Changed 11 years ago by k776

comment:5 Changed 11 years ago by k776

As I said in my post above

"I rebooted one more time, now every time I try to load it, it doesn't reach the desktop. It goes to a command prompt (shell console) and I dont know how to load anything from there."

So the freezing seems to have stopped since it reached first time config page, but after rebooting from that, still no desktop. Probably just Fedora realted? Any ideas?

comment:6 Changed 11 years ago by frank

Anyway, please would you upload the release log (~/.VirtualBox/Machines/.../Logs/VBox.log)?! And regarding not reaching the desktop: Please would you upload your Xorg.0.log (of the guest of course)? Thanks in advance.

comment:7 Changed 11 years ago by k776

I already did, several hours ago:  http://www.virtualbox.org/attachment/ticket/162/VBox.log

And as far as Xorg.0.log, where would I find that, cause its neither on my system nor the guests.

comment:8 Changed 11 years ago by frank

Sorry, didn't realize that you already sent VBox.log. The Xorg.0.log can be found in /var/log/. Please also send /etc/X11/xorg.conf. Thanks in advance.

comment:9 Changed 11 years ago by k776

I've found both files, and can access them, but I can't show you them because they wont copy over. I'm not copying it over by hand :P

comment:10 Changed 11 years ago by k776

Ok. I'm using the new 1.3.8. Here is a run through for me installing Fedora Core 6, as a Linux 2.6 OS type (that is correct?). Setting memory to 1024mb ram. Making new hard disk. Dynamic, with 11.33 GB. Done. Setting up to boot using ISO file. Starting.........

Hit Enter to install using graphics mode. Lots of console output. Testing ISO file (media check). Frozen on 73% (first freeze). Reseting.... DVD Media passed, continuing..... Frozen after hitting Ok (second freeze). Reseting..... Skipping media check (now I know it passed). Remove all partitions, create default layout.... All packages and settings remain (minus timezone, and root password)..... Install process started..... Opps. The whole process froze then aborted (third freeze and first shutdown).... It shut down on its own :S Restarting..... All default settings now (partitions, timezone, settings). Go to enter root password. Froze again (forth freeze). Restarting.... Just entered the install screen and freeze (fifth freeze). This is freezing earlier now :S Restarting.... Entered root password, Install process started..... Installation complete, rebooting.... Froze when starting Power Management services (sixth freeze). Rebooting.... Forze again between uncompressing and starting processes (seventh freeze)... rebooting... Forze again, then this between process's and services (eighth freeze).

I have had it :P It wont load properly anymore. Solution? VMWare. Installed and run perfectly first time. So its not the DVD media, it has to be VirtualBox. Sorry.

comment:11 follow-up: ↓ 13 Changed 11 years ago by sandervl73

It could be because of your AMD X2 cpu. Yesterday we fixed a problem related to timing on such cpus. If you can compile VBox yourself, you could try. Otherwise wait for the next release.

comment:12 Changed 11 years ago by sandervl73

You can try the workarounds in this defect too:  http://www.virtualbox.org/ticket/35

comment:13 in reply to: ↑ 11 Changed 11 years ago by dla

I also have trouble with FC6, but on WinXP host with VB 1.3.8: It just hangs before init can be started. At least to me, the workaround is to pass the enforcing=0 parameter to the kernel command line in grub (in the guest OS).

comment:14 Changed 11 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

I've fixed a problem with Fedora Core 5 hanging early during boot on some systems. As for the other report, my guess is still your X2 cpu. This has been fixed, so you'd better try the next release. Reopen if it still occurs.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use