VirtualBox

Ticket #1613 (closed defect: fixed)

Opened 6 years ago

Last modified 2 years ago

build_in_tmp not found => remove /etc/vbox/vbox.cfg

Reported by: choman Owned by:
Priority: major Component: installer
Version: VirtualBox 1.6.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

After a recent update to hardy heron (26 May 2008) which included a kernel update. Virtual box ceased to run a VM and produced a kernel module error. The Error message:

VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root. VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

Result Code: 0x80004005 Component: Console Interface: IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}


After running the suggested command to resolve the issue. The output log contained only the following line:

/etc/init.d/vboxdrv: 311: /usr/lib/virtualbox/src/build_in_tmp: not found

Change History

comment:1 follow-up: ↓ 4 Changed 6 years ago by frank

Which package did you install? It seems that you mixed some packages. You should find a file /etc/vbox/vbox.cfg which is not supposed to be there if you installed the .deb package from our website. Removing this file helps.

comment:2 Changed 6 years ago by frank

Or better remove the previous installation of a VirtualBox.run package first (VirtualBox.run uinstall).

comment:3 Changed 6 years ago by frank

  • Summary changed from Hardy Heron and build_in_tmp to build_in_tmp not found

comment:4 in reply to: ↑ 1 Changed 6 years ago by silentwind

Replying to frank:

Which package did you install? It seems that you mixed some packages. You should find a file /etc/vbox/vbox.cfg which is not supposed to be there if you installed the .deb package from our website. Removing this file helps.

I confirm this bug. I too confirm that removing /etc/vbox/vbox.cfg fix the problem. As a note, I install virtualbox-ose from ubuntu hardy repository once before removing it and download the version from sun's site.

comment:5 Changed 6 years ago by bluTiger

Confirmed too - after this mornings Ubuntu (7.1/x64) updates I got stuck in the same situation. Removing /etc/vbox/vbox.cfg fixed my problem as well.

comment:6 Changed 6 years ago by frank

Version 1.6.2 will contain a check which refuses to install the package if /etc/vbox/vbox.cfg was found.

comment:7 Changed 6 years ago by charonn0

I can also confirm the bug and that deleting /etc/vbox/vbox.cfg and then running the /etc/init.d/vboxdrv setup command afterwards clears up the problem.

comment:8 Changed 6 years ago by barranza

I can also confirm the bug and that deleting /etc/vbox/vbox.cfg and then running the /etc/init.d/vboxdrv setup command afterwards clears up the problem.

comment:9 Changed 6 years ago by frank

  • Host type changed from other to Linux

comment:10 Changed 6 years ago by frank

  • Component changed from other to installer

comment:11 Changed 6 years ago by frank

  • Summary changed from build_in_tmp not found to build_in_tmp not found => remove /etc/vbox/vbox.cfg

comment:12 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use