VirtualBox

Ticket #1599 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

DOS Navigator, problem with cursor keys

Reported by: PSL Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I tried VirtualBox 1.6 to run MS-DOS 6.22 based virtual PC. I found a problem with keyboard in some applications. For example DOS Navigator 1.51, NC like free clone manager, has a problem when I try to use up and down arrow keys to go through the list of files in the window, one file is skiped, like one key press of arrow creates two events. Similar problem in UFO manager (NC like manager), I can go through list of files without problem but I have a probelm in editor, when I press "arrow right", "66" is inserted to the text. Arrow left inserts "44". Arrow up inserts "88", arrow down inserts "22" and home key inserts "77". Sometimes, text is not inserted but two events are created, like in DOS Navigator case.

I run the same PC under VMWare player/server and I don't have problem like this one. I noticed similar problem when I run my image under MS VirtualPC in the past.

I can prepare disk image with DOS Navigator for test, on request. Problem is repeatable, I guess some problem with virtual keyboard implementation.

Change History

comment:1 Changed 6 years ago by PSL

I can repeat the issue with FreeDOS, no real difference.

I have disk image with FreeDOS and DOS Navigator 1.51 to demonstrate the problem, size is about 4M (ZIP). I cannot attach it as limit is 400k. Disk can be used with VMware and with VirtualBox 1.6.

comment:2 Changed 6 years ago by PSL

VMDK file (VMware disk image) with FreeDOS and DN can be downloaded from here, size about 4MB:

 http://psl.ic.cz/data/FreeDOS_DN.zip

FreeDOS_DN.vmdk disk can be used in VMware player and in VirtualBox 1.6. Disk can be used to verify difference between keyboard emulation in VMware and VirtualBox. Arrow keys (and other special keys) doesn't work well in DOS Naviator when run under Virtual Box. It is major issue related to DOS emulation.

comment:3 Changed 6 years ago by PSL

Retested with VirtualBox 1.6.2. Issue was not fixed yet.

comment:4 follow-up: ↓ 5 Changed 6 years ago by frank

  • Version changed from VirtualBox 1.6.0 to VirtualBox 1.6.2

comment:5 in reply to: ↑ 4 Changed 6 years ago by PSL

Retested with VirtualBox 1.6.4. Issue was not fixed yet.

comment:6 Changed 6 years ago by PSL

Ticket #58 describes similar or the same issue.

comment:7 Changed 6 years ago by PSL

Retested with VB 1.6.6 and 2.0.0. No improvement, I can repeat the issue.

comment:8 Changed 5 years ago by PSL

Retested with VB 2.1.0. I can repeat the issue.

comment:9 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 1.6.2 to VirtualBox 2.1.0

comment:10 Changed 5 years ago by akraievoy

Reproduced in VirtualBox v. 2.1.2, Dos 6.22. Apps used: NC, Turbo/Borland Pascal... #58 sees to be a dupe of this one.

comment:11 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Let's continue the discussion there then. Closing this one.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use