VirtualBox

Ticket #15962 (reopened defect)

Opened 6 years ago

Last modified 5 years ago

Wayland Login Manager Borks Login process in Fedora 24

Reported by: jerrysVB Owned by:
Component: GUI Version: VirtualBox 5.1.6
Keywords: login Cc:
Guest type: Linux Host type: other

Description

Host: MacOSX 10.11.6 Guest: Fedora 24 VB 5.1.6 I am not sure when this happened, but recently.

In the current version of Fedora 24 the Wayland Login Manager is used. Booting Fedora give a blank grey screen.

If I manually refresh the screen ( minimize or drag a window over the VM window) My login name will appear.

If I click on the login name and manually refresh the screen the password box will appear.

If I click on the password box and blind type ( no dots appear as I type) the password and hit return I will be presented with the desktop and everything ( except sound) works. Bummer.

If I go to /etc/gdm/custom.conf and uncomment out the line:

  # WaylandEnable=false

and reboot there is no problem ( well sound randomly appears and vanishes ).

I think Wayland will be the default in Fedora 25 so y'all might want to find out why the login screen is not properly being refreshed.

Change History

comment:1 Changed 6 years ago by frank

Could you install the latest 5.1.x Guest Additions from the test builds page (>= revision 110639) and check if the problem is fixed?

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 Changed 6 years ago by amasover

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am seeing exactly the same behavior in Fedora 25, VB 5.1.10, VB Guest Additions 5.1.10.

Uncommenting the "WaylandEnable=false" line is the only way that I can seem to login.

comment:4 Changed 6 years ago by michael

Please give the current development (not 5.1) test build<1> of the Guest Additions a try.

  1. https://www.virtualbox.org/wiki/Testbuilds#development_snapshots

comment:5 Changed 6 years ago by Dr. Moro

No change even with the latest test build of the Guest Additions! And the Xorg is buggy and too sluggish for regular use! Any fix soon?!

comment:6 Changed 5 years ago by michael

Does this happen with fresh guest installs? If not, could you please find the critical difference?

comment:7 Changed 5 years ago by michael

Also, please test with 3D disabled (possible duplicate of #16360). And please attach a log file - see the instructions here:

https://www.virtualbox.org/newticket

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use