VirtualBox

Ticket #15945 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

symlink in shared folder

Reported by: vDev Owned by:
Component: guest additions Version: VirtualBox 5.1.6
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description

I have a Linux guest VM on a Mac OS X host on VirtualBox 5.1.4. A nagging issue is the inability to create symlink on the shared folder.

~/macshared$ ln -s file symlinkfile ln: creating symbolic link `symlinkfile': Operation not permitted

I have followed other posts, with the following recommendation but it does not help.

VBoxManage setextradata VM_NAME VBoxInternal2/SharedFoldersEnableSymlinksCreate/SHARE_NAME 1

Change History

comment:1 in reply to: ↑ description Changed 6 years ago by ppanish

Replying to vDev: I'm posting a reply to receive notifications when this defect is updated. I have the same problem using VirtualBox v5.1.14 on a Mac host running ElCapitan. I've tried the VBoxManage... solution noted in this post and elsewhere with no success. I'm trying to backup an open source project from a shared directory on the host. My project uses automake, which requires symbolic links to function properly.

I have a Linux guest VM on a Mac OS X host on VirtualBox 5.1.4. A nagging issue is the inability to create symlink on the shared folder.

~/macshared$ ln -s file symlinkfile ln: creating symbolic link `symlinkfile': Operation not permitted

I have followed other posts, with the following recommendation but it does not help.

VBoxManage setextradata VM_NAME VBoxInternal2/SharedFoldersEnableSymlinksCreate/SHARE_NAME 1

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10085.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use