VirtualBox

Ticket #15944 (closed defect: fixed)

Opened 10 months ago

Last modified 9 months ago

Stop making assumptions about the size of the IMAGE_LOAD_CONFIG_DIRECTORY [FIXED IN SVN]

Reported by: Trance Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.6 Keywords: crash; IMAGE_LOAD_CONFIG_DIRECTORY; rs2
Cc: Guest type: all
Host type: Windows

Description (last modified by frank) (diff)

In latest builds of RS2 (windows builds greater than 14393), virtualbox will crash on launch due to dependencies on the size of IMAGE_LOAD_CONFIG_DIRECTORY.

FOLLOWUP_IP: 
VirtualBox+139bd
00007ff7`aae939bd 8a042515000000  mov     al,byte ptr [15h]

CONTEXT:  (.ecxr)
rax=00000000fffffd8e rbx=00007ff7aaf365c0 rcx=00000000004fe6b3
rdx=0000000000000000 rsi=0000000000000000 rdi=000000000000060a
rip=00007ff7aae939bd rsp=00000000004fe520 rbp=00000000004fe620
 r8=0000000000000000  r9=0000000000000000 r10=0000000000000003
r11=00000000004fe500 r12=00007ff7aaefc1b0 r13=00007ff7aaf365a0
r14=0000000000000000 r15=0000000000000280
iopl=0         nv up ei ng nz na po nc
cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010284
VirtualBox+0x139bd:
00007ff7`aae939bd 8a042515000000  mov     al,byte ptr [15h] ds:00000000`00000015=??

STACK_TEXT:  
00000000`004fe520 00007ff7`aaf365c0 : 00000000`004fe620 00000000`00000000 00000000`0000060a 00000000`004fe568 : VirtualBox+0x139bd
00000000`004fe528 00000000`004fe620 : 00000000`00000000 00000000`0000060a 00000000`004fe568 00000000`004fea00 : VirtualBox+0xb65c0
00000000`004fe530 00000000`00000000 : 00000000`0000060a 00000000`004fe568 00000000`004fea00 00000000`004fe930 : 0x4fe620

version: 5.1.5.10316

Change History

comment:1 Changed 10 months ago by frank

  • Description modified (diff)

comment:2 Changed 10 months ago by bird

Thanks for the report! I would have fixed it already if my windows 10 fast ring system wasn't busted by expired winload signing certificates, and apparently needs a complete reinstall. Many thanks to Microsoft.

comment:3 Changed 10 months ago by bird

#16051 is a duplicate of this one.

comment:4 Changed 10 months ago by mrg

Any update on a fix/workaround for this issue? VirtualBox will not start on Windows 10 build 14942.

comment:5 Changed 10 months ago by Zero3K

There's still no fix/workaround available.

comment:6 Changed 10 months ago by bird

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Stop making assumptions about the size of the IMAGE_LOAD_CONFIG_DIRECTORY to Stop making assumptions about the size of the IMAGE_LOAD_CONFIG_DIRECTORY [FIXED IN SVN]

comment:7 Changed 10 months ago by doodad

I can confirm VirtualBox is now working again on my machine with Windows 10 14942 on release 111203.

comment:8 Changed 9 months ago by palarnik

This is still appearing for some of us in 5.1.8 on Insider 14951

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use