VirtualBox

Ticket #15921 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

problems with capturing USB devices , says captured on hover but it's not

Reported by: mcirsta Owned by:
Component: USB Version: VirtualBox 5.1.6
Keywords: attach capture Cc:
Guest type: Linux Host type: Windows

Description

I have the Virtualbox on a Windows 7 x64 host and I'm using Kubuntu 14.04 as a guest. Until VirtualBox 5.1.0 I didn't have any problems attaching USB devices but then I installed VirtualBox 5.14 and since I haven't been able to see the host USB devices in the guest OS. I've tried reverting to older versions of Vbox ( 5.1.0 ) but it still doesn't work. What happens when I try to capture an USB devices it that it gets disconnected from the host but after a few seconds I can see it again in Device Manager and the guest can't access it of course. Attached are the logs, let me know if you need any additional info. I should also mention that I've installed the latest USB drivers for my Dell Precision Tower 5810 and that my updates are filtered by my company ( so I might be missing some ).

Attachments

Kubuntu 14.04-2016-09-13-12-31-20 - USB attach fail.log Download (68.5 KB) - added by mcirsta 5 years ago.
log of failing to capture USB device

Change History

Changed 5 years ago by mcirsta

log of failing to capture USB device

comment:1 Changed 5 years ago by mcirsta

One thing that might be of interest is that VmWare reports the following for one of the USB devices:

The device 'Telit Wireless Android' was unable to connect to its ideal host controller. An attempt will be made to connect this device to the best available host controller. This might result in undefined behavior for this device.

comment:2 Changed 5 years ago by mcirsta

This seems to have been both caused and fixed by some Windows 7 x64 update. However I think Vbox should have properly reported the failure ( and maybe even the cause in the logs ).

comment:3 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use