VirtualBox

Ticket #15898 (new defect)

Opened 3 years ago

Last modified 3 years ago

Add Shared Folder - pasting folder path causes VBox Manager to crash - until navigated to.

Reported by: RichardK Owned by:
Component: other Version: VirtualBox 5.1.4
Keywords: Qt5 "shared folder" Cc:
Guest type: all Host type: Windows

Description

VirtualBox Manager version 5.1.4.
Windows 10.

(Up to this time I have never tried to add a Shared Folder. Ie no VM has one, and I've never attempted to configure one.)

Select a VM.
Select Settings.
Select Shared Folders.
Select '+' to add a new shared folder.
Paste a folder path into the Folder Path entry box.
select OK.
VirtualBox Manager crashes.

This crash was completely repeatable until I approached the task in a different way.

Select a VM.
Select Settings.
Select Shared Folders.
Select '+' to add a new shared folder.
Select the drop-down arrow in the Folder Path entry box.
Navigate to the folder I want to add.
Select it.
Select 'Select Folder'.
All works fine.

After doing the task once this way it now works entirely satisfactorily doing it the first way, ie by pasting in a folder name.

So, not as serious a fault as I first thought but smells to me like something not initialized if one hits some code first by pasting the folder name rather than by navigating to it.


I have reported this on the forum and been advised that it is a Qt5 library issue and that I should report it here.

I have no unusual storage devices, it's a conventional Windows desktop computer. There is no Bluetooth.
The crash occurred for all the VMs that I tried. Most are Windows guests, one is Linux.
Once it works it continues to work.

Attachments

VBox manager crashes.7z Download (1.9 KB) - added by RichardK 3 years ago.
Collection of Windows Event notifications showing the issue.
Report1.7z Download (2.3 KB) - added by RichardK 3 years ago.
WER relating to this issue.
Report2.7z Download (2.3 KB) - added by RichardK 3 years ago.
Further WER relating to this issue.

Change History

Changed 3 years ago by RichardK

Collection of Windows Event notifications showing the issue.

Changed 3 years ago by RichardK

WER relating to this issue.

Changed 3 years ago by RichardK

Further WER relating to this issue.

comment:1 Changed 3 years ago by Santosh Kumar

Couldn't reproduce the issue on Windows7 and Windows10 machines here, but it might be something to do with the path you are pasting. There might be an issue in parsing the path. Could you please provide the example string of the path you are pasting?

comment:2 Changed 3 years ago by RichardK

The two I tried were as follows:

C:\Projects\Drivers\lawo\router\mxgui_config_share
C:\Projects\Drivers\lawo\router\mxgui_user_share

Part of the characteristic of this bug seemed to be that once it has started working right it continued to work. However, in retrying the steps just now I have found it crashing again.

Are you not able to find the location of the crash (ie the address, line number) from the error report files I have supplied ? Is there anything else I might have on my PC that might help you ? I'm wondering whether this crash might be similar in cause to another I'm getting on the same PC and have reported as Ticket 15930.

I'm well aware that it is machine specific as I have another PC where the fault doesn't show.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use