VirtualBox

Ticket #15888 (reopened defect)

Opened 3 years ago

Last modified 3 years ago

VirtualBox 5.1.0 - 5.1.4 Guest Additions problem in Windows XP Guest

Reported by: batyrulan Owned by:
Component: guest additions Version: VirtualBox 5.1.4
Keywords: gues additions windows xp Cc:
Guest type: Windows Host type: Windows

Description

Host: Windows 8.1 Pro 64 bit, Intel Core i7-4770K, 16 GB RAM

Guest: Windows XP SP3, 512 MB RAM, all other settings default.

Problem with guest additions in Windows XP

The guest additions worked properly in VirtualBox 5.0.24 and earlier. In all 5.1 versions (5.1.0 - 5.1.4) the following problems are observed:

•the guest additions icon does not appear in the system tray;

•seamless mode is disabled and does not switch;

•mouse wheel does not response.

I also noticed that VBoxTray process gets started but then terminates in approximately a minute after the start and guest additions icon never appears.

This problem pertains in my virtual machine with Windows XP what I used continuously with Virtual Box 5.0.24 without any problems.

Other guest OS including Windows 7, 8.1 and 10 do not have this problem.

Attachments

VBox.log Download (106.2 KB) - added by batyrulan 3 years ago.
VBoxHardening.log Download (303.7 KB) - added by batyrulan 3 years ago.

Change History

Changed 3 years ago by batyrulan

Changed 3 years ago by batyrulan

comment:1 Changed 3 years ago by frank

Looks like the Guest Additions service does not want to start for some reason. I don't remember if there was a related fix recently. Could you also try the 5.1.6 Guest Additions?

comment:2 follow-up: ↓ 3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 in reply to: ↑ 2 Changed 3 years ago by invite_ciel

Replying to frank:

Nope, still broken. I have same issue, but on Windows 10 guest. Host is Debian Jessie, Linux Kernel 4.7.8. I've tried both 5.1.6 & 5.1.8 Guest Additions versions - both broken. 5.0.28 now is the last working GA version.

VBoxTray.exe starts and rapidly exits - leaving no logs or anything useful to investigate.

What should I look for to trace the reason of this bug?

comment:4 Changed 3 years ago by invite_ciel

  • Status changed from closed to reopened
  • Resolution fixed deleted
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use