VirtualBox

Ticket #15875 (closed defect: fixed)

Opened 13 months ago

Last modified 13 months ago

Resizing problem with linux guests -> fixed in releases higher than 5.1.4

Reported by: mskov Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by michael) (diff)

Starting from VirtualBox 5.1.0 resizing of linux guests doesn't work well anymore. Sometimes it works, sometimes it takes a few seconds to resize and sometimes the screen doesn't resize at all (that happens on the same running instance of a VM, without restarting it). We observed this problem on VirtualBox 5.1.0, 5.1.2 and 5.1.4 (with the corresponding version of guest additions installed). The problem occurred both for the Ubuntu 15.04 guest and for a Debian 8 guest.

After every (!) restart of the VM I see the following messages in the system log:

Sep 01 18:40:36 sirrix-VirtualBox vboxadd.sh[654]: Starting the VirtualBox Guest Additions.
Sep 01 18:40:36 sirrix-VirtualBox vboxadd-x11.sh[706]: Installing the Window System drivers.
Sep 01 18:40:36 sirrix-VirtualBox vboxadd-x11.sh[714]: Installing X.Org Server 1.17 modules.
Sep 01 18:40:37 sirrix-VirtualBox vboxadd-x11.sh[727]: Setting up the Window System to use the Guest Additions.
Sep 01 18:40:37 sirrix-VirtualBox vboxadd[533]: You may need to restart the the Window System (or just restart the guest system)
Sep 01 18:40:37 sirrix-VirtualBox vboxadd[533]: to enable the Guest Additions.
Sep 01 18:40:37 sirrix-VirtualBox vboxadd-x11.sh[735]: Installing graphics libraries and desktop services components.
Sep 01 18:40:37 sirrix-VirtualBox vboxadd-x11.sh[748]: Window system drivers installed.
Sep 01 18:40:37 sirrix-VirtualBox vboxadd.sh[794]: .
Sep 01 18:40:37 sirrix-VirtualBox systemd[1]: Started vboxadd.service.

The VBox.log from 5.1.4 with an Ubuntu guest (guest additions 5.1.4) is attached.

If we revert the additions to 5.0.20 - all works fine (with virtualbox 5.1.4).

Attachments

Ubuntu 15.04-2016-09-01-18-36-23.log Download (153.9 KB) - added by mskov 13 months ago.

Change History

Changed 13 months ago by mskov

comment:1 Changed 13 months ago by mskov

Well, actually with additions 5.0.20 the resizing problem also occurs sometimes for me (with VirtualBox 5.1.4). But in that case I don't get those weird messages in the system log.

Last edited 13 months ago by mskov (previous) (diff)

comment:2 Changed 13 months ago by michael

  • Description modified (diff)

comment:3 Changed 13 months ago by michael

The log messages should be pretty easy to get rid of.

Please provide more information about the resizing problem, including how to reproduce it. Generally, we changed the way we report size changes in the guest to be more standard. So now desktop environments which handle resize events (i.e. monitor hot-plug) like GNOME and KDE should work more reliably. To take care of environments which still do not do this right (i.e. LXDE and XFCE if I remember correctly) we do a resize of the desktop ourselves after about three seconds if the environment does not do it when we report the change.

comment:4 Changed 13 months ago by michael

So if you are using a desktop environment other than GNOME or KDE a three second delay is most likely expected, and this is something that the environment should fix (you will probably find "resize and rotate handling" on the to do list on their web site). However, the delayed resize should still happen consistently.

comment:5 Changed 13 months ago by mskov

Ok, thanks for the information about those changes. I will do more tests in the next few days there to see if the resize after a 3 second delay really happens consistently or not (my feeling was that sometimes it doesn't happen) and for what desktop environments this happens. Doesn't look like a good change to me though. Could you also maybe clarify starting from what version of VirtualBox/GAs this change takes place? VBox 5.1.4 + GAs 5.0.12 seem to work fine for me, but VBox 5.1.4 + GAs 5.0.20 under some conditions have this 3 second delay and under others don't. While with VBox 5.1.4 + GAs 5.1.4 it never resizes immediately.

comment:6 Changed 13 months ago by michael

I think it was starting with the 5.0.16 Additions (the host version should not be very relevant). Any desktop environment which properly handles resize events (which were added in X.Org Server 1.3 in April 2007, so they have had enough time to look into it) should not suffer from the delay.

By the way, I will probably fix the log messages you mentioned, but not in 5.1 releases as I don't want to make unnecessary changes to the set-up scripts there.

comment:7 Changed 13 months ago by mskov

So, some test results with VBox 5.1.0 as a host:

Ubuntu 15.05, kernel: 3.19.0-15-generic, libgnome2-common: 2.32.1-4ubuntu1, unity: 7.3.2

with GAs 5.1.0 all works great. With GAs 5.1.4 sometimes it works, but usually doesn't resize at all (even after a 3 sec delay). If I run "xrandr" after a failed resize - it resizes fine. I can also see the resize events if I run "udevadm monitor".

Debian 8.3 (SMP Debian 3.16.7-ckt20-1+deb8u4), kernel: 3.16.0-4-amd64, openbox: 3.5.2-8

resizing happens with a 3 sec delay. But it happens consistently. I guess that's expected for openbox. But, I cannot see any resize events at all if I run "udevadm monitor". Is this expected in such a case?

Same debian with stable gnome: resizing works fine. But I still don't see any events if I run "udevadm monitor".

Last edited 13 months ago by mskov (previous) (diff)

comment:8 Changed 13 months ago by michael

If that Debian is using a version of X.Org Server older than 1.17 then no udev events are expected, as everything is done in user space. So the problem here is not so much Linux guests as Ubuntu guests with Unity?

comment:9 Changed 13 months ago by mskov

yes. the problem with Debian was some misconfiguration on my side. With a clean install I get the udev events as expected. So the real problem that I could reproduce thus far is the one for Ubuntu guests with unity and with GAs 5.1.4.

comment:10 Changed 13 months ago by michael

You write "Unity guests" in the plural. Does that mean that you have also tested this with a freshly installed guest? (Suggestive question!)

comment:11 Changed 13 months ago by mskov

no, I didn't test it with any other version of Ubuntu or unity.

comment:12 Changed 13 months ago by mskov

well, actually with Debian it also works a bit strange. I could get the event from "udevadm monitor" on a Debian 8.2 with openbox and GAs 5.1.2, but this only worked until I rebooted the VM. After that "udevadm monitor" didn't show anything anymore and the custom "udev" script which I added didn't trigger anymore. With GAs 5.1.4 it didn't show any events at all. This could be again a problem of my configuration though, since it was not a completely clean install. So, I did now a clean install of Debian 8.5 with the default Gnome (1:3.14+3) and GAs 5.1.4. And there resizing worked fine without a delay, but again, I could not see any events from "udevadm monitor" and I was getting a stack of warning messages in the systemlog after every resize:

Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): EDID vendor "VBX", prod id 0
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): DDCModeFromDetailedTiming: 1920x1096 Warning: We only handle separate sync.
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): Using hsync ranges from config file
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): Using vrefresh ranges from config file
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): Printing DDC gathered Modelines:
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): Modeline "1920x1096"x0.0  127.34  1920 1922 1924 1926  1096 1098 1100 1102 -h
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): EDID vendor "VBX", prod id 0
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): DDCModeFromDetailedTiming: 1920x1096 Warning: We only handle separate sync.
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): Using hsync ranges from config file
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): Using vrefresh ranges from config file
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): Printing DDC gathered Modelines:
Sep 07 13:51:17 debian gdm-Xorg-:0[558]: (II) VBoxVideo(0): Modeline "1920x1096"x0.0  127.34  1920 1922 1924 1926  1096 1098 1100 1102 -h
Last edited 13 months ago by mskov (previous) (diff)

comment:13 Changed 13 months ago by michael

I can reproduce this. Will investigate.

comment:14 Changed 13 months ago by michael

Please give the current 5.1 Guest Additions test build<1> a try.

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:15 Changed 13 months ago by mskov

I don't see any difference in behaviour of GAs 5.1.4r110228 (current test build) and the release version of GAs 5.1.4. Both for Debian and Ubuntu behaviour seems to be the same.

On Ubuntu I've also got once the following message in the systemlog:

 kernel: [drm:vbox_bo_push_sysram [vboxvideo]] *ERROR* unpin bad ffff88007ac18800

But that I saw only once. It doesn't happen every time when resizing stops working on Ubuntu.

comment:16 Changed 13 months ago by michael

The current test build is revision 110588.

Last edited 13 months ago by michael (previous) (diff)

comment:17 Changed 13 months ago by mskov

yeah, sorry, I've used a wrong version. With r110588 Ubuntu works perfectly fine. On Debian I still get those messages in the systemlog and don't see any events via "udevadm monitor". But the resizing itself also works perfectly fine there, so it cannot be considered as a bug. Thanks for a fix.

comment:18 Changed 13 months ago by michael

  • Summary changed from Resizing problem with linux guests to Resizing problem with linux guests -> fixed in releases higher than 5.1.4

comment:19 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use