VirtualBox

Ticket #15860 (closed defect: obsolete)

Opened 15 months ago

Last modified 2 days ago

RHEL/CENTOS 7.2 does not work any longer after installing guest extensions after 5.0.14 -> possibly obsolete

Reported by: HRZunibi Owned by:
Priority: major Component: guest additions/x11/graphics
Version: VirtualBox 5.1.4 Keywords: RedHat
Cc: raynebc Guest type: Linux
Host type: Windows

Description

Redhat 7.2 (and may other versions) crashes login screen when installing guest extensions above 5.0.14 (until 5.1.14). After rebooting before logging in I see message "Oh no! Smomething went wrong. A problem has occured and the system can't recover. Please log out and try again." - But I didn't log in before - so the messsage does not match the problem... But it is a freshly installed and patched dev. system of RHEL 7.2. A coworker told me, that this also happens under CENTOS 7.2. Clean shutdown via ACPI is possible.

Attachments

VBox.log_install_ext Download (140.1 KB) - added by HRZunibi 15 months ago.
vbox.log when installing the guest extensions
VBox.log_with_ext Download (127.6 KB) - added by HRZunibi 15 months ago.
vbox.log from first (unsusccessful) boot after installing guest extensions
Xorg.0.log_after_install Download (26.7 KB) - added by HRZunibi 15 months ago.
Logfile with crash
Xorg.0.log_b4_reboot Download (74.3 KB) - added by HRZunibi 15 months ago.
Logfile after installation of extensions before reboot
messages.txt Download (145.3 KB) - added by HRZunibi 15 months ago.
messages from the last reboot before installation until failure

Change History

Changed 15 months ago by HRZunibi

vbox.log when installing the guest extensions

Changed 15 months ago by HRZunibi

vbox.log from first (unsusccessful) boot after installing guest extensions

comment:1 Changed 15 months ago by frank

Do you have an Xorg.0.log file available from your guest?

comment:2 Changed 15 months ago by frank

And is there any change if you increase the amount of video memory to 128MB (you have 3D enabled for your guest)?

Last edited 15 months ago by frank (previous) (diff)

comment:3 Changed 15 months ago by HRZunibi

3d acceleration is enabled and video memory is currently 32MB. I just increased it to 128MB and retried (from snapshot of machine). Problem still exists.

Changed 15 months ago by HRZunibi

Logfile with crash

Changed 15 months ago by HRZunibi

Logfile after installation of extensions before reboot

comment:4 Changed 15 months ago by michael

Does this still happen with the latest Additions test build<1>? If it does, can you try looking for SELinux alerts?

sealert -a /var/log/audit/audit.log > selinux.log

This will generate a log file - selinux.log - that you can inspect and attach to this ticket.

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:5 Changed 15 months ago by HRZunibi

Hello!

I just installed the fresh released 5.1.6 version of guest extensions. Installation was successful and everything worked until I logged out. Before I was able to log in again the well known "Oh no! ..." screen appeared. That's what sealert dumps out:

found 0 alerts in /var/log/audit/audit.log

Changed 15 months ago by HRZunibi

messages from the last reboot before installation until failure

comment:6 Changed 15 months ago by michael

Can you reproduce this with a fresh installation of CentOS 7.2? If so, please give exact reproduction steps. (So far I have failed to reproduce it.)

comment:7 Changed 14 months ago by HRZunibi

Yes I was able to reproduce it with a fresh install. I made some snapshots of the machine when doing this. So I can send you the complete machine packed as an appliance / upload it to our cloud provider. Can I send you the link and credentials via another way (not publically readable) ie. PM?

Peter.

comment:8 Changed 14 months ago by michael

You can e-mail me at michael dot thayer at oracle. How long will the link be usable? I may not get the chance to look this week.

comment:9 Changed 14 months ago by HRZunibi

The link to our cloud has been sent by PM. Link (w. PW) is valid until Oct, 15th.

comment:10 Changed 14 months ago by michael

I tried mailing you back, will try here: I got the link but could not see any password.

comment:11 Changed 14 months ago by michael

Had a quick look, and it looks to me (based on the time stamps on the log files) as if CentOS does not even try to start gdm. Have to work out why not.

comment:12 Changed 14 months ago by michael

It is in runlevel 3, whatever that means when systemd is running. When I switch to runlevel 5 gdm starts, stops (crashes?) once and starts again. At that point I can log in.

comment:13 Changed 14 months ago by michael

Following a systemd FAQ on freedesktop.org<1> I did the following to change the runlevel, and the machine happily starts GDM.

# ln -sf /usr/lib/systemd/system/graphical.target /etc/systemd/system/default.target

I assume I am missing something here? Or perhaps it is due to the fact that I am running a development version of VirtualBox rather than 5.1.6. (I did not update the Additions in the virtual machine though.)

<1>  https://www.freedesktop.org/wiki/Software/systemd/FrequentlyAskedQuestions/

comment:14 Changed 14 months ago by HRZunibi

When I log in in runlevel 3 and give "init 5" to enable gdm login I get the well known but not loved "Oops!" and only a black screen after press the logout button. This is the behaviour since VBox 5.0.16. My version of VBox is 5.1.6r110634. Using VBox Extensions 5.0.14 everything works fine.

comment:15 Changed 14 months ago by michael

Does disabling 3D make a difference? If I read your log file correctly you are using the Windows software renderer ("GDI generic renderer") rather than a graphics card driver for 3D.

comment:16 Changed 14 months ago by HRZunibi

After disabling 3D acceleration it starts correctly.

comment:17 Changed 14 months ago by michael

  1. Out of interest, are you using RDP or something similar? That might explain why the generic renderer is being used.
  2. The current development snapshot (not the 5.1 build!) of the Guest Additions<1> should automatically detect this and disable 3D in the guest. It would be nice if you could test it and see if it solves your problem without disabling 3D in the machine settings. (In fact the Linux/X11 Additions code in the development snapshot is not very different to the 5.1 branch at the moment.)

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:18 Changed 14 months ago by HRZunibi

RDP is enabled but not in use. I've never tried to run a VBox machine inside a RDP session. Sounds funny but I think it does not make really sense (for GUI VBOXes)...

I'll give the TestBuild a try...

comment:19 Changed 13 months ago by HRZunibi

I just tried VBox 5.1.7r111271 with the matching extensions and it works. gdm login is possible. Re-enabling 3d acceleration results in a crash. So just before it only runs with disabled 3D-accelleration. Maybe this can be mentioned in the FAQ and/or docs...

Last edited 13 months ago by HRZunibi (previous) (diff)

comment:20 Changed 13 months ago by michael

A crash of the VirtualBox process on the host? If so, would you be able to provide us with a crash trace and/or a mini-dump<1>? I'm afraid that we currently can't provide anywhere to upload a mini-dump too, but if you can provide somewhere we can download it to, please send me an e-mail at michael dot thayer at oracle.

<1> https://www.virtualbox.org/wiki/Core_dump#WindowsMiniDumps

comment:21 Changed 13 months ago by HRZunibi

HellO!

It's not a crash on the host (sorry for the misunderstanding). It's just the "Oh no! Something has gone wrong."-Window on the guest side.

comment:22 Changed 13 months ago by michael

  • Cc raynebc added

Adding raynebc to CC.

comment:23 Changed 13 months ago by michael

Could you please check the result of VBoxClient --check3d (i.e. VBoxClient --check3d || echo "No 3D") on your guest machine when 3D is enabled with the latest Additions, from a text console or whatever? It should say "No 3D". If it does, perhaps you could take a look at the /sbin/rcvboxadd service script to see why the VirtualBox 3D libraries are still being set up?

comment:24 Changed 13 months ago by HRZunibi

The command "VBoxClient --check3d
echo "No 3D"" returns nothing (so 3D is enabled when enabling it in the VirtualBox Manager.

"/sbin/rcvboxadd status" returna "The VirtualBox Additions are currently running". "lsmod|grep -i vbox" just shows vboxguest and vboxsf. "/sbin/rcvboxadd-x11 status" returns nothing

Last edited 13 months ago by HRZunibi (previous) (diff)

comment:25 Changed 7 days ago by michael

  • Summary changed from RHEL/CENTOS 7.2 does not work any longer after installing guest extensions after 5.0.14 to RHEL/CENTOS 7.2 does not work any longer after installing guest extensions after 5.0.14 -> possibly obsolete

Is this still an issue with the current version?

comment:26 Changed 7 days ago by michael

If it is, please try a current test build.

comment:27 Changed 2 days ago by michael

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use