VirtualBox

Ticket #1584 (closed defect: duplicate)

Opened 6 years ago

Last modified 2 years ago

Guest Additions don't apply initial Host window size

Reported by: mss Owned by:
Priority: minor Component: other
Version: VirtualBox 1.6.0 Keywords:
Cc: Guest type: other
Host type: other

Description

There's a small glitch starting XP with Guest Additions on a Ubuntu 8.04 host: When I maximize the window while the Windows splash screen is still displayed (ie. the graphics driver not loaded), Windows won't recognize the screen size later on and just switch to whatever resolution was configured (800x600 in my case). I have to manually restore and re-maximize the window to get rid of the grey area around the window.

Maybe the Guest Additions/the driver should request the current screen size from the host after they got loaded or after the login or something like that.

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by finex

Could this ticket be considered as a duplicate of  http://www.virtualbox.org/ticket/5372 ?

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 4 years ago by mss

Replying to finex:

Could this ticket be considered as a duplicate of  http://www.virtualbox.org/ticket/5372 ?

Jepp, it is. No idea how to mark this a duplicate.

comment:3 in reply to: ↑ 2 Changed 4 years ago by finex

Replying to mss:

Jepp, it is. No idea how to mark this a duplicate.

Probably bugtracker admins could do it :-)

This bug has been submitted multiple times, merging them all could be helpful to give it more priority :-)

comment:4 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Guest Additions don't apply initial Host window size to Guest Additions don't apply initial Host window size -> working in current revision

This was not reproducible when I tested it on the most recent revision of VirtualBox. I will close it as obsolete.

comment:5 Changed 4 years ago by michael

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hm, tried it again and it doesn't seem to work after all.

comment:6 Changed 4 years ago by michael

  • Summary changed from Guest Additions don't apply initial Host window size -> working in current revision to Guest Additions don't apply initial Host window size

comment:7 Changed 4 years ago by michael

Ah, this occurs if I maximise the window during boot on a fresh start, but not if the virtual system has just rebooted.

comment:8 Changed 4 years ago by eFloh

someone with enough rights may close this as dup of #5372...

comment:9 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use