VirtualBox

Ticket #1582 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Mac OS X: cannot configure raw disk support

Reported by: hramrach Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.0 Keywords:
Cc: Guest type: other
Host type: other

Description

It is currently impossible to configure a real hardware disk or partition for use with a virtual machine in VirtualBox.

It is technically possible to do so but only by using a configuration tool for another virtualization solution, and it does not work on OS X.

There is no option for configuring multiple CD drives. As it is possible to configure any image as a CD-rom as long as its name ends with .iso it would be a possible workaround for the inability to configure physical disks.

Still it is very cumbersome to use this way as one cannot use a rescue live CD with so configures image. It is necessary to install an OS to an virtual disk image and only then it is possible to read disk images as CDs.

Change History

comment:1 Changed 6 years ago by michael

  • Summary changed from dick configuration very inflexible to disk configuration very inflexible

comment:2 Changed 6 years ago by frank

  • Summary changed from disk configuration very inflexible to Mac OS X: cannot configure raw disk support

The problem with having more than one CDROM drive is known and will be fixed in future releases, there are other bug reports open regarding this issue. So the remaining issue of your report is the missing support for raw partitions in Mac OS X.

comment:3 Changed 6 years ago by erstazi

This seems to be a duplicate of #1461

comment:4 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use