VirtualBox

Ticket #1578 (closed defect: fixed)

Opened 6 years ago

Last modified 5 months ago

Install fails on OSX

Reported by: huzzam Owned by:
Priority: major Component: host support
Version: VirtualBox 1.6.0 Keywords: install fail osx leopard
Cc: Guest type: other
Host type: Mac OS X

Description (last modified by frank) (diff)

I am unable to install VirtualBox 1.6.0 on my Mac (system details below). Install makes it almost all the way through, then gives this error:

Install Failed The following install step failed: run postflight script for Sun xVM VirtualBox Kernel Extension. Contact the software manufacturer for assistance.

I have an old, non-functional version of VirtualBox installed (1.4.1-beta2) which wouldn't launch anymore, I think since I upgraded to Leopard. I have a Macbook, Leopard 10.5.2, Core2Duo 2gHz, 2Gb ram, plenty of disk space.

Attachments

VB Install.log Download (14.0 KB) - added by MacHovis 5 years ago.
Extract from install.log showing VirtualBox installation activity
log Download (3.9 KB) - added by jasonm23 4 years ago.
VBox relevant grep of Mac /var/log/*log
VirtualBox.xml Download (2.3 KB) - added by simonvwade 4 years ago.
Windows XP.xml Download (9.0 KB) - added by simonvwade 4 years ago.
VBox.log Download (56.4 KB) - added by simonvwade 4 years ago.
vbox.log Download (16.1 KB) - added by pfudd 3 years ago.
grep -i vbox /var/log/*log

Change History

comment:1 Changed 6 years ago by bjepson

I received the same error, but my kernel crashed shortly after receiving this error. Here is the Panic Report:

Wed Jun  4 13:00:41 2008
panic(cpu 0 caller 0x001A8CD4): Kernel trap at 0x001902ef, type 14=page fault, registers:
CR0: 0x8001003b, CR2: 0x5c3223ec, CR3: 0x00cf2000, CR4: 0x00000660
EAX: 0x5c18136c, EBX: 0x00000000, ECX: 0x0669e208, EDX: 0x00000063
CR2: 0x5c3223ec, EBP: 0x54df7f08, ESI: 0x00000040, EDI: 0x5c3223ec
EFL: 0x00010202, EIP: 0x001902ef, CS:  0x00000008, DS:  0x01970010
Error code: 0x00000000

Backtrace, Format - Frame : Return Address (4 potential args on stack) 
0x54df7d18 : 0x12b0fa (0x459294 0x54df7d4c 0x133243 0x0) 
0x54df7d68 : 0x1a8cd4 (0x4627fc 0x1902ef 0xe 0x461fac) 
0x54df7e48 : 0x19ede5 (0x54df7e60 0x202 0x54df7f08 0x1902ef) 
0x54df7e58 : 0x1902ef (0xe 0x48 0x54df0010 0x140010) 
0x54df7f08 : 0x18f461 (0x5c18136c 0x5c3223ec 0x40 0x197ea74) 
0x54df7f38 : 0x3ea977 (0x5c3223ec 0x7e8b200 0x75e0208 0x0) 
0x54df7f78 : 0x13eb1d (0x0 0x0 0x0 0x0) 
0x54df7fc8 : 0x19ebdc (0x0 0x0 0x10 0x77eff40) 
Backtrace terminated-invalid frame pointer 0

BSD process name corresponding to current thread: kernel_task

Mac OS version:
9D34

Kernel version:
Darwin Kernel Version 9.3.0: Fri May 23 00:49:16 PDT 2008; root:xnu-1228.5.18~1/RELEASE_I386
System model name: MacBookPro3,1 (Mac-F4238BC8)

comment:2 Changed 6 years ago by frank

  • Component changed from other to host support

comment:3 Changed 6 years ago by frank

Please retry with 2.0.0 and reopen if the problem persists.

comment:4 Changed 6 years ago by huzzam

I did indeed have the same problem upgrading from 1.6.4 to 2.0.0. I was, however, able to resolve it by running the 1.6.4 uninstaller, rebooting, and running the 2.0.0 installer.

I'm not sure how to reopen the issue, as there doesn't seem to be any indication of status on this page.

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

I assume that this problem is finally fixed.

comment:6 Changed 5 years ago by jasonm23

  • Status changed from closed to reopened
  • Resolution fixed deleted

This is happening on my system. with VirtualBox-3.0.0-49315-OSX

System info:

Model Name: MacBook Pro 15"

Model Identifier: MacBookPro2,2 Processor Name: Intel Core 2 Duo Processor Speed: 2.33 GHz Number Of Processors: 1 Total Number Of Cores: 2 L2 Cache: 4 MB Memory: 4 GB Bus Speed: 667 MHz Boot ROM Version: MBP22.00A5.B07 SMC Version (system): 1.12f5 Serial Number (system): W870604LX6B Sudden Motion Sensor: State: Enabled


System Version: Mac OS X 10.5.7 (9J61) Kernel Version: Darwin 9.7.0


Changed 5 years ago by MacHovis

Extract from install.log showing VirtualBox installation activity

comment:7 Changed 5 years ago by MacHovis

This has happened to me on an iMac7,1, Intel Core 2 Duo, 2.4 GHz with 4GB RAM ever since 2.1.4 (i.e. the last version that installs successfully is 2.1.4).

Every time I try to install a later edition, the installation script stalls (progress indicator about 95% complete) and the system locks up. It is then necessary to reboot in safe mode, mount the installation dmg file for the failed version, run the uninstall script supplied and restart (in normal mode) to recover from the situation.

I have attached an extract from the install.log file that shows the installation of version VirtualBox-3.0.2-49928-OSX up to the point where the installation script stalls and the system hangs.

comment:8 follow-up: ↓ 9 Changed 5 years ago by jasonm23

=Upgrade of VirtualBox on OS X - v3.0.0 / v3.0.2=

It seems that the install scripts do not handle upgrading an existing installation. Failing on the "postflight" script.

To updgrade, Mac OS X users must...

# Uninstall the existing version of VirtualBox (using the uninstall on the new installation dmg, will work) # Reboot # Install VirtualBox

This obviously isn't a usable situation for a vast number of target users, I hope there is a fix soon.

comment:9 in reply to: ↑ 8 Changed 5 years ago by MacHovis

Replying to jasonm23:
I tried as you suggest for VirtualBox-3.0.4-50677-OSX but with the same result. I used the uninstall from VirtualBox-2.1.4-42893-OSX (the last version that installs properly for me) to remove that before attempting to install the newer version.
Running the installer for 3.0.4 croaks at the last stage when it is trying to install the Kernel Extensions. The machine locks up and I have to do a safe mode boot to recover the situation (i.e. run the uninstaller for the version that failed to install and then reboot).
I won't be trying this again until the installer get fixed.

comment:10 Changed 5 years ago by simonvwade

This also happened for me upgrading to version 3.0.6. Really hope there's a fix for this soon - not a good look.

comment:11 follow-up: ↓ 12 Changed 5 years ago by UoA-DL

I resolve this problem, by loading in OSX safe mode (hold down the shift key during startup), ran the uninstaller of the previously install virtualbox to remove any other files that the current version of uninstaller missed and then installed the current 3.0.8 version.

Restart in normal mode and virtualbox application now works.

comment:12 in reply to: ↑ 11 Changed 5 years ago by jasonm23

Replying to UoA-DL:

I resolve this problem, by loading in OSX safe mode (hold down the shift key during startup), ran the uninstaller of the previously install virtualbox to remove any other files that the current version of uninstaller missed and then installed the current 3.0.8 version.

Restart in normal mode and virtualbox application now works.

That's a useful workaround, let's hope there is a proper resolution to this year old issue, before another 12 months rolls around.

comment:13 Changed 4 years ago by frank

  • Host type changed from other to Mac OS X

Still relevant?

comment:14 Changed 4 years ago by simonvwade

Yes, still relevant. Happened to me last time I tried to upgrade.

comment:15 Changed 4 years ago by poetzsch

Please check if there is something unusual in the logs of your Mac OS X system when trying to install VBox. You find them either in /var/log or by starting the Console.app. Search for all stuff which include VBox.

Changed 4 years ago by jasonm23

  • attachment log Download added

VBox relevant grep of Mac /var/log/*log

comment:16 Changed 4 years ago by simonvwade

Below are the entries from the console after installing:

12/05/10 4:39:55 PM Installer[27760] ================================================================================ 12/05/10 4:39:55 PM Installer[27760] User picked Standard Install 12/05/10 4:39:55 PM Installer[27760] Choices selected for installation: 12/05/10 4:39:55 PM Installer[27760] Upgrade: "Sun VirtualBox" 12/05/10 4:39:55 PM Installer[27760] Upgrade: "Sun VirtualBox Kernel Extensions" 12/05/10 4:39:55 PM Installer[27760] Upgrade: "Sun VirtualBox Startup Items" 12/05/10 4:39:55 PM Installer[27760] Upgrade: "Sun VirtualBox" 12/05/10 4:39:55 PM Installer[27760] Upgrade: "Sun VirtualBox Command Line Utilities" 12/05/10 4:39:55 PM Installer[27760] ================================================================================ 12/05/10 4:39:56 PM Installer[27760] Configuring volume "Macintosh HD" 12/05/10 4:39:56 PM Installer[27760] Free space on "Macintosh HD": 4.82 GB (4818739200 bytes). 12/05/10 4:39:56 PM Installer[27760] Create temporary directory "/var/folders/n+/n+qaAhMzE3Syq4WqxKa9pk+++TI/-Tmp-Install.277601PnIua" 12/05/10 4:39:56 PM Installer[27760] IFPKInstallElement (4 packages) 12/05/10 4:39:56 PM installd[27791] PackageKit: ----- Begin install ----- 12/05/10 4:40:33 PM kernel Can't unload kext org.virtualbox.kext.VBoxUSB; classes have instances: 12/05/10 4:40:33 PM kernel Kext org.virtualbox.kext.VBoxUSB class org_virtualbox_VBoxUSB has 1 instance. 12/05/10 4:40:33 PM kernel Kext org.virtualbox.kext.VBoxUSB class org_virtualbox_VBoxUSBClient has 3 instances. 12/05/10 4:40:33 PM kernel Kext org.virtualbox.kext.VBoxUSB class org_virtualbox_VBoxUSBDevice has 1 instance. 12/05/10 4:40:33 PM kernel Kext org.virtualbox.kext.VBoxUSB class org_virtualbox_VBoxUSBInterface has 3 instances. 12/05/10 4:40:36 PM com.apple.kextd[10] Can't load /Library/Extensions/VBoxDrv.kext - a different version is already loaded. 12/05/10 4:40:36 PM com.apple.kextd[10] Failed to load /Library/Extensions/VBoxDrv.kext - (libkern/kext) different version/uuid already loaded. 12/05/10 4:40:36 PM installd[27791] PackageKit: Install Failed: PKG: post-flight scripts for "org.virtualbox.pkg.vboxkexts" Error Domain=PKInstallErrorDomain Code=112 UserInfo=0x101e7ffe0 "An error occurred while running scripts from the package “VBoxKEXTs.pkg”." {

NSFilePath = "./postflight"; NSLocalizedDescription = "An error occurred while running scripts from the package \U201cVBoxKEXTs.pkg\U201d."; NSURL = "./Contents/Packages/VBoxKEXTs.pkg --  file://localhost/Volumes/VirtualBox/VirtualBox.mpkg/"; PKInstallPackageIdentifier = "org.virtualbox.pkg.vboxkexts";

} 12/05/10 4:40:36 PM Installer[27760] Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance. 12/05/10 4:40:37 PM Installer[27760] IFDInstallController 320DC0 state = 7 12/05/10 4:40:37 PM Installer[27760] Displaying 'Install Failed' UI. 12/05/10 4:40:37 PM Installer[27760] 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'. 12/05/10 4:40:37 PM Installer[27760] The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.

comment:17 Changed 4 years ago by poetzsch

This shows that the old kernel extension could not be unloaded. That is the reason why the installer fails. Now we need to find out why it couldn't be unloaded. When installing a new version, you have to make absolutely sure that there is no part of VirtualBox running. Please check with "ps -A | grep -i box" in a Terminal window if there are some processes of VBox left before trying to install it. Also please execute "sudo /Library/StartupItems/VirtualBox/VirtualBox stop" and post the output here.

comment:18 Changed 4 years ago by simonvwade

VB is running, before starting a VM:

  661 ??         0:01.03 /Applications/VirtualBox.app/Contents/MacOS/VirtualBox -psn_0_180268
  668 ??         0:00.06 /Applications/VirtualBox.app/Contents/MacOS/VBoxXPCOMIPCD
  673 ??         0:01.99 /Applications/VirtualBox.app/Contents/MacOS/VBoxSVC --pipe 9 --auto-shutdown

When a VM is running:

  661 ??         0:01.55 /Applications/VirtualBox.app/Contents/MacOS/VirtualBox -psn_0_180268
  668 ??         0:00.18 /Applications/VirtualBox.app/Contents/MacOS/VBoxXPCOMIPCD
  673 ??         0:02.23 /Applications/VirtualBox.app/Contents/MacOS/VBoxSVC --pipe 9 --auto-shutdown
  809 ??         0:00.85 /Applications/VirtualBox.app/Contents/MacOS/../Resources/VirtualBoxVM.app/Contents/MacOS/VirtualBoxVM --comment Windows XP --startvm e2cd0f4a-bda5-4476-8038-e028141ac70c

After VB has been shut down, there are no processes still running.

When I run "sudo /Library/StartupItems/VirtualBox/VirtualBox stop" this is the output:


Unloading VBoxUSB.kext
(kernel) Can't unload kext org.virtualbox.kext.VBoxUSB; classes have instances:
(kernel)     Kext org.virtualbox.kext.VBoxUSB class org_virtualbox_VBoxUSB has 1 instance.
(kernel)     Kext org.virtualbox.kext.VBoxUSB class org_virtualbox_VBoxUSBClient has 1 instance.
Failed to unload org.virtualbox.kext.VBoxUSB - (libkern/kext) kext is in use or retained (cannot unload).
-v Error: Failed to unload VBoxUSB.kext
Unloading VBoxNetFlt.kext
Unloading VBoxNetAdp.kext
Unloading VBoxDrv.kext
Failed to unload org.virtualbox.kext.VBoxDrv - (libkern/kext) kext is in use or retained (cannot unload).
-v Error: Failed to unload VBoxDrv.kext
-f VirtualBox

comment:19 Changed 4 years ago by poetzsch

Are you using any USB devices within VirtualBox? Can you please attach the VBox.log of your WinXP VM and maybe the config xml file. Does the uninstall also fail if you try it directly after a reboot of your Mac?

comment:20 Changed 4 years ago by simonvwade

The only USB devices are my keyboard, and possibly iSight - but even if I don't use iSight it stil fails.

The problem doesn't happen if I haven't started VirtualBox after a reboot.

comment:21 Changed 4 years ago by poetzsch

Are you using this USB keyboard exclusively in the VM? Please attach the xml config and a vbox log file. Also please attach the output of kextstat after using the VM. Sorry for asking so much questions, but I can't reproduce that behavior.

comment:22 Changed 4 years ago by simonvwade

I'm not using this USB keyboard exclusively in the VM - it's just my normal keyboard for the host.

Have attached requested XML and log files.

kextstat follows:

Index Refs Address    Size       Wired      Name (Version) <Linked Against>
    1   86 0          0          0          com.apple.kpi.bsd (10.3.0)
    2    4 0          0          0          com.apple.kpi.dsep (10.3.0)
    3  117 0          0          0          com.apple.kpi.iokit (10.3.0)
    4  124 0          0          0          com.apple.kpi.libkern (10.3.0)
    5  107 0          0          0          com.apple.kpi.mach (10.3.0)
    6   29 0          0          0          com.apple.kpi.private (10.3.0)
    7   54 0          0          0          com.apple.kpi.unsupported (10.3.0)
    8    1 0          0          0          com.apple.kernel.6.0 (7.9.9)
    9    0 0          0          0          com.apple.kernel.bsd (7.9.9)
   10    0 0          0          0          com.apple.kernel.iokit (7.9.9)
   11    3 0          0          0          com.apple.kernel.libkern (7.9.9)
   12    1 0          0          0          com.apple.kernel.mach (7.9.9)
   13   10 0x96b000   0x4000     0x3000     com.apple.iokit.IOACPIFamily (1.3.0) <7 6 4 3>
   14   22 0x97f000   0x11000    0x10000    com.apple.iokit.IOPCIFamily (2.6) <7 5 4 3>
   15    2 0xe96000   0x41000    0x40000    com.apple.driver.AppleACPIPlatform (1.3.2) <14 13 7 6 5 4 3>
   16    0 0x11b4000  0x1c000    0x1b000    com.apple.driver.AppleIntelCPUPowerManagement (104.3.0) <7 6 5 4 3 1>
   17   11 0xfce000   0x18000    0x17000    com.apple.iokit.IOStorageFamily (1.6) <7 6 5 4 3 1>
   18    0 0x12e2000  0x11000    0x10000    com.apple.driver.DiskImages (283) <17 7 6 5 4 3 1>
   19    0 0x1418000  0x8000     0x7000     com.apple.nke.applicationfirewall (2.1.11) <7 6 5 4 3 1>
   20    0 0x183e000  0x3000     0x2000     com.apple.security.TMSafetyNet (6) <7 6 5 4 2 1>
   21    2 0x1841000  0x3000     0x2000     com.apple.kext.AppleMatch (1.0.0d1) <4 1>
   22    0 0x1844000  0x5000     0x4000     com.apple.security.quarantine (0) <21 7 6 5 4 2 1>
   23    0 0x1849000  0x8000     0x7000     com.apple.security.sandbox (0) <21 7 6 5 4 2 1>
   24    0 0x11d0000  0x3000     0x2000     com.apple.driver.AppleIntelCPUPowerManagementClient (104.3.0) <7 6 5 4 3 1>
   25    0 0xef9000   0x3000     0x2000     com.apple.driver.AppleAPIC (1.4) <4 3>
   26    2 0xedb000   0x3000     0x2000     com.apple.iokit.IOSMBusFamily (1.1) <5 4 3>
   27    0 0xede000   0x5000     0x4000     com.apple.driver.AppleACPIEC (1.3.2) <26 15 13 5 4 3>
   28    0 0x1252000  0x4000     0x3000     com.apple.driver.AppleSMBIOS (1.5) <7 4 3>
   29   12 0xe5b000   0x3b000    0x3a000    com.apple.iokit.IOHIDFamily (1.6.2) <7 6 5 4 3 1>
   30    0 0xed7000   0x4000     0x3000     com.apple.driver.AppleACPIButtons (1.3.2) <29 15 13 7 6 5 4 3 1>
   31   16 0x1178000  0x31000    0x30000    com.apple.iokit.IOUSBFamily (3.9.6) <14 7 5 4 3 1>
   32    0 0x12be000  0x10000    0xf000     com.apple.driver.AppleUSBUHCI (3.9.6) <31 14 7 5 4 3 1>
   33    0 0x1170000  0x3000     0x2000     com.apple.driver.AppleHPET (1.5) <13 7 5 4 3>
   34    0 0x124c000  0x6000     0x5000     com.apple.driver.AppleRTC (1.3.1) <13 5 4 3 1>
   35    1 0xf5c000   0x3000     0x2000     com.apple.driver.AppleEFIRuntime (1.3.0) <7 5 4 3>
   36    0 0xf5f000   0x6000     0x5000     com.apple.driver.AppleEFINVRAM (1.3.0) <35 7 5 4 3>
   37    6 0xd5a000   0x16000    0x15000    com.apple.iokit.IONetworkingFamily (1.9) <7 6 5 4 3 1>
   38    0 0x1319000  0x2c000    0x2b000    com.apple.iokit.AppleYukon2 (3.1.14b1) <37 14 5 4 3 1>
   39    2 0x120d000  0xd000     0xc000     com.apple.iokit.IOATAFamily (2.5.1) <5 4 3 1>
   40    0 0x121a000  0x9000     0x8000     com.apple.driver.AppleIntelPIIXATA (2.5.1) <39 14 5 4 3>
   41    2 0xee3000   0x6000     0x5000     com.apple.iokit.IOAHCIFamily (2.0.3) <5 4 3 1>
   42    0 0xee9000   0x10000    0xf000     com.apple.driver.AppleAHCIPort (2.1.1) <41 14 5 4 3 1>
   43    2 0xf65000   0x43000    0x42000    com.apple.iokit.IOFireWireFamily (4.2.6) <5 4 3 1>
   44    0 0xfa8000   0x26000    0x25000    com.apple.driver.AppleFWOHCI (4.5.7) <43 14 7 6 5 4 3 1>
   45    0 0x1256000  0x7000     0x6000     com.apple.driver.AppleSmartBatteryManager (160.0.0) <26 13 5 4 3 1>
   46    0 0x1271000  0x16000    0x15000    com.apple.driver.AppleUSBEHCI (3.9.6) <31 14 7 5 4 3 1>
   47    0 0x960000   0x6000     0x5000     com.apple.AppleFSCompression.AppleFSCompressionTypeZlib (1.0.0d1) <6 4 3 2 1>
   48    0 0x966000   0x5000     0x4000     com.apple.BootCache (31) <7 6 5 4 3 1>
   50    1 0x13bf000  0x2000     0x1000     com.apple.iokit.IOUSBUserClient (3.9.6) <31 7 5 4 3 1>
   51    0 0x128d000  0x11000    0x10000    com.apple.driver.AppleUSBHub (3.9.6) <31 5 4 3 1>
   52    5 0x1370000  0x1a000    0x19000    com.apple.iokit.IOSCSIArchitectureModelFamily (2.6.2) <5 4 3 1>
   53    0 0x138a000  0x5000     0x4000     com.apple.iokit.IOATAPIProtocolTransport (2.5.1) <52 39 5 4 3 1>
   54    3 0x1398000  0x8000     0x7000     com.apple.iokit.IOCDStorageFamily (1.6) <17 5 4 3 1>
   55    2 0x13a0000  0x6000     0x5000     com.apple.iokit.IODVDStorageFamily (1.6) <54 17 5 4 3 1>
   56    1 0x13d9000  0x5000     0x4000     com.apple.iokit.IOBDStorageFamily (1.6) <55 54 17 5 4 3 1>
   57    0 0x13de000  0x18000    0x17000    com.apple.iokit.IOSCSIMultimediaCommandsDevice (2.6.2) <56 55 54 52 17 5 4 3 1>
   58    0 0x140c000  0x7000     0x6000     com.apple.iokit.SCSITaskUserClient (2.6.2) <52 17 5 4 3 1>
   59    1 0x1232000  0x4000     0x3000     com.apple.driver.AppleUSBComposite (3.9.0) <31 4 3 1>
   60    0 0x1236000  0x4000     0x3000     com.apple.driver.AppleUSBMergeNub (3.9.6) <59 31 4 3 1>
   61    0 0x135d000  0x13000    0x12000    com.apple.iokit.IOAHCIBlockStorage (1.6.1) <41 17 5 4 3 1>
   62    0 0x130c000  0x3000     0x2000     com.apple.driver.XsanFilter (402.1) <17 5 4 3 1>
   64    3 0x11a9000  0x6000     0x5000     com.apple.iokit.IOUSBHIDDriver (3.9.6) <31 29 5 4 3 1>
   65    1 0x116e000  0x2000     0x1000     com.apple.driver.AppleHIDKeyboard (1.2.0a3) <29 4 3>
   66    0 0x128b000  0x2000     0x1000     com.apple.driver.AppleUSBHIDKeyboard (1.2.0a3) <65 64 29 4 3>
   67    0 0x11af000  0x5000     0x4000     com.apple.driver.AppleIRController (303) <64 31 29 5 4 3>
   68    0 0x12a0000  0x4000     0x3000     com.apple.driver.AppleUSBTCKeyboard (1.8.1b1) <64 31 29 7 6 5 4 3 1>
   69    0 0x129e000  0x2000     0x1000     com.apple.driver.AppleUSBTCKeyEventDriver (1.8.1b1) <29 5 4 3>
   70    0 0x12a4000  0x1a000    0x19000    com.apple.driver.AppleUSBTrackpad (1.8.1b1) <31 29 5 4 3>
   71    5 0xf00000   0x3d000    0x3c000    com.apple.iokit.IOBluetoothFamily (2.3.1f4) <7 5 4 3 1>
   72    1 0x1266000  0xb000     0xa000     com.apple.driver.AppleUSBBluetoothHCIController (2.3.1f4) <71 31 7 5 4 3>
   73    0 0x12de000  0x4000     0x3000     com.apple.driver.CSRUSBBluetoothHCIController (2.3.1f4) <72 71 31 5 4 3>
   74    9 0x990000   0x21000    0x20000    com.apple.iokit.IOGraphicsFamily (2.1) <14 7 5 4 3>
   75    4 0x9b1000   0xd000     0xc000     com.apple.iokit.IONDRVSupport (2.1) <74 14 7 5 4 3>
   76    2 0x9be000   0x2d9000   0x2d8000   com.apple.NVDAResman (6.1.0) <75 74 14 5 4 3 1>
   77    0 0x1420000  0x41e000   0x41d000   com.apple.nvidia.nv50hal (6.1.0) <76 4 3>
   78    0 0xc97000   0xa9000    0xa8000    com.apple.GeForce (6.1.0) <76 75 74 14 7 6 5 4 3 1>
   79    0 0x1911000  0x4000     0x3000     com.parallels.kext.prl_usb_connect (4.0 3810.351321) <31 7 5 4 3>
   80    0 0xefc000   0x4000     0x3000     com.apple.driver.AppleBacklight (170.0.16) <75 74 14 5 4 3>
   82    0 0x122f000  0x3000     0x2000     com.apple.driver.AppleLPC (1.4.11) <14 5 4 3>
   83    1 0xd40000   0xa000     0x9000     com.apple.driver.IOPlatformPluginFamily (4.1.1d0) <6 5 4 3>
   84    4 0x96f000   0xa000     0x9000     com.apple.driver.AppleSMC (3.0.1d2) <13 7 5 4 3>
   85    0 0xd4a000   0x10000    0xf000     com.apple.driver.ACPI_SMC_PlatformPlugin (4.1.1d0) <84 83 14 13 7 6 5 4 3>
   86    7 0x11d3000  0x2c000    0x2b000    com.apple.iokit.AppleProfileFamily (41) <14 7 6 5 4 3 1>
   87    0 0x11ff000  0x7000     0x6000     com.apple.driver.AppleIntelMeromProfile (19.1) <86 6 5 4 3>
   91    2 0x1005000  0x7000     0x6000     com.apple.iokit.IOHDAFamily (1.8.4fc3) <5 4 3 1>
   92    1 0x100c000  0x16000    0x15000    com.apple.driver.AppleHDAController (1.8.4fc3) <91 74 14 5 4 3 1>
   93    2 0x1022000  0x4000     0x3000     com.apple.kext.OSvKernDSPLib (1.3) <5 4>
   94    4 0x1026000  0x18000    0x17000    com.apple.iokit.IOAudioFamily (1.7.6fc2) <93 5 4 3 1>
   95    0 0x12d7000  0x4000     0x3000     com.apple.driver.AudioIPCDriver (1.1.2) <94 5 4 3 1>
   96    2 0x1345000  0x5000     0x4000     com.apple.iokit.CHUDKernLib (208) <6 5 4 3 1>
   97    0 0x134a000  0xc000     0xb000     com.apple.iokit.CHUDProf (216) <96 12 7 5 4 3 1>
   98    0 0x1356000  0x7000     0x6000     com.apple.iokit.CHUDUtils (201) <96 5 4 3 1>
   99    0 0x1851000  0x24000    0x23000    com.digidesign.iokit.DigiDal (7.4f1) <14 5 4 3>
  100    0 0x1875000  0x7000     0x6000     com.digidesign.iokit.DigiIO (7.4f1) <17 14 8 7 6 5 4 3 1>
  101    0 0x979000   0x6000     0x5000     com.apple.Dont_Steal_Mac_OS_X (7.0.0) <84 7 4 3 1>
  102    1 0x12f9000  0x9000     0x8000     com.apple.iokit.IOSerialFamily (10.0.3) <7 6 5 4 3 1>
  103    0 0x138f000  0x9000     0x8000     com.apple.iokit.IOBluetoothSerialManager (2.3.1f4) <102 7 5 4 3 1>
  104    0 0x13f6000  0xb000     0xa000     com.apple.iokit.IOSurface (74.0) <7 5 4 3 1>
  105    0 0x1413000  0x5000     0x4000     com.apple.kext.AppleSMCLMU (1.5.0d1) <84 74 5 4 3>
  106    0 0x187f000  0x3000     0x2000     com.parallels.kext.prl_hid_hook (4.0 3810.351321) <7 5 4 3 1>
  107    0 0x1882000  0x88000    0x87000    com.parallels.kext.prl_hypervisor (4.0 3810.351321) <11 7 5 4 3 1>
  108    0 0x190a000  0x7000     0x6000     com.parallels.kext.prl_netbridge (4.0 3810.351321) <5 4 3 1>
  109    0 0x1915000  0x5000     0x4000     com.parallels.kext.prl_vnic (4.0 3810.351321) <37 4 3>
  110    1 0xd70000   0x24000    0x23000    com.apple.iokit.IO80211Family (310.6) <37 7 5 4 3 1>
  111    0 0xd94000   0xc7000    0xc6000    com.apple.driver.AirPort.Atheros (422.19.10) <110 37 14 7 5 4 3 1>
  112    0 0x13b6000  0x9000     0x8000     com.apple.iokit.IOFireWireIP (2.0.3) <43 37 5 4 3 1>
  113    0 0x1306000  0x6000     0x5000     com.apple.driver.SMCMotionSensor (3.0.0d4) <84 5 4 3>
  114    0 0x123a000  0x3000     0x2000     com.apple.driver.AppleProfileCallstackAction (20) <86 5 4 3 1>
  115    0 0x123d000  0x3000     0x2000     com.apple.driver.AppleProfileKEventAction (10) <86 4 3 1>
  116    0 0x12d3000  0x4000     0x3000     com.apple.driver.AudioAUUC (1.4) <94 74 14 13 7 5 4 3 1>
  117    0 0x1243000  0x3000     0x2000     com.apple.driver.AppleProfileRegisterStateAction (10) <86 4 3 1>
  118    0 0x1246000  0x3000     0x2000     com.apple.driver.AppleProfileThreadInfoAction (14) <86 6 4 3 1>
  119    0 0x1249000  0x3000     0x2000     com.apple.driver.AppleProfileTimestampAction (10) <86 5 4 3 1>
  120    0 0x12ce000  0x5000     0x4000     com.apple.driver.AppleUpstreamUserClient (3.3.2) <74 14 13 7 5 4 3 1>
  121    0 0x1240000  0x3000     0x2000     com.apple.driver.AppleProfileReadCounterAction (17) <86 6 4 3>
  122    1 0x103e000  0x7f000    0x7e000    com.apple.driver.DspFuncLib (1.8.4fc3) <94 93 5 4 3 1>
  123    0 0x10bd000  0xad000    0xac000    com.apple.driver.AppleHDA (1.8.4fc3) <122 94 92 91 75 74 5 4 3 1>
  127    0 0x12f3000  0x6000     0x5000     com.apple.driver.IOBluetoothBNEPDriver (2.3.1f4) <71 37 7 5 4 3 1>
  129    0 0x187c000  0x3000     0x2000     com.paceap.kext.pacesupport.snowleopard (5.7.2) <7 5 4 3 1>
  130    0 0x130f000  0xa000     0x9000     com.apple.filesystems.autofs (2.1.0) <7 6 5 4 3 1>
  131    0 0x5dd8d000 0x64000    0x63000    com.vmware.kext.vmx86 (1.1.1fc2) <11 5 4 3 1>
  132    0 0x5dcf5000 0xa000     0x9000     com.vmware.kext.vmci (1.1.1fc2) <5 4 3 1>
  133    0 0x90e000   0x52000    0x51000    com.apani.nke.ApaniKernel (3.3) <5 4 1>
  134    0 0x5dd3b000 0x6000     0x5000     com.vmware.kext.vmioplug (1.1.1fc2) <31 29 5 4 3>
  135    3 0x5dd66000 0x23000    0x22000    org.virtualbox.kext.VBoxDrv (3.1.8) <7 5 4 3 1>
  136    0 0x5dd46000 0x8000     0x7000     com.vmware.kext.vmnet (1.1.1fc2) <11 5 4 3 1>
  137    0 0x5dd4e000 0x7000     0x6000     org.virtualbox.kext.VBoxUSB (3.1.8) <135 50 31 7 5 4 3 1>
  138    0 0x5ddfa000 0x4000     0x3000     org.virtualbox.kext.VBoxNetFlt (3.1.8) <135 7 5 4 3 1>
  139    0 0x5dd38000 0x3000     0x2000     org.virtualbox.kext.VBoxNetAdp (3.1.8) <135 5 4 1>
  140    0 0x1173000  0x5000     0x4000     com.apple.driver.AppleHWSensor (1.9.3d0) <5 4 3>
  141    1 0xf3d000   0x9000     0x8000     com.apple.driver.AppleMultitouchDriver (204.12.1) <29 7 6 5 4 3 1>
  142    1 0xf46000   0xd000     0xc000     com.apple.driver.IOBluetoothHIDDriver (2.3.1f4) <71 29 4 3>
  143    0 0xf53000   0x9000     0x8000     com.apple.driver.AppleBluetoothMultitouch (51.2) <142 141 71 29 5 4 3>
  144    0 0x78b9a000 0x14000    0x13000    com.google.filesystems.fusefs (2.1.5) <7 5 4 3 1>
  145    0 0x723ed000 0xb000     0xa000     com.apple.iokit.IOUSBMassStorageClass (2.6.1) <52 31 17 5 4 3 1>
  146    0 0x78e15000 0x18000    0x17000    com.apple.iokit.IOSCSIBlockCommandsDevice (2.6.2) <52 17 5 4 3 1>

Changed 4 years ago by simonvwade

Changed 4 years ago by simonvwade

Changed 4 years ago by simonvwade

comment:23 Changed 4 years ago by simonvwade

I just noticed that my Apple iSight is being automatically selected in the USB Devices menu. In the settings for the virtual machine under Ports > USB > USB Device Filters > "Apple Inc. Built-In iSight [1045]" is checked

comment:24 Changed 3 years ago by vineeth

Tried installing VBox 4.0.4 Gave the same error. Now any version is giving the error.

comment:25 Changed 3 years ago by pfudd

I just bought a brand new MacPro5,1 with SnowLeopard (10.6.8), logged in as root, and tried installing VBox 4.0.12-72916-OSX.dmg. Virtualbox was installed successfully, but the installer claimed that the install failed!

I guess the postflight script returned an error of some kind.

This error has occurred on every mac I've ever installed vbox on in the past year or so.

Do you think it might be time to fix this once and for all? It makes users wonder about the kwality of the programming in the product.

Changed 3 years ago by pfudd

grep -i vbox /var/log/*log

comment:26 Changed 3 years ago by pfudd

I see the problem: logging in as root causes the postflight script to not identify the current user, and so when it runs 'sudo' to register file extensions, it dies with 'unknown user'.

comment:27 Changed 3 years ago by poetzsch

What is the reason to install VirtualBox as root? This is not necessary.

comment:28 Changed 3 years ago by pfudd

We install all software as root, and then prevent users from changing it. This may be considered a corner case.

comment:29 Changed 3 years ago by poetzsch

I fixed the root install problem, although the rest of the ticked is about different installation problems (unloading the driver), which I still can't reproduce.

comment:30 Changed 9 months ago by MiSchi

I still have this problem and the work around of rebooting is a nuisance. This is the log of exectuing the uninstall tool:

michael% /Volumes/VirtualBox/VirtualBox_Uninstall.tool ; exit;

Welcome to the VirtualBox uninstaller script.

And the following KEXTs will be unloaded:

org.virtualbox.kext.VBoxUSB org.virtualbox.kext.VBoxDrv

Do you wish to uninstall VirtualBox (Yes/No)? yes

The uninstallation processes requires administrative privileges because some of the installed files cannot be removed by a normal user. You may be prompted for your password now...

unloading org.virtualbox.kext.VBoxUSB Please enter michael's password (unloading org.virtualbox.kext.VBoxUSB): (kernel) Can't unload kext org.virtualbox.kext.VBoxUSB; classes have instances: (kernel) Kext org.virtualbox.kext.VBoxUSB class org_virtualbox_VBoxUSB has 1 instance. (kernel) Kext org.virtualbox.kext.VBoxUSB class org_virtualbox_VBoxUSBClient has 1 instance. Failed to unload org.virtualbox.kext.VBoxUSB - (libkern/kext) kext is in use or retained (cannot unload). An error occurred durning 'sudo /sbin/kextunload -m org.virtualbox.kext.VBoxUSB', there should be a message above. (rc=3) unloading org.virtualbox.kext.VBoxDrv Failed to unload org.virtualbox.kext.VBoxDrv - (libkern/kext) kext is in use or retained (cannot unload). An error occurred durning 'sudo /sbin/kextunload -m org.virtualbox.kext.VBoxDrv', there should be a message above. (rc=3) Failed to unload one or more KEXTs, please reboot the machine to complete the uninstall. logout

i am not sure, whether you can get something out of this:

michael% kextstat -b org.virtualbox.kext.VBoxUSB Index Refs Address Size Wired Name (Version) <Linked Against>

132 0 0x492ac000 0x7000 0x6000 org.virtualbox.kext.VBoxUSB (4.2.14) <131 41 34 7 5 4 3 1>

michael% kextstat -b org.virtualbox.kext.VBoxDrv Index Refs Address Size Wired Name (Version) <Linked Against>

131 1 0x59f4e000 0x37000 0x36000 org.virtualbox.kext.VBoxDrv (4.2.14) <7 5 4 3 1>

I checked with ps and the Activity monitor for VBox related tasks, but there are none. Since there is no process running, maybe the extension is retained, whatever that means.

Version 0, edited 9 months ago by MiSchi (next)

comment:31 Changed 9 months ago by simonvwade2

I can confirm that this is no longer an issue for me.

comment:32 Changed 9 months ago by frank

  • Description modified (diff)

MiSchi, which did you really check that no VBox processes are running? Not only VirtualBox but also VBoxHeadless, VBoxNetDHCP and such like (actually all processes with 'VBox' prefix).

comment:33 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No further response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use