VirtualBox

Ticket #1573 (closed defect: fixed)

Opened 6 years ago

Last modified 3 years ago

Ubuntu Hardy: VirtualBox resume causes system reboot (host)

Reported by: cdukes Owned by:
Priority: major Component: host support
Version: VirtualBox 1.6.0 Keywords: reboot
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

On 4 separate occasions now, VirtualBox crashed after doing a resume of a saved session and it causes my host (Ubuntu Hardy) to reboot without warning. I'm not sure what's causing it, but in each case, after the host reloads and I try to start the VirtualBox guest (Windows XP), I get an error stating that the host is inaccessible with a message of:

Could not load the settings file '/home/cdukes/.VirtualBox/Machines/XPSP3/XPSP3.xml'.
Premature end of data in tag VirtualBox line 3.
Location: '/home/cdukes/.VirtualBox/Machines/XPSP3/XPSP3.xml', line 65 (3), column 49.

Result Code: 
0x80004005
Component: 
VirtualBox
Interface: 
IVirtualBox {2d3b9ea7-25f5-4f07-a8e1-7dd7e0dcf667}

When I look at that file, it looks like the file is truncated. The only option I have is to delete the host and recreate it using the the same virtual disk.

VirtualBox seemed so much more stable in v1.5x, what happened?

Attachments

XPSP3.xml Download (3.2 KB) - added by cdukes 6 years ago.
XPSP3.xml - the truncated file
VBox.log Download (28.2 KB) - added by cdukes 6 years ago.
VirtualBox Log file (note the odd binary data at the end)
XPSP3.crashed.tgz Download (28.2 KB) - added by cdukes 6 years ago.
Here's a tar of the whole directory in case you need it.
VBox.log.1 Download (42.3 KB) - added by mmarano 6 years ago.
Logs for crash after starting from saved state.
VBox.log.2 Download (49.2 KB) - added by mmarano 6 years ago.
Logs for crash after starting from saved state.
utopia.xml Download (5.7 KB) - added by mmarano 6 years ago.
the broken machine configuration file
bszente_vbox_logs.zip Download (32.7 KB) - added by bszente 5 years ago.
VirtualBox 2.1.4 log files

Change History

Changed 6 years ago by cdukes

XPSP3.xml - the truncated file

Changed 6 years ago by cdukes

VirtualBox Log file (note the odd binary data at the end)

comment:1 Changed 6 years ago by cdukes

I attached the log file, but it cuts off the binary data at the end of the log file from where it crashed. So the last line of text is: 00:00:06.892 Changing the VM state from 'CREATED' to 'LOADING'. Followed by several lines of unreadable binary data.

Changed 6 years ago by cdukes

Here's a tar of the whole directory in case you need it.

comment:2 Changed 6 years ago by frank

  • Description modified (diff)

comment:3 follow-up: ↓ 4 Changed 6 years ago by frank

All that sounds strange as no hardware virtualization is involved.

  • So this is a regression for you, that is, you never experienced this behavior with VBox 1.5.6?
  • How easy is it for you to reproduce this spontaneous reboot?
  • Does it only occur if you resume from a saved state or as well if you start a VM?
  • Which host kernel version are you using?
  • Are there any messages in the host log files after your host rebooted?
  • Could you try if switching the network adapter to PCNet improves things for you?

The binary data at the end of the log file are most probably a result of the spontaneous reboot (the file was not completely written yet).

comment:4 in reply to: ↑ 3 Changed 6 years ago by cdukes

Replying to frank:

All that sounds strange as no hardware virtualization is involved.

  • So this is a regression for you, that is, you never experienced this behavior with VBox 1.5.6?

1.5.6 worked well - I moved to 1.6 for the USB 2.0 support.

  • How easy is it for you to reproduce this spontaneous reboot?

It seems sporadic at this point. I'll let you know if I figure out how to recreate it. I also had a bluescreen in the windows host this morning after I tried to resize the guest. Not sure if it's related, but so far the whole thing just seems extremely volatile.

  • Does it only occur if you resume from a saved state or as well if you start a VM?

So far, yes

  • Which host kernel version are you using?

Ubuntu Hardy

Linux cdukes-lnx 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/
  • Are there any messages in the host log files after your host rebooted?

Nothing of value

  • Could you try if switching the network adapter to PCNet improves things for you?

I've tried both - was on PCNet originally

The binary data at the end of the log file are most probably a result of the spontaneous reboot (the file was not completely written yet).

Makes sense...

I'm considering going back to either 1.5.6 or VMWare.

I've also been wondering if these problems are possibly related more to Hardy so I'm thinking about reverting back to Gutsy. This sure is frustrating :-)

comment:5 Changed 6 years ago by frank

  • Component changed from other to host support

comment:6 Changed 6 years ago by vitrex

Same Error here, Thinkpad T43p Ubuntu Hardy with VirtualBox 1.6.6 restarts without warning after resuming Windows XP as guest system. Should I trie VB 2.0? Everithing else works fine.

comment:7 Changed 6 years ago by mmarano

I recently installed virtualbox 1.6.4 on my Macbook Pro running OS X 10.5.5 on a 2.6 GHz Core 2 Duo. I got my Ubuntu Hardy guest image all setup, configured, updated, and was installing the apps I need. I did my first "save state" on the guest when stopping it to quit. When I restarted the guest next day, it crashed my mac (kindly hold down the power button). I just attempted to start it up again since am now gettting the following message:

Could not load the settings file '/Users/mmarano/Library/VirtualBox/Machines/utopia/utopia.xml'.
Premature end of data in tag VirtualBox line 3.
Location: '/Users/mmarano/Library/VirtualBox/Machines/utopia/utopia.xml', line 117 (3), column 3.


Result Code: 
0x80004005
Component: 
VirtualBox
Interface: 
IVirtualBox {2d3b9ea7-25f5-4f07-a8e1-7dd7e0dcf667}

I'm admittedly haven't tried to troubleshoot much, as I just found this thread when googling for my solution, but figured I should post my experience since it sounds related (restarting the guest from a saved state). I'll attach my log and config as it stands. I'm new to virtualbox so I don't know how to troubleshoot everything yet. I'll probalby rebuild my guest machine based upon the existing vdi and hope that works.

Changed 6 years ago by mmarano

Logs for crash after starting from saved state.

Changed 6 years ago by mmarano

Logs for crash after starting from saved state.

Changed 6 years ago by mmarano

the broken machine configuration file

comment:8 follow-up: ↓ 9 Changed 5 years ago by bszente

I can confirm this behavior with VirtualBox 2.1.4. Let me describe my scenario:

  • I installed long time ago VirtualBox 1.3.8 on my Gentoo host, and Windows XP as guest;
  • It worked very stable over 2 years, I used it heavily without any problem. I did not upgrade neither my system nor the computer;
  • Last week I made a major upgrade: I changed the computer and I upgraded my Gentoo and with it VirtualBox too;
  • The new VirtualBox version (2.1.4) converted my old profile and that old XP guest machine to the new version without any problem;
  • VirtualBox works ok, but I experience random reboots of the host machine when I resume a snapshot.

The problem:

  • I tried to find a logic or a pattern in the occurence of reboots, and I can say that it happens around every third time when I resume the snapshot;
  • Sometimes the XML files get corrupted, sometimes not;
  • When the reboot occurs, no entries are written in the kernel logs and the machine log stops on the same place every time, before the following line: DevPcBios: ATA LUN#0 LCHS=...;
  • I looked to the logs of cdukes, and they are quite similar: his logs end also around this DevPcBios line.

My preliminary conclusion:

  • These logs have one thing in common: they stop at DevPcBios point;
  • Each of us has PIIX3 ATA: LUN#0: disk, PCHS=*/16/63 which gets translated to DevPcBios: ATA LUN#0 LCHS=*/128/63 or */255/63 (it might be just a normal behavior, but I don't know);
  • My presumption is that something regarding to the disk access in the VirtualBox BIOS has been changed with makes it incompatible with older VDI images. However I don't see why this would cause the reboot of the host machine, so it should be related also to the kernel module too;
  • I will try make a fresh new XP guest, with a new VDI disk, and to see whether those PCHS/LCHS values will change and the reboots will occur or not.

You may find my log files in the attached bszente_vbox_logs.zip archive.

Changed 5 years ago by bszente

VirtualBox 2.1.4 log files

comment:9 in reply to: ↑ 8 Changed 5 years ago by bszente

Replying to bszente:

  • I will try make a fresh new XP guest, with a new VDI disk, and to see whether those PCHS/LCHS values will change and the reboots will occur or not.

I made a fresh new XP guest from zero, I made a new VDI file, etc. The problem is not manifesting anymore. Probably it was some incompatibility issue between my old VDI image and the new VirtualBox.

comment:10 Changed 5 years ago by cdukes

How do I unsubscribe from this ticket?

comment:11 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be finally fixed in VBox 3.1.4. Happenend only if VT-x/AMD-V are not enabled for that VM.

comment:12 Changed 4 years ago by olau

  • Status changed from closed to reopened
  • Resolution fixed deleted

We've just had the same kind of crashes. With 3.1.4. Tried to upgrade to 3.1.8. Same problem. Nothing in the kernel log. It has now become very reproducible, it reboots a minute or so after the guest is started.

So I don't think this problem has been fixed. I think we'll try to recreate our guests and see if that helps.

comment:13 Changed 4 years ago by olau

Also we're on Debian testing, kernel is 2.6.32 (but it happened on 2.6.26 too).

comment:14 Changed 4 years ago by olau

Recreating the guests seems to have helped.

comment:15 Changed 4 years ago by olau

Actually, it happened again with recreated guests.

comment:16 Changed 3 years ago by frank

Still relevant with VBox 4.0.4?

comment:17 Changed 3 years ago by olau

Hi! Sorry for not getting back. I think this eventually turned out to be some sort of compatibility problem. We uninstalled the official VirtualBox packages we'd gotten from this site, and instead installed the open source ones included in Debian and haven't had the problem since.

I'm really apologize for the extranous spam on this bug, I think you can close it again.

comment:18 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use