VirtualBox

Ticket #15726 (closed defect: fixed)

Opened 16 months ago

Last modified 15 months ago

VirtualBox Manager crash on exit

Reported by: mhanor Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Hello,

I can reproduce a crash of the VirtualBox Manager, under my Windows 10 64 bit host. It seems it crashes when I close the Manager window, after I've started a VM using the Manager. I'm sending Frank an e-mail with a Google Drive link to a full memory crash dump of VirtualBox-5.1.3-109189-Win. I can also reproduce it with the 5.1.2 release, the crash looks identical.

Attachments

windbg_log.txt Download (24.6 KB) - added by mhanor 15 months ago.
VirtualBox OSE 5.1.4 no hardening

Change History

comment:1 Changed 15 months ago by frank

Just wanted to let you know that we downloaded and analyzed the dump you provided us, thank you! It looks like VBoxProxyStub is unloaded too early. At the moment we don't know why.

comment:2 Changed 15 months ago by frank

Unfortunately we are not able to reproduce. Maybe some different host configuration ...

comment:3 Changed 15 months ago by mhanor

Open the VirtualBox Manager, create and start an empty VM (no boot medium), wait for it to show you the "Fatal: no bootable medium found!" message and close the Manager. You can open the Manager again, for another attempt, without disturbing the VM. For me, it crashes almost every time.

Changed 15 months ago by mhanor

VirtualBox OSE 5.1.4 no hardening

comment:4 Changed 15 months ago by mhanor

I've attached a windbg log, showing the access after unloading of VBoxProxyStub.

comment:5 Changed 15 months ago by frank

Mihai, we think we fixed the crash -- the fix is actually more a hack but it should work for now. Could you test the latest test build from here? Your reproduction scenario was very helpful, thanks!

comment:6 Changed 15 months ago by mhanor

I'm not able to trigger a crash with the new test build.

comment:7 Changed 15 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use